ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

2910al Trunking and STP

CraigS1
Occasional Advisor

2910al Trunking and STP

I recently upgraded a portion of my network from 3400cl switches to 2910al switches.  Two of the 3400cl switches in separate buildings were connected together via TWO 10-gigabit links in a trunked configuration.  (No problems at all over many years.)  However, when I try to duplicate this configuration on the 2910al switches, one of the two 10-gigabit links gets disabled by spanning tree.  I have enabled spanning tree on all switches, and set my core switch as priority 0.  The logs show that port B1 is blocked by spanning tree, and then disabled.  (Interestingly, it appears to alternate between B1 and B2, but every time I look at the switch itself, I only see B1 getting disabled.)  Any ideas?

Thank you.

 

5 REPLIES
CraigS1
Occasional Advisor

Re: 2910al Trunking and STP

The more I think about this, the more I suspect a firmware bug.  (I reported other 2910al firmware bugs last year that have yet to be addressed or even acknowledged:  http://community.hpe.com/t5/ProCurve-ProVision-Based/2910al-Firmware-Bugs/m-p/6759931 )

Copper trunks seem to work fine, but fiber trunks do NOT seem to be seen as one logical path by STP.  (Otherwise, why would STP disable ONE link in a trunk?)

Is there newer firmware available for the 2910al switches?  I'm running W.15.14.0012 now, but that's almost a year old.

 

16again
Respected Contributor

Re: 2910al Trunking and STP

Did you use show commands, to verify if trunking of ports is working fine?   If trunk isn't fully functional, it's just STP coming to the rescue in preventing a loop.
What's config?

CraigS1
Occasional Advisor

Re: 2910al Trunking and STP

Yes, I verified that trunking was configured properly:

HP-2910al-211# show trunks

Load Balancing

Port | Name Type | Group Type
---- + -------------------------------- --------- + ----- --------
13 | 100/1000T | Trk13 Trunk
14 | 100/1000T | Trk13 Trunk
15 | 100/1000T | Trk13 Trunk
16 | 100/1000T | Trk13 Trunk
17 | 100/1000T | Trk17 Trunk
18 | 100/1000T | Trk17 Trunk
19 | 100/1000T | Trk17 Trunk
20 | 100/1000T | Trk17 Trunk
21 | 100/1000T | Trk21 Trunk
22 | 100/1000T | Trk21 Trunk
23 | 100/1000T | Trk21 Trunk
24 | 100/1000T | Trk21 Trunk
B1 | SFP+SR | Trk51 Trunk
B2 | SFP+SR | Trk51 Trunk

 

And the switch on the other end:

HP-2910al-212# show trunks

Load Balancing

Port | Name Type | Group Type
---- + -------------------------------- --------- + ----- --------
45 | 100/1000T | Trk45 Trunk
46 | 100/1000T | Trk45 Trunk
47 | 100/1000T | Trk45 Trunk
48 | 100/1000T | Trk45 Trunk
B1 | SFP+SR | Trk51 Trunk
B2 | SFP+SR | Trk51 Trunk

 

B1 and B2 are the fiber links between the two switches.  (These are the ONLY direct paths available between these two switches.)

CraigS1
Occasional Advisor

Re: 2910al Trunking and STP

The event logs show this:

I 03/27/16 08:13:49 00077 ports: port B2 in Trk51 is now off-line
I 03/27/16 08:14:28 00435 ports: port B2 is Blocked by STP
I 03/27/16 08:14:28 00076 ports: port B2 in Trk51 is now on-line
I 03/27/16 08:15:01 00077 ports: port B1 in Trk51 is now off-line
I 03/27/16 08:15:28 00435 ports: port B1 is Blocked by STP
I 03/27/16 08:15:28 00076 ports: port B1 in Trk51 is now on-line
I 03/27/16 08:15:28 00077 ports: port B1 in Trk51 is now off-line

In a trunk, STP shouldn't be disabling a single logical path.  (And yet it is...)  It's as if trunking isn't working properly with this firmware.

CraigS1
Occasional Advisor

Re: 2910al Trunking and STP

Core switch config:  (Switch on other end of fiber has a virtually identical config, except for a different name, IP, and spanning-tree priority is not set to 0.)

HP-2910al-211# show config

Startup configuration:

; J9145A Configuration Editor; Created on release #W.15.14.0012
; Ver #06:04.18.63.ff.35.05:b6
hostname "HP-2910al-211"
module 1 type j9145a
module 2 type j9008a
module 3 type j9008a
trunk 13-16 trk13 trunk
trunk 17-20 trk17 trunk
trunk 21-24 trk21 trunk
trunk B1-B2 trk51 trunk
timesync sntp
sntp unicast
sntp server priority 1 172.20.2.1
time daylight-time-rule continental-us-and-canada
time timezone -360
ip default-gateway 172.20.1.1
interface 9
name "Iso"
exit
interface 10
name "Iso"
exit
interface 11
name "SP"
exit
interface 12
name "SP"
exit
snmp-server community "public" unrestricted
snmp-server host 172.20.2.31 community "public"
vlan 1
name "DEFAULT_VLAN"
no untagged 9-12
untagged 1-8,A1-A2,Trk13,Trk17,Trk21,Trk51
ip address 172.20.230.211 255.255.0.0
exit
vlan 5
name "SP"
untagged 11-12
tagged Trk13,Trk17,Trk21,Trk51
no ip address
exit
vlan 9
name "Iso"
untagged 9-10
tagged Trk13,Trk17,Trk21,Trk51
no ip address
exit
vlan 10
name "VG"
tagged 11-12,Trk13,Trk17,Trk21,Trk51
no ip address
exit
vlan 20
name "VS"
tagged 11-12,Trk13,Trk17,Trk21,Trk51
no ip address
exit
vlan 30
name "VC"
tagged 11-12,Trk13,Trk17,Trk21,Trk51
no ip address
exit
vlan 40
name "VPC"
tagged 11-12,Trk13,Trk17,Trk21,Trk51
no ip address
exit
spanning-tree
spanning-tree Trk13 priority 4
spanning-tree Trk17 priority 4
spanning-tree Trk21 priority 4
spanning-tree Trk51 priority 4
spanning-tree priority 0
no tftp server
no autorun
no dhcp config-file-update