ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

5406zl vlan routing problem

SOLVED
Go to solution
awall
Occasional Contributor

5406zl vlan routing problem

I'm starting to set up a lab, but I can't seem to get traffic to/from this switch.

I'm going out to a cisco 3750.  3750 router has a vlan with an ip of 192.168.60.254

What am I missing?

Here's my config:

 

Running configuration:

; J8697A Configuration Editor; Created on release #K.15.16.0008
hostname "Lab_switch"
module 1 type j8702a
module 2 type j8702a
no timesync
time daylight-time-rule continental-us-and-canada
time timezone -420
ip route 0.0.0.0 0.0.0.0 192.168.60.254
ip routing
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged A1,A13-A24,B1-B24
untagged A2-A12
no ip address
exit
vlan 10
name "VLAN10"
untagged A13-A24
ip address 10.0.10.1 255.255.255.0
exit
vlan 20
name "VLAN20"
untagged B1-B12
ip address 10.0.20.1 255.255.255.0
exit
vlan 30
name "VLAN30"
untagged B13-B24
ip address 10.0.30.1 255.255.255.0
exit
vlan 40
name "VLAN40"
tagged A1

ip address 192.168.60.158 255.255.255.0
exit
no spanning-tree bpdu-throttle

 

I've tried configuring A1 as tagged, and also as untagged on both sides, but I'm not able to hit anything outside the switch from VLAN 10, 20, or 30.

I can ping between VLANs 10, 20,30, and 40, but can't make that next hop (192.168.60.254) out to the 3750.

Computers on each of the VLANs have the VLAN IP address as the default gateway and are connected to their repective VLAN interfaces.

 

Thanks

Tony

 

4 REPLIES
Vince-Whirlwind
Honored Contributor

Re: 5406zl vlan routing problem

Does the 3750 have routes telling it where the 10.0.0.0/16 network is?

Emil_Gogushev
Trusted Contributor
Solution

Re: 5406zl vlan routing problem

Hello,

 

My suspect is that the Cisco router may not know how to route back to the ranges 10.0.10.0/24, 10.0.20.0/24 and 10.0.30.0/24. So the ping may reach the Cisco router but it doesnt know how to route the response back.

The router will have a connected route to range 192.168.60.0/24 in the routing table because it has an interface in this range.  However in order for the ranges 10.0.10.0/24, 10.0.20.0/24 and 10.0.30.0/24 to appear in the routing table a static route has to be configured pointing to the IP 192.168.60.158 as next hop.

 

ip route 10.0.10.0 255.255.255.0 192.168.60.158

ip route 10.0.20.0 255.255.255.0 192.168.60.158

ip route 10.0.30.0 255.255.255.0 192.168.60.158

 

(You can configure a single static route with shorter mask if there are no other subnets in the 10.0.x.x range on other routers)

 

So please check in the routing table of the Cisco whether there are routes for this ranges and what is the next hop. If not try to configure the static routes. Another option would be to enable a routing protocol on both 5406zl and Cisco.

 

 

 

Emil /HPN
awall
Occasional Contributor

Re: 5406zl vlan routing problem

Wow, I feel like an idiot! Can't believe I missed such a basic item.

That was the problem, but now I'm having a different issue.

 

I have pings running from both sides (host 192.168.60.50 on Cisco switch pinging host 10.0.10.100 on the HP switch and vice versa). Those pings are fine, maybe one time out every several minutes, but running continuous for the last couple hours.

 

I also have pings running from host 10.0.10.100 to the Cisco switch vlan 192.168.60.254. Those pings will reply for a random length of time, 10 seconds to 10+ minutes (and I have internet access from 10.0.10.100), then they'll start timing out and I have no traffic flow, (except for the pings that are still going between the 192.168.60.50 and 10.0.10.100 hosts).

Affer a couple minutes, it might reply for 2 or 3 pings, then stop, then maybe after 10 minutes, it will start replying again for 30 sec, then stop. It seems really random.

I can access the HP switch GUI from 192.168.60.50 host.

While this is going on, in the HP switch console session (PuTTY), I can ping to 192.168.60.50, but not to the Cisco router vlan 192.168.60.254.

If I disable and re-enable the interface on either switch, it will come back up, but then stop at some point.

HP and Cisco switch logs don't show anything unusual.

 

 

awall
Occasional Contributor

Re: 5406zl vlan routing problem

It certainly is a Monday!! Somebody had a duplicate IP of my VLAN on the HP switch (192.168.60.158).

Changed that and the routes, and everything is happy.

 

Thanks for your help!