ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot get IP address on Voice Vlan

SOLVED
Go to solution
vegasjoe
Visitor

Cannot get IP address on Voice Vlan

The voip phones are working in the Main office. I am trying to get a voip phone to office B. I am not getting an ip address from the DHCP server on vlan 24. I can get ip addresses from from the other vlans 4, and 12.

 

Main -> Office A -> Office B

 

The DHCP server is in the main office.  Office A connects to the Main switch.  Office B connects to the switch in office A using port 42. Office B switch port 8 is for the phones.   

 

In Office A, I temporarly set an ip helper-address on the vlan 24 to 10.100.4.50 (DHCP). But this did not help.

 

How do I diagnose this problem? any hints on where the issue may be?

 

Thanks, 

 

Office B switch config

; J9774A Configuration Editor; Created on release #YA.15.12.0015
; Ver #05:08.41.ff.37.27:a3

ip route 0.0.0.0 0.0.0.0 10.105.4.1
snmp-server community "public" unrestricted

vlan 1
name "DEFAULT_VLAN"
no untagged 1-10
no ip address
exit
vlan 4
name "SERVER"
untagged 2,7
ip address 10.104.4.3 255.255.252.0
exit
vlan 8
name "TEACHER"
untagged 1
tagged 7
no ip address
exit
vlan 12
name "STUDENT"
untagged 3-6,9-10
tagged 7
no ip address
exit
vlan 16
name "TEACHER_WIFI"
tagged 7
no ip address
exit
vlan 20
name "STUDENT-WIFI"
tagged 7
no ip address
exit
vlan 24
name "AVAYA"
untagged 8
tagged 7
no ip address
exit
primary-vlan 4
password manager
password operator

 

Office A - passthrough


SN MAC Address System Name Device Type Status
-- ------------- ------------- -------------------- -------------------------
0 c8cbb8-dabf40 LCSD-LCHS-0 HP 2910al-48G-PoE Commander Up
1 c8cbb8-db4ec0 LCSD-LCHS01 HP 2910al-48G-PoE Member Up

Running configuration:

; J9148A Configuration Editor; Created on release #W.15.14.0007
; Ver #05:18.63.ff.35.05:b1
hostname "LCSD-LCHS-0"
module 1 type j9148a
module 2 type j9165a
module 3 type j9008a
power-over-ethernet pre-std-detect ports 1-48
stack commander "LCHS"
stack auto-grab
stack member 1 mac-address c8cbb8-db4ec0
ip route 0.0.0.0 0.0.0.0 10.150.1.5
ip routing
interface 6
poe-allocate-by value
poe-value 33
exit
interface 33
poe-allocate-by value
poe-value 33
exit
snmp-server community "lcsd-snmp" operator

router rip
no auto-summary
redistribute connected
enable
exit
vlan 1
name "NOTUSED"
no untagged 1-48,A1
untagged A2,B1-B2
no ip address
exit
vlan 4
name "ServersEquip"
untagged 1-2,42,A1
ip address 10.105.4.1 255.255.252.0
ip helper-address 10.100.4.50
ip rip 10.105.4.1
exit
vlan 8
name "TEACHER-DATA"
untagged 6-10,13,15,18,22-23,29
tagged 42,A1
ip address 10.105.8.1 255.255.252.0
ip helper-address 10.100.4.50
ip rip 10.105.8.1
exit
vlan 12
name "StudentData"
untagged 3-5,11-12,14,16,19-21,24-28,30,32,34-41,43-47
tagged 42,A1
ip address 10.105.12.1 255.255.252.0
ip helper-address 10.100.4.50
ip rip 10.105.12.1
exit
vlan 16
name "TEACHER-WIFI"
tagged 17,31,33,42,A1
ip address 10.105.16.1 255.255.252.0
ip helper-address 10.100.4.50
ip rip 10.105.16.1
exit
vlan 20
name "STUDENT-WIFI"
untagged 17,31,33
tagged 42,A1
ip address 10.105.20.1 255.255.252.0
ip helper-address 10.100.4.50
ip rip 10.105.20.1
exit
vlan 24
name "AVAYA"
tagged 42,A1
ip address 10.105.24.1 255.255.252.0
ip helper-address 10.100.24.10
ip rip 10.105.24.1
exit
vlan 50
name "NSHEWAN"
untagged 48
ip address 10.150.1.10 255.255.255.0
ip rip 10.150.1.10
exit
vlan 160
name "VLAN160"
tagged A1
ip address 10.10.16.1 255.255.255.0
exit
primary-vlan 4
no tftp server
no autorun
no dhcp config-file-update
password manager
password operator

 

Main Office - where phones work now

hostname "PANACA-ADMIN-SW1"
module 1 type j9727a
ip routing
interface 1
poe-allocate-by value
poe-value 33
exit
interface 2
poe-allocate-by value
poe-value 33
exit
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
exit
router rip
no auto-summary
redistribute connected
enable
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 1-24
untagged A1-A2,B1-B2
ip address dhcp-bootp
exit
vlan 4
name "SERVER"
untagged 3-24
ip address 10.100.4.2 255.255.252.0
ip helper-address 10.100.4.50
ip rip 10.100.4.2
exit
vlan 16
name "ADMIN-WIFI"
untagged 1-2
tagged 22
no ip address
ip helper-address 10.100.4.50
exit
vlan 24
name "AVAYA"
tagged 3-22
no ip address
ip helper-address 10.100.24.10
exit
vlan 28
name "GUEST-WIFI"
tagged 1-2,22
no ip address
ip helper-address 10.100.4.50
exit
primary-vlan 4
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator

1 REPLY
vegasjoe
Visitor
Solution

Re: Cannot get IP address on Voice Vlan

It seems that the problem was the VOIP server DHCP scope was set correctly.