Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 2530 DHCP issue

Wrath55
Visitor

HP 2530 DHCP issue

I'm new to the managed HP networking world so have some patience with me please.

So here is my setup...

I have a main switch (2530) in one part of the building  and 3 other switches (2530) setup in a ring topology in another part of the building.  I have 2 fiber cables run from the main switch to one of the three other switches on ports 51 and 52.  Both of these cables are setup as a trunk carrying 2 vlans, vlan 10 and vlan 200.  Both vlans are connected to a DHCP server to provide IP addresses to whatever devices that connects to that lan.  For what ever reason the vlan that works correctly is vlan 10.  An IP cannot be pull from the vlan 200 dhcp server.  I can set a static ip and it works.  Any help and or suggestions for this newbie would be much appreciated.

See running config below.

 

Main Switch

Running configuration:

; J9775A Configuration Editor; Created on release #YA.15.12.0015
; Ver #05:08.41.ff.37.27:a3
hostname "NETWORK-SWITCH-1"
trunk 51-52 trk1 lacp
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-48
untagged 49-50,Trk1
ip address dhcp-bootp
exit
vlan 10
name "VLAN10"
untagged 1-24
tagged Trk1
ip address 10.100.10.230 255.255.0.0
exit
vlan 200
name "VLAN200"
untagged 25-48
tagged Trk1
no ip address
exit
primary-vlan 10
spanning-tree
spanning-tree Trk1 priority 1
spanning-tree instance 1 vlan 10 200
spanning-tree instance 1 Trk1 priority 4
no tftp server
no dhcp config-file-update

 

First switch in ring topology

Running configuration:

; J9775A Configuration Editor; Created on release #YA.15.12.0015
; Ver #05:08.41.ff.37.27:a3
hostname "NETWORK-SWITCH-2"
trunk 51-52 trk1 lacp
trunk 50 trk2 trunk
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-48
untagged 49,Trk1-Trk2
ip address dhcp-bootp
exit
vlan 10
name "VLAN10"
untagged 1-24
tagged 49,Trk1-Trk2
ip address 10.100.10.231 255.255.0.0
exit
vlan 200
name "VLAN200"
untagged 25-48
tagged 49,Trk1-Trk2
no ip address
exit
primary-vlan 10
spanning-tree
spanning-tree Trk1 priority 2
spanning-tree Trk2 priority 3
no tftp server
no dhcp config-file-update

 

Second Switch

Running configuration:

; J9775A Configuration Editor; Created on release #YA.15.12.0015
; Ver #05:08.41.ff.37.27:a3
hostname "NETWORK-SWITCH-3"
trunk 50 trk2 trunk
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-48
untagged 49,51-52,Trk2
ip address dhcp-bootp
exit
vlan 10
name "VLAN10"
untagged 1-24
tagged 49,Trk2
ip address 10.100.10.232 255.255.0.0
exit
vlan 200
name "VLAN200"
untagged 25-48
tagged 49,Trk2
no ip address
exit
primary-vlan 10
spanning-tree
spanning-tree Trk2 priority 4
no tftp server
no dhcp config-file-update

Third Switch

Running configuration:

; J9775A Configuration Editor; Created on release #YA.15.12.0015
; Ver #05:08.41.ff.37.27:a3
hostname "NETWORK-SWITCH-4"
trunk 50 trk2 trunk
snmp-server community "public" unrestricted
vlan 1
name "DEFAULT_VLAN"
no untagged 1-48
untagged 49,51-52,Trk2
ip address dhcp-bootp
exit
vlan 10
name "VLAN10"
untagged 1-24
tagged 49,Trk2
ip address 10.100.10.233 255.255.0.0
exit
vlan 200
name "VLAN200"
untagged 25-48
tagged 49,Trk2
no ip address
exit
primary-vlan 10
spanning-tree
spanning-tree Trk2 priority 4
no tftp server
no dhcp config-file-update

4 REPLIES
TerjeAFK
Respected Contributor

Re: HP 2530 DHCP issue

Do you have the same problem on the main switch, ie. if you connect a laptop to port 25 on the main switch (untagged in vlan 200) you do not get a DHCP address? Do you have DHCP snooping configured on any of the switches? Can you see any relevant log entries on the switch when you connect a client and it does not get a DHCP address?

16again
Respected Contributor

Re: HP 2530 DHCP issue

Without dhcp relay, make sure the dhcp server has an interface (=IP address) in every VLAN  requiring DHCP. 

Wrath55
Visitor

Re: HP 2530 DHCP issue

TerjeAFK

You would be correct.  DHCP is not working on the main switch either for VLAN 200.  I'm not quite sure what you mean about DHCP snooping.  Can you explain?  I do not see any log entires about client connects.

Thanks for your patience

Wrath55
Visitor

Re: HP 2530 DHCP issue

16again

The DHCP server has an ip address. (192.168.200.5).  How would I go about setting up a DHCP relay?

Thanks for your patience