ProCurve / ProVision-Based
Showing results for 
Search instead for 
Do you mean 

How to assign a port to two different Vlans (voice and data)

Occasional Advisor

How to assign a port to two different Vlans (voice and data)

Guys i need your help regarding a small issue i am facing.

 

i want to assign each single port on my edge switches to two different vlans, one for voice traffic and the other for data.

each has it's own Vlan.

 

The IP phone will be connected to the node in the wall and the PC will be connected to the other port of the IP phone.

 

On Cisco switches, it can be implemented as the following :

 

interface FastEthernet0/1-8

description HQ-SW-2 ===> IP Phone and PC

switchport access vlan 11

switchport mode access

switchport voice vlan 12

spanning-tree portfast

 

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

switchport trunk allowed vlan 10-12

!

 

 

 

interface Vlan10

ip address 10.110.1.3 255.255.255.0

 

the vlan 11 is for data and vlan 12 for IP phones.Vlan 10 will be connected to the gateway device which is the router or the firewall.

please guide me if i can do the same on the interfaces  as Cisco can do on  their switches.

 

for more details about this please check the following link on Cisco support forums:

 

https://learningnetwork.cisco.com/thread/33173

 

your feedbacks are higly appreciated .

 

regards,

M.Amarneh

9 REPLIES

Re: How to assign a port to two different Vlans (voice and data)

Hi,

 

I assume that you want to know how it's done with Procuve switches, so this is the way:

 

Example for interface 1

 

vlan 11

vlan 12 voice

vlan 11 untagged 1

vlan 12 tagged 1

 

Hope this helps.

 

Regards,

Michael

 

 

 

Highlighted
Occasional Advisor

Re: How to assign a port to two different Vlans (voice and data)

hi Micheal,

 

Thx for your reply but i am not sure if i get it correctly, so can you please show me the exact thing should be done on the interface so i can do it??

 

regards

Occasional Advisor

Re: How to assign a port to two different Vlans (voice and data)

HP doesn't work the same way as cisco.  These configs are not done at the interface level...more so it is done on the vlan level, where you assign interfaces.

In the example from MichaelvLonden, you go into the vlan and designate one as voice:

(vlan 12 voice)

then tag interface 1

vlan 12 tagged 1

 

vlan 11 untagged 1 is used to assign  interface 1 to vlan 11 for all other traffic.

The voice traffic will be tagged (cisco speak trunked) in vlan 12.


vlan 11

vlan 12 voice

vlan 11 untagged 1

vlan 12 tagged 1


 

Re: How to assign a port to two different Vlans (voice and data)

Hi Amarneh,

 

First of all. For which model switch do you want to configure voice vlans?

Cisco, HP,....?

 

If it's HP ProCurve. the commands I posted earlies are you need to do the job.

With Cisco you enter config mode conf-if and configure a voice vlan or access vlan.

With Procurve  you enter vlan config mode and add a interface to the vlan.

 

With Cisco you add a vlan to an interface and with Procurve you add an interface to a vlan.

 

enter the following commands to enable data vlan 11 and voice vlan 12 on interface 1:

 

conf

vlan 11                                              (this creates vlan 11)

vlan 12 voice                                    (this creates vlan 12 and labels it as voice vlan)

vlan 11 untagged 1                         (interface 1 is added to the access vlan 11)

vlan 12 tagged 1                            (interface 1 is added to the voice vlan 12)

end

wr m

 

Regards,

Michael

 

 

Frequent Advisor

Re: How to assign a port to two different Vlans (voice and data)

If you are using older Cisco phones(7940,7960, etc..), you will also need to manually enter the voice VLAN to the Admin VLAN setting on the phones as well. The older phones only use Cisco Discover Protocol (CDP) to get the voice VLAN number. The newer phones will also use LLDP-MED to configure the voice VLAN. LLDP-MED is one of many open standards supported by HP.

 

HTH

Bob

Re: How to assign a port to two different Vlans (voice and data)

Bob has a good point.

With our Avaya VoIP phones is mandatory that the voice vlan name contains the word VOICE in order to let LLDP-MED  work.

I don't know if it is also mandatory for other vendors of VoIP phones.

 

Regards,

Michael

Occasional Visitor

Re: How to assign a port to two different Vlans (voice and data)

Hello sir,

please what is the difference between these two commands:

 

vlan 12 tagged 1

 

vlan 11 untagged 1

 

I know as you explain, untagged 1 add port 1 to vlan 11 but I dont know of tagged 1. Does tagged 1 also add the port to vlan 12.

 

Thanks

Occasional Visitor

Re: How to assign a port to two different Vlans (voice and data)

[ Edited ]

Bobs point for editig the admin vlan setting on the phone was spot on.  Finding that little bit of info was like discovering the needle in the haystack.  Thanks!

Occasional Visitor

Re: How to assign a port to two different Vlans (voice and data)

Hello everyone, 

I'm trying to configure HP procurve 2530 and I have a lot of issues with tagging ports for vlans and spliting voice and data. 
Here are some informations about the setup. 

I have internet going into a switch. From that switch one cable is going to a Edge device (VOIP provider gave us this device and she is able to serve as DHCP) which has static ip configuration with .1 WAN IP. Another cable from that switch is going to Firewall which also has static ip configuration with .2 WAN IP. 
Now, I have cables from Firewall and Edge device going to my HP Procurve 2530 switch. 
There I have configured two VLANs and their configuration is bellow: 

vlan 1
name "data"
tagged 21
untagged 1-20,22-28
ip address 192.168.0.5 255.255.255.0
exit


HP-2530-24G# sh run vlan 10

Running configuration:

vlan 10
name "VOICE"
tagged 1-28
ip address dhcp-bootp
qos dscp 101110
voice
exit

I want to note that I have tried several different configurations of VLAN's but I was not able to make DHCP to assign different IP addresses to the phone and the computer.. 
Also, phones are connected to a outlet and then from phone cable is going to PC. 
Any ideas? What am I doing wrong here?
I would appreciate any help or advice. 

Thanks!