ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Hyper-V and VLAN tagging

bruun
Occasional Contributor

Hyper-V and VLAN tagging

Recently bought a 3400cl procurve switch to learn and test with HP equipment. I've setup a Hyper-V server and installed server machines, in the properties of the VM i've set the following VLAN ID:
VM 1 --> vlan 10
VM 2 --> vlan 20

The cable is connected to interface 9. The connection should be able to carry multiple VLANs as i'm only using one NIC dedicated to the VM's

I've configured a VM with a static gateway matching the VLAN's IP address (192.168.4.2), however I'm not able to ping the VLAN's IP address if I tag the port. However when i untag the port in VLAN 10 i'm able to ping the VLAN's IP adres (192.168.4.2). What is going wrong?

; J4905A Configuration Editor; Created on release #M.10.104

hostname "switch01"
no web-management
web-management ssl
no telnet-server
interface 9
name "Hyper-V-VMs"
exit
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 1-24
ip address 192.168.3.2 255.255.255.0
exit
vlan 10
name "Site1"
ip address 192.168.4.2 255.255.255.0
tagged 9
exit
vlan 20
name "site2"
ip address 192.168.5.2 255.255.255.0
tagged 9
exit
ip route 0.0.0.0 0.0.0.0 192.168.3.1
ip ssh
password manager
password operator

2 REPLIES
johnk3r
Respected Contributor

Re: Hyper-V and VLAN tagging

You have configured the VLAN tags on Hyper-V?
**************************************
ATP FLEXNETWORK V3 | ACSA
bruun_2
Occasional Visitor

Re: Hyper-V and VLAN tagging

Posting from a new user account, please fix these forums as the log in doesn't work at all! Like many other things on the site!

Yes, the VLAN ID has been set at VM level. Normally it supposed to work right?