ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

LAG/LACP trunks and spanning tree on 2910al-24g

SOLVED
Go to solution
pauladam2608
Occasional Advisor

LAG/LACP trunks and spanning tree on 2910al-24g

Hi All,

Firstly I will say for the record, I come from a Cisco IOS background :)

Ive been landed in a situation where I have a set of 2 HP 2910al-24g switches with a 4 port Trunk (LAG/LACP) between them and I need to add a new VLAN to the trunk group....simple enough, however, not being that familiar with HP switches I need to get a handle on the ramifications of making changes to the trunk port and the spanning-tree settings that are associated.

The easiest thing to do is show the relevant parts of the config as a start....

trunk 21-24 trk1 trunk

interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit

spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 priority 0
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 1
spanning-tree instance 2 Trk1 priority 4

Thats everything that is relevant as far as I can see - the switches are not stacked, they are individual units, but both have the same config.

I need to add VLAN 64 to the Trk1 trunk - which of course is straightforward to do in terms of adding the "tagged Trk1" config to the vlan - but what I dont know about is adding it into the spanning-tree instances - particularly whether adding it will cause the trunk to drop and renegotiate etc.

I dont understand why there are two configured spanning tree instances either? (I didnt do the config, like I say, I have just inherited it) - is it a case that I can just add VLAN 64 to one of the instances without interruption, or should I create a new instance for my new VLAN without causing a drop? Or am I facing a drop no matter what I do? 

And before anyone says - Ive renamed the spanning-tree config name in the snippet above...but does that have any bearing in sharing of the config, or is it just an identifier, I assume all switches must have the same config name?

Any help/advice greatly appreciated.

Thanks

Paul

16 REPLIES
parnassus
Honored Contributor

Re: LAG/LACP trunks and spanning tree on 2910al-24g


pauladam2608 wrote: I dont understand why there are two configured spanning tree instances either?

Good question to starting with.

The point is it looks like it was configured exactly to prevent Spanning Tree to activate if those Switches (supposing they were the only ones involved in your scenario) have (or have had) more than one active link between them (so as they hadn't a Port Trunk configured since beginning...so active links formed a physical loop managed by MSTP with its spanning tree instances).

But then the question is: if actually really there is just a 4 ports LACP Port Trunk what's the reason for those MSTP instances?

What's about providing show lacp, show trunk and show vlan outputs? ...just to be sure about Trk1 and VLANs.

As you said adding the VLAN Id 64 to Trk1 Port Trunk is pretty straightforward...as doing:

vlan 64 tagged trk1

 

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Here's the outputs (and a some more of the background below also)

sh lacp

no LACP ports found (???)

sh trunk

Load Balancing

Port | Name Type | Group Type
---- + -------------------------------- --------- + ----- --------
21 | 100/1000T | Trk1 Trunk
22 | 100/1000T | Trk1 Trunk
23 | 100/1000T | Trk1 Trunk
24 | 100/1000T | Trk1 Trunk

sh vlan 

Status and Counters - VLAN Information

Maximum VLANs to support : 256
Primary VLAN : DEFAULT_VLAN
Management VLAN :

VLAN ID Name | Status Voice Jumbo
------- -------------------------------- + ---------- ----- -----
1 DEFAULT_VLAN | Port-based No No
10 vMotion | Port-based No No
20 iSCSI | Port-based No Yes
30 vSphere | Port-based No No
40 FaultTolerance | Port-based No No
64 HQServersNew | Port-based No No

So as you can see this is a pair (ok...so its actually two pairs! - I'll explain further below) of switches handling a lot more than it probably should be (VMware vMotion, iSCSI, FT and VM networking) - but it is what it is.... the VMware hosts are split across the two switch chassis, hence why the trunk is in place between the two - note this is not the way I would normally do this in my traditional Cisco background, it would be a stacked pair with Etherchannels for the VM networking for a start with IP hashing on the VMware vSwitches, but I dont have the luxury of being able to change all of this on a whim Im afraid - also, currently the entire LAN is residing in VLAN 1 (yes...I know - again, its inherited!) and is running on a 10.0.0.0/8 (facepalm!), so I am working towards segregating things up into seperate VLANs and stage 1 is to get the servers into their own VLAN - as you can see...VLAN 64
But hopefully, based on this, you can see why I am nervous about what may happen if I change any spanning-tree parameters on that trunk link (I was surprised to see no LACP to be honest - but there you go, thats the lack of my knowledge of the HP switch OS).

As I said its actually two pairs (probably a KEY bit of info I should have mentioned!!) - the switches each have the HP J9008A 2-port 10-GbE SFP+ module installed - the VMware environment is split into two locations within the premises.

So switches 1 and 2 are in the same location and connected with the 4 port trunk as previously mentioned and switches 3 and 4 are exactly the same, however switches 1 and 3 are connected by a 10g fibre and switches 2 and 4 are also connected by 10g fibre - hence...a BIG loop - so this is the critical bit of info regarding the spanning tree, sorry about missing that - was trying not to do an information overload in the first post :) - I've added a quick screen snip of a diagram to illustrate the connectivity

So hopefully you now see why I need to add the new VLAN into the spanning-tree config - but it comes back to the original question of will I suffer a drop in connectivity? (with iSCSI and critical VM's communicating over this, I need to be sure!)

Thanks again

Paul

parnassus
Honored Contributor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Hi Paul, now the scenario is a more complete.

No LACP because the Port Trunking(s) you have are all using the Non-Protocol Port Trunking mode instead of the LACP (IEEE 802.3ad)...things were done that way but who know what was the reason (I suspect that was used "Trunk" - No Protocol - as Port Trunking type instead of Dynamic - LACP - due to MSTP requirement but I could be totally wrong on that). Doesn't matter for what you want to achieve.

I think you need to learn - on all four involved Switches (SW1, SW2, SW3 and SW4) - what is the MSTP configuration (Instances) to understand how those Instances were configured (it looks like you have Instance 1 with VLAN IDs 1 Default, 10 vMotion and 20 iSCSI and Instance 2 with VLAN IDs 30 vSphere and 40 Fault Tolerance)...so traffic tagged on those VLAN IDs will obey to MSTP configuration and use different links to reach involved hosts eliminating, from the point of view of each instance, the physical loop we see (my take: Instance 1 sees a path loop-free for VLAN Ids 1, 10 and 20...the same happens for Instance 2 for VLAN Ids 30 and 40).

Probably it's only a matter of adding the new VLAN Id 64 to the proper instance giving that you know what instance that VLAN should be part of and the path it will use (depending on being part of a particular MSTP Instance other than another).

As reference see the HP Switch Software Advanced Traffic Management Guide W.15.14 (from Page 70, MSTP) and, if necessary to basic management of the Switch, the HP Switch Software Management and Configuration Guide for W.15.14. On the first guide, at Page 112, MSTP is finally described so if I were you I will start from there (that guide starts immediately with MSTP configuration which is IMHO a little bit discouraging without knowing what's the MSTP main purpose), if you want to avoid jumping on that page give a read to this other chapter (it's about another Switch family but the subject is always about MSTP and its description is correctly provided at very beginning).

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Hi Parnassus,

Thanks for getting back to me - yes, apologies for being "light" on the detail in the first post - I was trying to summarize, but when you mentioned about the loop I realised I had to provide the full detail :)

Anyway, I do understand the detail surrounding spanning-tree and whats its there for etc - been involved wth networks for a very long time, just not HP (sorry :))

I just dont get why the multiple instances for this - as far as I can see they are defining exactly the same loop for both (I will go anbd check though), which brings me right back to my original question.....(sorry - I will go and read the docs you sent, but I did do some reading before posting and couldnt find a definitive answer).

Anyway, this is still the main question - Will adding my vlan 64 to either of those instances cause a full reconvergence to occur - i.e. a drop in connectivity? Could I create a new instance for just VLAN 64 and not effect instances 1 and 2?

Thanks again

Paul

parnassus
Honored Contributor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Mmm...I don't believe that adding a new VLAN Id (64) on an existing MSTP Instance will cause any convergence (re)calculation (should verify but topology doesn't seem to change by adding that VLAN)...so that operation should not - di per sè - drop anything (clearly it all boils down to what ports that VLAN 64 it will be tagged to).

If those two Instances share the same path (and both block the same link) what's the purpose of having two instead of just one? having two identical will mean that a 10G (up)link between those two pairs will never be used (would be interesting to see Path(s) costs to understand better the whole configuration), isn't it? ...supposing the unlocked path shared by both instances uses one of those two 10G uplinks or the other but, clearly, not both.

TerjeAFK
Respected Contributor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

I'm only guessing of course, but could the two MSTP instances have been used as load balancing, ie. that instance1 would use two of the uplinks while instance2 used the other two?

parnassus
Honored Contributor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Hi @TerjeAFK, nice to have another pair of eyes looking at this.

But...if so...why the priority is the same (4) WRT Trk1 (that particulat Trk1 <-- what Switch is it referring I miss, also we miss all the others on remaining Switches, isn't it?):

spanning-tree instance 1 Trk1 priority 4

spanning-tree instance 2 Trk1 priority 4

I mean the whole Trk1 has the same priority in both MSTP Instances...so I doubt Trk1 member ports can act differently (in a sort of load splitting)...or is that possible?

I expected to see something related to those two 10G uplinks...let me say: Instance 1 use one path blocking the other, Instance 2 the vice-versa...so, as example, we should see two free loop paths:

  • SW2<=>SW1<--10G Uplink 1-->SW3<=>SW4 when SW2<--10G Uplink 2-->SW4 is blocked on a MSTP Instance
  • SW1<=>SW2<--10G Uplink 2-->SW4<==>SW3 when SW1<--10G Uplink 1-->SW3 is blocked on the other

Or, guessing, both 10G uplinks are always permitted in any instance and, instead, 4x1G Trunk(s) - with lower path cost - between SW1/SW2 and SW3/SW4 alternate WRT MSTP instances, so we should see something like:

  • SW1<--10G Uplink 1-->SW3<=>SW4<--10G Uplink 2-->SW2 when SW1/SW2 Trunk is blocked on a MSTP Instance
  • SW3<--10G Uplink 1-->SW1<=>SW2<--10G Uplink 2-->SW4 when SW3/SW3 Trunk is blocked on the other
TerjeAFK
Respected Contributor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

I agree if the whole STP config has been posted. So to come back to the original question: pick one of the instances (best guess) to add the new vlan as tagged. But you should look into the config and if possible change it to using dynamic trunk (LACP) and a single MSTP instance (or switch to RSTP) if there are no special needs.

 

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Sorry for delayed response, been dealing with some other things today so far....

Im going to pull the full config from all 4 switches and some additional "show" commands for you to have a look at, bear with me - I'll post shortly

I agree with looking at LACP, but I just dont have that luxury just now (its a long story, but Im only here temporarily and trying to do the best I can with a non standard situation (to my eyes anyway)

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Ok so the forum doesnt allow text files to be uploaded - thats a bit rubbish - so the following posts will be quite long!!!!

One thing to point out is dont concern yourselves too much about any ports other than Trk1 and A1 - they are the only ones in the loop - everything else is purely for edge networking of hosts (VMware, iSCSI etc....) - and one pair does have different edge/access ports to the other - thats expected (although far from ideal - but Im fine with that.

Ive got a green light to make some changes tonight late on, so my current thinking is to create a new MST instance (3) and add VLAN 64 to it

But still intrigued to see what you guys think would be the best way round doing this for others in the future - and any recommendations you might have for future changes.

As you will see I still havent tagged 64 onto the A1 (10g Uplinks) just yet - just because of the uncertainty of whether it will drop the links.

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

SW1


Running configuration:

; J9145A Configuration Editor; Created on release #W.15.14.0012
; Ver #06:04.18.63.ff.35.05:b6
hostname "SW1"
module 1 type j9145a
module 2 type j9008a
trunk 21-24 trk1 trunk
no stack
interface 1
name "ESXi1 - ILO"
exit
interface 2
name "HP Node1 ILO"
exit
interface 3
name "ESX1 Nic1"
exit
interface 4
name "ESX2 Nic1"
exit
interface 5
name "Backup ILO"
exit
interface 6
flow-control
name "HP Node1-1"
exit
interface 7
flow-control
name "HP Node3-1"
exit
interface 8
flow-control
name "ESX1 Nic3"
exit
interface 9
flow-control
name "ESX2 Nic3"
exit
interface 10
flow-control
name "ESX5 Nic3"
exit
interface 11
flow-control
exit
interface 12
name "ESX1 Nic4"
exit
interface 13
name "ESX2 Nic4"
exit
interface 14
name "ESX5 Nic4"
exit
interface 16
name "ESX5 Nic1"
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
interface A1
flow-control
exit

vlan 1
name "DEFAULT_VLAN"
no untagged 1-16
untagged 17-20,A2
tagged A1,Trk1
ip address 10.0.4.30 255.0.0.0
exit
vlan 10
name "vMotion"
untagged 12-15
tagged A1,Trk1
exit
vlan 20
name "iSCSI"
untagged 6-11,A1,Trk1
jumbo
exit
vlan 30
name "vSphere"
untagged 1-5,16
tagged A1,Trk1
exit
vlan 40
name "FaultTolerance"
tagged 12-15,A1,Trk1
exit
vlan 64
name "HQServersNew"
tagged A1
exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 priority 0
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 1
spanning-tree instance 2 Trk1 priority 4
no autorun

=-=-=-=-=-=-=-=-
sh lldp info remote
LLDP Remote Devices Information

LocalPort | ChassisId PortId PortDescr SysName
--------- + ------------------------- ------ --------- ----------------------
21 | 2c 27 d7 73 29 00 21 21 SW2
22 | 2c 27 d7 73 29 00 22 22 SW2
23 | 2c 27 d7 73 29 00 23 23 SW2
24 | 2c 27 d7 73 29 00 24 24 SW2
A1 | 2c 27 d7 73 78 c0 25 A1 SW4

=-=-=-=-=-=-=-=-SH SPAN=-=-=-=-=-=-=-=-
sh span

Multiple Spanning Tree (MST) Information

STP Enabled : Yes
Force Version : MSTP-operation
IST Mapped VLANs : 2-9,11-19,21-29,31-39,41-4094
Switch MAC Address : 2c27d7-747500
Switch Priority : 32768
Max Age : 20
Max Hops : 20
Forward Delay : 15

Topology Change Count : 374,359
Time Since Last Change : 18 secs

CST Root MAC Address : 002473-34cd00
CST Root Priority : 32768
CST Root Path Cost : 20023
CST Root Port : Trk1

IST Regional Root MAC Address : 2c27d7-732900
IST Regional Root Priority : 32768
IST Regional Root Path Cost : 20000
IST Remaining Hops : 19

Root Guard Ports :
Loop Guard Ports :
TCN Guard Ports :
BPDU Protected Ports :
BPDU Filtered Ports :
PVST Protected Ports :
PVST Filtered Ports :

Root Inconsistent Ports :
Loop Inconsistent Ports :

| Prio | Designated Hello
Port Type | Cost rity State | Bridge Time PtP Edge
----- --------- + --------- ---- ------------ + ------------- ---- --- ----
1 100/1000T | 200000 128 Forwarding | 2c27d7-747500 2 Yes Yes
2 100/1000T | 200000 128 Forwarding | 2c27d7-747500 2 Yes Yes
3 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
4 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
5 100/1000T | Auto 128 Disabled | 2 Yes No
6 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
7 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
8 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
9 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
10 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
11 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
12 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
13 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
14 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
15 100/1000T | Auto 128 Disabled | 2 Yes No
16 100/1000T | 20000 128 Forwarding | 2c27d7-747500 2 Yes Yes
17 100/1000T | Auto 128 Disabled | 2 Yes No
18 100/1000T | Auto 128 Disabled | 2 Yes No
19 100/1000T | Auto 128 Disabled | 2 Yes No
20 100/1000T | 200000 128 Forwarding | 2c27d7-747500 2 Yes Yes
A1 SFP+SR | 2000 128 Forwarding | 2c27d7-747500 2 Yes No
A2 | Auto 128 Disabled | 2 Yes No
Trk1 | 20000 64 Forwarding | 2c27d7-732900 2 Yes No


=-=-=-=-=-=-=-=-SH SPAN INST 1=-=-=-=-=-=-=-=-
sh span inst 1

MST Instance Information

Instance ID : 1
Mapped VLANs : 1,10,20
Switch Priority : 0

Topology Change Count : 374320
Time Since Last Change : 0 secs

Regional Root MAC Address : 2c27d7-747500
Regional Root Priority : 0
Regional Root Path Cost : 0
Regional Root Port : This switch is root
Remaining Hops : 20

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T 200000 128 Designated Forwarding 2c27d7-747500
2 100/1000T 200000 128 Designated Forwarding 2c27d7-747500
3 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
4 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
5 100/1000T Auto 128 Disabled Disabled
6 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
7 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
8 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
9 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
10 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
11 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
12 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
13 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
14 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
17 100/1000T Auto 128 Disabled Disabled
18 100/1000T Auto 128 Disabled Disabled
19 100/1000T Auto 128 Disabled Disabled
20 100/1000T 200000 128 Designated Forwarding 2c27d7-747500
A1 10GbE-GEN 2000 128 Designated Forwarding 2c27d7-747500
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Designated Forwarding 2c27d7-747500

=-=-=-=-=-=-=-=-SH SPAN INST 2=-=-=-=-=-=-=-=-
sh span inst 2

MST Instance Information

Instance ID : 2
Mapped VLANs : 30,40
Switch Priority : 4096

Topology Change Count : 2
Time Since Last Change : 237 days

Regional Root MAC Address : 2c27d7-732740
Regional Root Priority : 0
Regional Root Path Cost : 22000
Regional Root Port : Trk1
Remaining Hops : 18

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T 200000 128 Designated Forwarding 2c27d7-747500
2 100/1000T 200000 128 Designated Forwarding 2c27d7-747500
3 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
4 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
5 100/1000T Auto 128 Disabled Disabled
6 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
7 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
8 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
9 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
10 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
11 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
12 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
13 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
14 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-747500
17 100/1000T Auto 128 Disabled Disabled
18 100/1000T Auto 128 Disabled Disabled
19 100/1000T Auto 128 Disabled Disabled
20 100/1000T 200000 128 Designated Forwarding 2c27d7-747500
A1 10GbE-GEN 2000 128 Alternate Blocking 2c27d7-7378c0
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Root Forwarding 2c27d7-732900

 

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

SW2


Running configuration:

; J9145A Configuration Editor; Created on release #W.15.14.0012
; Ver #06:04.18.63.ff.35.05:b6
hostname "SW2"
module 1 type j9145a
module 2 type j9008a
trunk 21-24 trk1 trunk
sntp server priority 1 10.0.0.28
interface 1
name "ESX2 ILO"
exit
interface 2
name "HP Node2 ILO"
exit
interface 3
name "ESX1 Nic5"
exit
interface 4
name "ESX2 Nic5"
exit
interface 5
name "ESXi5 (ILO)"
exit
interface 6
flow-control
name "HP Node1-2"
exit
interface 7
flow-control
name "HP Node3-2"
exit
interface 8
flow-control
name "ESX1 Nic7"
exit
interface 9
flow-control
name "ESX2 Nic7"
exit
interface 10
flow-control
name "ESX5 Nic7"
exit
interface 11
flow-control
exit
interface 12
name "ESX1 Nic8"
exit
interface 13
name "ESX2 Nic8"
exit
interface 14
name "ESX5 Nic8"
exit
interface 16
name "ESX5 Nic5"
exit
interface 20
name "Uplink to access switch"
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
interface A1
flow-control
exit

vlan 1
name "DEFAULT_VLAN"
no untagged 1-16
untagged 17-20,A2
tagged A1,Trk1
ip address 10.0.4.31 255.0.0.0
exit
vlan 10
name "vMotion"
untagged 12-15
tagged A1,Trk1
exit
vlan 20
name "iSCSI"
untagged 6-11,A1,Trk1
jumbo
exit
vlan 30
name "vSphere"
untagged 1-5,16
tagged A1,Trk1
exit
vlan 40
name "FaultTolerance"
tagged 12-15,A1,Trk1
exit
vlan 64
name "HQServersNew"
tagged 20,A1
exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 Trk1 priority 4
no autorun

=-=-=-=-=-=-=-=-
sh lldp info remote
LLDP Remote Devices Information

LocalPort | ChassisId PortId PortDescr SysName
--------- + ------------------------- ------ --------- ----------------------
20 | HQ-ACCESS_SWITCH Gig0/4
21 | 2c 27 d7 74 75 00 21 21 SW1
22 | 2c 27 d7 74 75 00 22 22 SW1
23 | 2c 27 d7 74 75 00 23 23 SW1
24 | 2c 27 d7 74 75 00 24 24 SW1
A1 | 2c 27 d7 73 27 40 25 A1 SW3

=-=-=-=-=-=-=-=-SH SPAN=-=-=-=-=-=-=-=-
sh span

Multiple Spanning Tree (MST) Information

STP Enabled : Yes
Force Version : MSTP-operation
IST Mapped VLANs : 2-9,11-19,21-29,31-39,41-4094
Switch MAC Address : 2c27d7-732900
Switch Priority : 32768
Max Age : 20
Max Hops : 20
Forward Delay : 15

Topology Change Count : 741,797
Time Since Last Change : 27 secs

CST Root MAC Address : 002473-34cd00
CST Root Priority : 32768
CST Root Path Cost : 20023
CST Root Port : 20

IST Regional Root MAC Address : 2c27d7-732900
IST Regional Root Priority : 32768
IST Regional Root Path Cost : 0
IST Remaining Hops : 20

Root Guard Ports :
Loop Guard Ports :
TCN Guard Ports :
BPDU Protected Ports :
BPDU Filtered Ports :
PVST Protected Ports :
PVST Filtered Ports :

Root Inconsistent Ports :
Loop Inconsistent Ports :

| Prio | Designated Hello
Port Type | Cost rity State | Bridge Time PtP Edge
----- --------- + --------- ---- ------------ + ------------- ---- --- ----
1 100/1000T | Auto 128 Disabled | 2 Yes No
2 100/1000T | 200000 128 Forwarding | 2c27d7-732900 2 Yes Yes
3 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
4 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
5 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
6 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
7 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
8 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
9 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
10 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
11 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
12 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
13 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
14 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
15 100/1000T | Auto 128 Disabled | 2 Yes No
16 100/1000T | 20000 128 Forwarding | 2c27d7-732900 2 Yes Yes
17 100/1000T | Auto 128 Disabled | 2 Yes No
18 100/1000T | 200000 128 Forwarding | 2c27d7-732900 2 Yes Yes
19 100/1000T | Auto 128 Disabled | 2 Yes No
20 100/1000T | 20000 128 Forwarding | 00192f-283580 2 Yes No
A1 SFP+SR | 2000 128 Forwarding | 2c27d7-732900 2 Yes No
A2 | Auto 128 Disabled | 2 Yes No
Trk1 | 20000 64 Forwarding | 2c27d7-732900 2 Yes No

=-=-=-=-=-=-=-=-SH SPAN INST 1=-=-=-=-=-=-=-=-
sh span inst 1

MST Instance Information

Instance ID : 1
Mapped VLANs : 1,10,20
Switch Priority : 32768

Topology Change Count : 741716
Time Since Last Change : 1 secs

Regional Root MAC Address : 2c27d7-747500
Regional Root Priority : 0
Regional Root Path Cost : 20000
Regional Root Port : Trk1
Remaining Hops : 19

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T Auto 128 Disabled Disabled
2 100/1000T 200000 128 Designated Forwarding 2c27d7-732900
3 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
4 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
5 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
6 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
7 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
8 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
9 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
10 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
11 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
12 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
13 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
14 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
17 100/1000T Auto 128 Disabled Disabled
18 100/1000T 200000 128 Designated Forwarding 2c27d7-732900
19 100/1000T Auto 128 Disabled Disabled
20 100/1000T 20000 128 Master Forwarding 2c27d7-732900
A1 10GbE-GEN 2000 128 Designated Forwarding 2c27d7-732900
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Root Forwarding 2c27d7-747500

=-=-=-=-=-=-=-=-SH SPAN INST 2=-=-=-=-=-=-=-=-
sh span inst 2

MST Instance Information

Instance ID : 2
Mapped VLANs : 30,40
Switch Priority : 32768

Topology Change Count : 741722
Time Since Last Change : 2 secs

Regional Root MAC Address : 2c27d7-732740
Regional Root Priority : 0
Regional Root Path Cost : 2000
Regional Root Port : A1
Remaining Hops : 19

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T Auto 128 Disabled Disabled
2 100/1000T 200000 128 Designated Forwarding 2c27d7-732900
3 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
4 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
5 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
6 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
7 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
8 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
9 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
10 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
11 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
12 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
13 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
14 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-732900
17 100/1000T Auto 128 Disabled Disabled
18 100/1000T 200000 128 Designated Forwarding 2c27d7-732900
19 100/1000T Auto 128 Disabled Disabled
20 100/1000T 20000 128 Master Forwarding 2c27d7-732900
A1 10GbE-GEN 2000 128 Root Forwarding 2c27d7-732740
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Designated Forwarding 2c27d7-732900

 

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

SW3


Running configuration:

; J9145A Configuration Editor; Created on release #W.15.14.0012
; Ver #06:04.18.63.ff.35.05:b6
hostname "SW3"
module 1 type j9145a
module 2 type j9008a
trunk 21-24 trk1 trunk
no stack
interface 1
name "ESX3 ILO"
exit
interface 2
name "HP Node2 ILO"
exit
interface 3
name "ESX3 Nic1"
exit
interface 4
name "ESX4 Nic1"
exit
interface 5
name "ESX6 Nic1"
exit
interface 6
flow-control
name "HP Node2-1"
exit
interface 7
flow-control
name "HP Node4-1"
exit
interface 8
flow-control
name "ESX3 Nic3"
exit
interface 9
flow-control
name "ESX4 Nic3"
exit
interface 10
flow-control
name "ESX6 Nic3"
exit
interface 11
name "ESX6 Nic2"
exit
interface 12
name "ESX3 Nic4"
exit
interface 13
name "ESX4 Nic4"
exit
interface 14
name "ESX6 Nic4"
exit
interface 16
name "ESX3 Nic2"
exit
interface 17
name "ESX4 Nic2"
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
interface A1
flow-control
exit

vlan 1
name "DEFAULT_VLAN"
no untagged 1-10,12-15
untagged 11,16-20,A2
tagged A1,Trk1
ip address 10.0.4.32 255.0.0.0
exit
vlan 10
name "vMotion"
untagged 12-15
tagged A1,Trk1
exit
vlan 20
name "iSCSI"
untagged 6-10,A1,Trk1
jumbo
exit
vlan 30
name "vSphere"
untagged 1-5
tagged A1,Trk1
exit
vlan 40
name "FaultTolerance"
tagged 12-15,A1,Trk1
exit
vlan 64
name "HQServersNew"
tagged 11,16-17,A1
no ip address
exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 priority 1
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 0
spanning-tree instance 2 Trk1 priority 4
no autorun

=-=-=-=-=-=-=-=-
sh lldp info remote
LLDP Remote Devices Information

LocalPort | ChassisId PortId PortDescr SysName
--------- + ------------------------- ------ --------- ----------------------
21 | 2c 27 d7 73 78 c0 21 21 SW4
22 | 2c 27 d7 73 78 c0 22 22 SW4
23 | 2c 27 d7 73 78 c0 23 23 SW4
24 | 2c 27 d7 73 78 c0 24 24 SW4
A1 | 2c 27 d7 73 29 00 25 A1 SW2


=-=-=-=-=-=-=-=-SH SPAN=-=-=-=-=-=-=-=-
sh span

Multiple Spanning Tree (MST) Information

STP Enabled : Yes
Force Version : MSTP-operation
IST Mapped VLANs : 2-9,11-19,21-29,31-39,41-4094
Switch MAC Address : 2c27d7-732740
Switch Priority : 32768
Max Age : 20
Max Hops : 20
Forward Delay : 15

Topology Change Count : 1,158,894
Time Since Last Change : 3 secs

CST Root MAC Address : 002473-34cd00
CST Root Priority : 32768
CST Root Path Cost : 20023
CST Root Port : A1

IST Regional Root MAC Address : 2c27d7-732900
IST Regional Root Priority : 32768
IST Regional Root Path Cost : 2000
IST Remaining Hops : 19

Root Guard Ports :
Loop Guard Ports :
TCN Guard Ports :
BPDU Protected Ports :
BPDU Filtered Ports :
PVST Protected Ports :
PVST Filtered Ports :

Root Inconsistent Ports :
Loop Inconsistent Ports :

| Prio | Designated Hello
Port Type | Cost rity State | Bridge Time PtP Edge
----- --------- + --------- ---- ------------ + ------------- ---- --- ----
1 100/1000T | 200000 128 Forwarding | 2c27d7-732740 2 Yes Yes
2 100/1000T | 200000 128 Forwarding | 2c27d7-732740 2 Yes Yes
3 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
4 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
5 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
6 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
7 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
8 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
9 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
10 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
11 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
12 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
13 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
14 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
15 100/1000T | Auto 128 Disabled | 2 Yes No
16 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
17 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
18 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
19 100/1000T | Auto 128 Disabled | 2 Yes No
20 100/1000T | 20000 128 Forwarding | 2c27d7-732740 2 Yes Yes
A1 SFP+SR | 2000 128 Forwarding | 2c27d7-732900 2 Yes No
A2 | Auto 128 Disabled | 2 Yes No
Trk1 | 20000 64 Forwarding | 2c27d7-732740 2 Yes No

 

=-=-=-=-=-=-=-=-SH SPAN INST 1=-=-=-=-=-=-=-=-
sh span inst 1

MST Instance Information

Instance ID : 1
Mapped VLANs : 1,10,20
Switch Priority : 4096

Topology Change Count : 32
Time Since Last Change : 237 days

Regional Root MAC Address : 2c27d7-747500
Regional Root Priority : 0
Regional Root Path Cost : 22000
Regional Root Port : A1
Remaining Hops : 18

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T 200000 128 Designated Forwarding 2c27d7-732740
2 100/1000T 200000 128 Designated Forwarding 2c27d7-732740
3 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
4 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
5 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
6 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
7 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
8 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
9 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
10 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
11 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
12 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
13 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
14 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
17 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
18 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
19 100/1000T Auto 128 Disabled Disabled
20 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
A1 10GbE-GEN 2000 128 Root Forwarding 2c27d7-732900
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Alternate Blocking 2c27d7-7378c0


=-=-=-=-=-=-=-=-SH SPAN INST 2=-=-=-=-=-=-=-=-
sh span inst 2

MST Instance Information

Instance ID : 2
Mapped VLANs : 30,40
Switch Priority : 0

Topology Change Count : 1158802
Time Since Last Change : 1 secs

Regional Root MAC Address : 2c27d7-732740
Regional Root Priority : 0
Regional Root Path Cost : 0
Regional Root Port : This switch is root
Remaining Hops : 20

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T 200000 128 Designated Forwarding 2c27d7-732740
2 100/1000T 200000 128 Designated Forwarding 2c27d7-732740
3 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
4 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
5 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
6 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
7 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
8 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
9 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
10 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
11 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
12 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
13 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
14 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
17 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
18 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
19 100/1000T Auto 128 Disabled Disabled
20 100/1000T 20000 128 Designated Forwarding 2c27d7-732740
A1 10GbE-GEN 2000 128 Designated Forwarding 2c27d7-732740
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Designated Forwarding 2c27d7-732740

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

SW4


Running configuration:

; J9145A Configuration Editor; Created on release #W.15.14.0012
; Ver #06:04.18.63.ff.35.05:b6
hostname "SW4"
module 1 type j9145a
module 2 type j9008a
trunk 21-24 trk1 trunk
interface 1
name "ESX4 ILO"
exit
interface 2
name "HP Node4 ILO"
exit
interface 3
name "ESX3 Nic5"
exit
interface 4
name "ESX4 Nic5"
exit
interface 5
name "ESX6 Nic5"
exit
interface 6
flow-control
name "HP Node2-2"
exit
interface 7
flow-control
name "HP Node4-2"
exit
interface 8
flow-control
name "ESX3 Nic7"
exit
interface 9
flow-control
name "ESX4 Nic7"
exit
interface 10
flow-control
name "ESX6 Nic7"
exit
interface 11
name "ESX6 Nic6"
exit
interface 12
name "ESX3 Nic8"
exit
interface 13
name "ESX4 Nic8"
exit
interface 14
name "ESX6 Nic8"
exit
interface 16
name "ESX3 Nic6"
exit
interface 17
name "ESX4 Nic6"
exit
interface 19
name "ESX6 ILO"
exit
interface 21
flow-control
exit
interface 22
flow-control
exit
interface 23
flow-control
exit
interface 24
flow-control
exit
interface A1
flow-control
exit

vlan 1
name "DEFAULT_VLAN"
no untagged 1-10,12-15,19
untagged 11,16-18,20,A2
tagged A1,Trk1
ip address 10.0.4.33 255.0.0.0
exit
vlan 10
name "Motion"
untagged 12-15
tagged A1,Trk1
exit
vlan 20
name "iSCSI"
untagged 6-10,A1,Trk1
jumbo
exit
vlan 30
name "vSphere"
untagged 1-5,19
tagged A1,Trk1
exit
vlan 40
name "FaultTolerance"
tagged 12-15,A1,Trk1
exit
vlan 64
name "HQServersNew"
tagged 11,16-17,A1
exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 Trk1 priority 4
no autorun

=-=-=-=-=-=-=-=-
sh lldp info remote
LLDP Remote Devices Information

LocalPort | ChassisId PortId PortDescr SysName
--------- + ------------------------- ------ --------- ----------------------
21 | 2c 27 d7 73 27 40 21 21 SW3
22 | 2c 27 d7 73 27 40 22 22 SW3
23 | 2c 27 d7 73 27 40 23 23 SW3
24 | 2c 27 d7 73 27 40 24 24 SW3
A1 | 2c 27 d7 74 75 00 25 A1 SW1

=-=-=-=-=-=-=-=-SH SPAN=-=-=-=-=-=-=-=-
sh span

Multiple Spanning Tree (MST) Information

STP Enabled : Yes
Force Version : MSTP-operation
IST Mapped VLANs : 2-9,11-19,21-29,31-39,41-4094
Switch MAC Address : 2c27d7-7378c0
Switch Priority : 32768
Max Age : 20
Max Hops : 20
Forward Delay : 15

Topology Change Count : 64
Time Since Last Change : 83 days

CST Root MAC Address : 002473-34cd00
CST Root Priority : 32768
CST Root Path Cost : 20023
CST Root Port : Trk1

IST Regional Root MAC Address : 2c27d7-732900
IST Regional Root Priority : 32768
IST Regional Root Path Cost : 22000
IST Remaining Hops : 18

Root Guard Ports :
Loop Guard Ports :
TCN Guard Ports :
BPDU Protected Ports :
BPDU Filtered Ports :
PVST Protected Ports :
PVST Filtered Ports :

Root Inconsistent Ports :
Loop Inconsistent Ports :

| Prio | Designated Hello
Port Type | Cost rity State | Bridge Time PtP Edge
----- --------- + --------- ---- ------------ + ------------- ---- --- ----
1 100/1000T | 200000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
2 100/1000T | 200000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
3 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
4 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
5 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
6 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
7 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
8 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
9 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
10 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
11 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
12 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
13 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
14 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
15 100/1000T | Auto 128 Disabled | 2 Yes No
16 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
17 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
18 100/1000T | 200000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
19 100/1000T | 20000 128 Forwarding | 2c27d7-7378c0 2 Yes Yes
20 100/1000T | Auto 128 Disabled | 2 Yes No
A1 SFP+SR | 2000 128 Blocking | 2c27d7-747500 2 Yes No
A2 | Auto 128 Disabled | 2 Yes No
Trk1 | 20000 64 Forwarding | 2c27d7-732740 2 Yes No

=-=-=-=-=-=-=-=-SH SPAN INST 1=-=-=-=-=-=-=-=-
sh span inst 1

MST Instance Information

Instance ID : 1
Mapped VLANs : 1,10,20
Switch Priority : 32768

Topology Change Count : 437396
Time Since Last Change : 15 secs

Regional Root MAC Address : 2c27d7-747500
Regional Root Priority : 0
Regional Root Path Cost : 2000
Regional Root Port : A1
Remaining Hops : 19

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T 200000 128 Designated Forwarding 2c27d7-7378c0
2 100/1000T 200000 128 Designated Forwarding 2c27d7-7378c0
3 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
4 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
5 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
6 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
7 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
8 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
9 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
10 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
11 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
12 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
13 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
14 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
17 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
18 100/1000T 200000 128 Designated Forwarding 2c27d7-7378c0
19 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
20 100/1000T Auto 128 Disabled Disabled
A1 10GbE-GEN 2000 128 Root Forwarding 2c27d7-747500
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Designated Forwarding 2c27d7-7378c0


=-=-=-=-=-=-=-=-SH SPAN INST 2=-=-=-=-=-=-=-=-
sh span inst 2

MST Instance Information

Instance ID : 2
Mapped VLANs : 30,40
Switch Priority : 32768

Topology Change Count : 437389
Time Since Last Change : 28 secs

Regional Root MAC Address : 2c27d7-732740
Regional Root Priority : 0
Regional Root Path Cost : 20000
Regional Root Port : Trk1
Remaining Hops : 19

Root Inconsistent Ports :
Loop Inconsistent Ports :

Designated
Port Type Cost Priority Role State Bridge
----- --------- --------- -------- ---------- ------------ --------------
1 100/1000T 200000 128 Designated Forwarding 2c27d7-7378c0
2 100/1000T 200000 128 Designated Forwarding 2c27d7-7378c0
3 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
4 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
5 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
6 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
7 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
8 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
9 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
10 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
11 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
12 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
13 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
14 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
15 100/1000T Auto 128 Disabled Disabled
16 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
17 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
18 100/1000T 200000 128 Designated Forwarding 2c27d7-7378c0
19 100/1000T 20000 128 Designated Forwarding 2c27d7-7378c0
20 100/1000T Auto 128 Disabled Disabled
A1 10GbE-GEN 2000 128 Designated Forwarding 2c27d7-7378c0
A2 Auto 128 Disabled Disabled
Trk1 20000 64 Root Forwarding 2c27d7-732740

 

parnassus
Honored Contributor
Solution

Re: LAG/LACP trunks and spanning tree on 2910al-24g

@pauladam2608: SW3 and SW4 are in wrong positions, SW3 is connected to SW2 via A1/A1 uplink...so it is SW4, connected via A1/A1 uplink to SW1. So exchange their positions in your Network Diagram.

Regarding all the config...I'm not so fast for tonight (remapping VLAN to Instance will cause convergence recalculation...so there will be probably a network disruption...to understand how much and what SW will be impacted more all the scenario should be studied).

Starting with:

SW1 (IST Regional Root Path Cost : 20000, CST Root Port: Trk1 | CST Root Path Cost: 20023):
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 priority 0
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 1
spanning-tree instance 2 Trk1 priority 4

SW2 (IST Regional Root Path Cost : 0, CST Root Port: 20 | CST Root Path Cost: 20023) <--- IST Regional Root
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 Trk1 priority 4

SW3 (IST Regional Root Path Cost : 2000, CST Root Port: A1 | CST Root Path Cost: 20023):

spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 priority 1
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 priority 0
spanning-tree instance 2 Trk1 priority 4

SW4 (IST Regional Root Path Cost : 22000, CST Root Port: Trk1 | CST Root Path Cost: 20023):

spanning-tree
spanning-tree Trk1 priority 4
spanning-tree config-name "MyConfig"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 10 20
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 2 vlan 30 40
spanning-tree instance 2 Trk1 priority 4

Consider to use the "pending" approach, see spanning-tree pending (Enabling an Entire MST Region at Once) on last document I linked.

I suspect that what happens in this scenario could be strictly related.

It's late here in CEST...I've no more power today.

pauladam2608
Occasional Advisor

Re: LAG/LACP trunks and spanning tree on 2910al-24g

Hi Parnassus,

Yeah I picked up on the error of connectivity last night when I was reviewing the config myself - that diagram was only put together super quick for this post, but the lack of a proper diagram does of course mean that one needs to be done (another issue I am dealing with here....no diagrams!)

Anyway, as I think I mentioned, I had the chance for some downtime this evening and played about with the spanning tree options just to see what would happen.

So adding vlan 64 to the stp instance 1 (VLANs 1, 10 and 20 were the existing VLAN in there) was not the best idea - massive recalculation and drops (which I did expect....but its all part of the learning process).

So I went for the create a new instance option and added 64 into it and of course tagged 64 onto the Trk1 uplinlks (in that order) - and happy to say I experienced no interruption at all with that option.

I need to go back and review the stp priorities for sure, but for now I am happy that I have the VLAN added into the loop and STP is blocking one of the paths as it should.

Thanks again for all your assistance, its been invaluable (and thanks to TerjeAFK for his input also)

Cheers

Paul