ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve 5308 CPU utilization goes through the roof

Richard Penhale
Occasional Advisor

Procurve 5308 CPU utilization goes through the roof

Dear All,

We have a 5308XL acting as a core routing switch on our LAN. It is linked to a 5412ZL via an 8 Port LACP trunk. All has been well until a few weeks back when 2 or three times a week it's cpu utilization hit 80-90% and the network grinds to a standstill. The only way to recover is to reboot the switch. MSTP is enabled on both these swchitches as well as rstp across the 50 edge switches on Campus. I have logged a call with procurve support but other than asking for a LAN diagram and show tech all output nothing. Any suggestions would be welcomed please?
5 REPLIES
Richard Penhale
Occasional Advisor

Re: Procurve 5308 CPU utilization goes through the roof

The config for info is as follows:-

; J4819A Configuration Editor; Created on release #E.11.10

hostname "HP ProCurve Switch 5308xl"
snmp-server contact "PEN, LUC"
snmp-server location "Core Switch Server Room"
max-vlans 256
broadcast-limit
time daylight-time-rule Western-Europe
no cdp run
console baud-rate 115200
ip access-list extended "100"
permit ip 0.0.0.0 255.255.255.255 10.3.44.13 0.0.0.0
permit udp 0.0.0.0 255.255.255.255 172.17.1.79 0.0.0.0 eq 161
permit udp 0.0.0.0 255.255.255.255 172.17.1.79 0.0.0.0 eq 162
permit udp 0.0.0.0 255.255.255.255 172.17.1.79 0.0.0.0 eq 512
exit
module 1 type J4907A
module 2 type J4907A
module 3 type J4878A
module 8 type J4907A
module 4 type J4907A
module 5 type J4878B
module 6 type J4878B
module 7 type J4907A
interface C1
name "Port 26 on HP2626 - 10.3.44.16 - Performing Arts Office"
no lacp
exit
interface C2
name "Port 25 on HP2524 - 10.3.44.57 - Maths Office"
no lacp
exit
interface C3
name "Port 26 on HP2626 - 10.3.44.18 - TCA"
no lacp
exit
interface C4
name "Port 25 on HP2626 - 10.3.44.59 - Science"
no lacp
exit
interface B1
name "SIMSSERVER - NIC1"
no lacp
exit
interface B2
name "EXCHANGE - NIC1"
no lacp
exit
interface B3
name "Sports Hall formerly crackle"
speed-duplex 100-full
no lacp
exit
interface B4
name "Port 26 on HP2626 - 10.3.44.22 - 4th Switch Comms"
no lacp
exit
interface B5
name "Port 26 on HP2626 - 10.3.44.21 - 5th Switch Comms"
no lacp
exit
interface B6
name "Port 26 on HP2626 - 10.3.44.15 - 2nd Switch Comms"
no lacp
exit
interface B7
name "Link1 - SEN - Port 26 on HP2626 - 10.3.44.??"
no lacp
exit
interface B8
name "SIMSSERVER - NIC2"
no lacp
exit
interface B9
name "Port G2 on Dell PowerConnect 3324 - 10.3.44.60 Comms Top Dell"
no lacp
exit
interface B10
name "Port 26 on HP2626 - 10.3.44.23 - 3rd Switch Comms"
no lacp
exit
interface B11
name "Link2 - MFL - Port 26 on HP2626 - 10.3.44.??"
no lacp
exit
interface B12
name "Port 26 on HP2626 - 10.3.44.20 - 6th Switch Comms"
no lacp
exit
interface B13
name "Port 26 on HP2626 - 10.3.44.24 - 1st Switch Comms"
no lacp
exit
interface B14
name "NTSERVERX1"
speed-duplex 100-full
no lacp
exit
interface B15
name "Admin"
no lacp
exit
interface B16
name "Motorola Spectra Sports Hall link 172.22.2.208"
no lacp
exit
interface A1
name "Cisco ASA 5510"
speed-duplex 100-full
no lacp
exit
interface A2
name "Dell 3324"
no lacp
exit
interface A3
name "SERVERX1 - NIC1"
no lacp
exit
interface A4
name "SERVERX2 - NIC1"
no lacp
exit
interface A5
name "POWERVAULT1 - NIC1"
speed-duplex auto-1000
no lacp
exit
interface A6
name "PROCURVE"
no lacp
exit
interface A7
name "POWERVAULT2 - NIC1"
no lacp
exit
interface A8
name "DELL KVM 2161DS"
no lacp
exit
interface A9
name "PROXY"
no lacp
exit
interface A10
name "ALTIRIS"
speed-duplex auto-1000
no lacp
exit
interface A11
name "SERVERX2 - NIC2"
no lacp
exit
interface A12
name "POWERVAULT1 - NIC2"
speed-duplex auto-1000
no lacp
exit
interface A13
name "SDC/13 - CCTV"
no lacp
exit
interface A14
name "P23 External Line"
no lacp
exit
interface A15
name "Port 25 on HP2626 - 10.3.44.25 - Place House Old"
no lacp
exit
interface A16
no lacp
exit
interface H1
name "Cable 5 not used"
no lacp
exit
interface H2
name "AVANTIS"
no lacp
exit
interface H3
name "Serverx3 NIC 6"
no lacp
exit
interface H4
name "Avaya G700 GW"
speed-duplex auto-100
no lacp
exit
interface H5
name "Cable 6 not used"
no lacp
exit
interface H6
name "LUCID"
no lacp
exit
interface H7
name "SERVERX1 - NIC2"
no lacp
exit
interface H8
name "CCTV - NIC?"
no lacp
exit
interface H9
name "CCTV - NIC?"
no lacp
exit
interface H10
name "EXCHANGE - NIC2"
no lacp
exit
interface H11
name "UPDATE"
no lacp
exit
interface H12
name "LinkSys Fiber Converter to DMorgan House"
speed-duplex 100-full
no lacp
exit
interface H13
name "SNAP"
no lacp
exit
interface H14
name "SECURUS"
no lacp
exit
interface H15
name "LinkSys Fibre Converter to English Block"
no lacp
exit
interface H16
name "Port 9 on HP2600PW - 10.3.44.30 PoE Comms Room "
no lacp
exit
interface D1
name "SDCCprint"
no lacp
exit
interface D2
name "New SIMS 1"
no lacp
exit
interface D3
name "Dell MD3000 RAID 0"
no lacp
exit
interface D4
name "NX1950 Top (a) NIC3"
no lacp
exit
interface D5
name "NX1950 Top (a) NIC 2"
no lacp
exit
interface D6
name "NX1950 Top (a) NIC 1"
no lacp
exit
interface D7
name "SDCCprint"
no lacp
exit
interface D8
no lacp
exit
interface D9
name "New SIMS 2"
no lacp
exit
interface D10
name "Dell MD3000 RAID 1"
no lacp
exit
interface D11
name "NX1950 Bottom (a) NIC 1"
no lacp
exit
interface D12
name "NX1950 Bottom (b) NIC 2"
no lacp
exit
interface D13
name "NX1950 Bottom (b) NIC 3"
no lacp
exit
interface D14
name "Tape Library"
no lacp
exit
interface D15
no lacp
exit
interface D16
no lacp
exit
interface E1
no lacp
exit
interface E2
no lacp
exit
interface E3
no lacp
exit
interface E4
no lacp
exit
interface F1
no lacp
exit
interface F2
no lacp
exit
interface F3
no lacp
exit
interface F4
no lacp
exit
trunk D15-D16 Trk1 Trunk
trunk C2,E1 Trk2 Trunk
trunk E3-E4 Trk3 Trunk
trunk F1-F2 Trk4 Trunk
interface G1
no lacp
exit
interface G2
no lacp
exit
interface G3
no lacp
exit
interface G4
no lacp
exit
interface G5
no lacp
exit
interface G6
no lacp
exit
interface G7
no lacp
exit
interface G8
no lacp
exit
interface G9
no lacp
exit
interface G10
no lacp
exit
interface G11
no lacp
exit
interface G12
no lacp
exit
interface G13
no lacp
exit
interface G14
no lacp
exit
interface G15
no lacp
exit
interface G16
no lacp
exit
trunk G1-G4,G8-G11 Trk16 LACP
ip default-gateway 10.3.47.254
sntp server 10.3.44.1
ip routing
timesync sntp
sntp unicast
logging facility syslog
logging 172.17.1.79
snmp-server community "public" Operator
snmp-server community "private" Unrestricted
snmp-server host 172.17.1.79 "public" All
snmp-server host 172.17.1.79 "private" All
snmp-server host 172.17.1.79 "public"
vlan 1
name "DEFAULT_VLAN"
untagged A1-A5,A7-A12,A14-A16,B1-B16,C1,C3-C4,D3-D7,D13,E2,F3-F4,G5-G7,G12-G16,H1,H3-H7,H10-H16,Trk1-Trk4
ip address 10.3.44.12 255.255.252.0
no untagged A6,A13,D1-D2,D8-D12,D14,H2,H8-H9,Trk16
exit
vlan 2
name "Wless-APs"
ip address 192.168.99.254 255.255.255.0
tagged A15-A16,B4-B7,B10-B13,B15-B16,C1,C3-C4,E2,F3-F4,H15-H16,Trk2-Trk4
exit
vlan 3
name "Wless-Users"
ip address 192.168.100.254 255.255.255.0
ip helper-address 10.3.44.1
tagged A15-A16,B3-B8,B10-B16,C1,C3-C4,E2,F3-F4,H15-H16,Trk2-Trk4
exit
vlan 17
name "Management"
untagged A6,D14
ip address 172.17.1.254 255.255.255.0
tagged A2,B9,Trk16
exit
vlan 19
name "Voice"
ip address 172.19.255.254 255.255.0.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
voice
exit
vlan 160
name "cctv"
untagged A13
ip address 172.16.16.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 163
name "Bms"
ip address 172.16.32.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 20
name "Staff"
ip address 172.20.255.254 255.255.0.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 180
name "IT01"
ip address 172.18.0.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 181
name "IT02"
ip address 172.18.1.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 182
name "IT03"
ip address 172.18.2.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 183
name "HY5"
ip address 172.18.3.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 184
name "MATHS"
ip address 172.18.4.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 185
name "English"
ip address 172.18.5.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 186
name "Library"
ip address 172.18.6.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 187
name "Admin"
ip address 172.18.7.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 188
name "SWROOM"
ip address 172.18.8.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 189
name "Vlan189"
ip address 172.18.9.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 190
name "Vlan190"
ip address 172.18.10.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 191
name "Vlan191"
ip address 172.18.11.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 192
name "Vlan192"
ip address 172.18.12.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 193
name "Vlan193"
ip address 172.18.13.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 194
name "Vlan194"
ip address 172.18.14.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 195
name "Vlan195"
ip address 172.18.15.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 196
name "Vlan196"
ip address 172.18.16.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 197
name "Vlan197"
ip address 172.18.17.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 198
name "Vlan198"
ip address 172.18.18.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 199
name "Vlan199"
ip address 172.18.19.254 255.255.255.0
ip helper-address 10.3.44.1
ip helper-address 10.3.44.3
ip helper-address 10.3.44.65
exit
vlan 999
name "iSCSI"
untagged D1-D2,D8-D12
exit
vlan 998
name "vmotion"
untagged H2,H8-H9
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
gvrp
qos protocol IP priority 7
qos device-priority 10.3.47.234 priority 7
qos device-priority 10.3.47.235 priority 7
qos device-priority 10.3.47.236 priority 7
qos device-priority 10.3.47.237 priority 7
qos device-priority 10.3.47.238 priority 7
qos device-priority 10.3.47.239 priority 7
qos device-priority 10.3.47.240 priority 7
qos device-priority 10.3.47.241 priority 7
qos device-priority 10.3.47.242 priority 7
qos device-priority 10.3.47.243 priority 7
qos device-priority 10.3.47.244 priority 7
qos device-priority 10.3.47.245 priority 7
qos device-priority 10.3.47.246 priority 7
qos device-priority 10.3.47.247 priority 7
qos device-priority 10.3.47.248 priority 7
qos type-of-service ip-precedence
ip route 0.0.0.0 0.0.0.0 10.3.47.254
filter connection-rate A1-A16,B1-B16,C1,C3-C4,D1-D14,E2,F3-F4,G5-G7,G12-G16,H1-H16,Trk1-Trk4,Trk16 notify-only
spanning-tree
spanning-tree A1 point-to-point-mac Auto
spanning-tree A2 point-to-point-mac Auto
spanning-tree A3 point-to-point-mac Auto
spanning-tree A4 point-to-point-mac Auto
spanning-tree A5 point-to-point-mac Auto
spanning-tree A6 point-to-point-mac Auto
spanning-tree A7 point-to-point-mac Auto
spanning-tree A8 point-to-point-mac Auto
spanning-tree A9 point-to-point-mac Auto
spanning-tree A10 point-to-point-mac Auto
spanning-tree A11 point-to-point-mac Auto
spanning-tree A12 point-to-point-mac Auto
spanning-tree A13 point-to-point-mac Auto
spanning-tree A14 point-to-point-mac Auto
spanning-tree A15 point-to-point-mac Auto
spanning-tree A16 point-to-point-mac Auto
spanning-tree B1 point-to-point-mac Auto
spanning-tree B2 point-to-point-mac Auto
spanning-tree B3 point-to-point-mac Auto
spanning-tree B4 point-to-point-mac Auto
spanning-tree B5 point-to-point-mac Auto
spanning-tree B6 point-to-point-mac Auto
spanning-tree B7 point-to-point-mac Auto
spanning-tree B8 point-to-point-mac Auto
spanning-tree B9 point-to-point-mac Auto
spanning-tree B10 point-to-point-mac Auto
spanning-tree B11 point-to-point-mac Auto
spanning-tree B12 point-to-point-mac Auto
spanning-tree B13 point-to-point-mac Auto
spanning-tree B14 point-to-point-mac Auto
spanning-tree B15 point-to-point-mac Auto
spanning-tree B16 point-to-point-mac Auto
spanning-tree C1 point-to-point-mac Auto
spanning-tree C3 point-to-point-mac Auto
spanning-tree C4 point-to-point-mac Auto
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree Trk16 priority 4
spanning-tree priority 0
ip ssh
password manager
password operator

Richard Penhale
Occasional Advisor

Re: Procurve 5308 CPU utilization goes through the roof

According to PCM+ we seem to be experiencing large numbers of STP instances across all switches despite it being enabled on all switches? Ports are blocked and then immediately reactivated?
Pieter 't Hart
Honored Contributor

Re: Procurve 5308 CPU utilization goes through the roof

it's more readable to put the config in an attachment instead of directly in the post.

but apart from that i see no reference to stp mstp rstp is this config ?

with MSTP each instance determines the stp topology for a number of vlan's. You may need to check mstp on both switches have the same vlan's configured.

as you use "Wless-APs", one of them may have "bridging" enabled wich may create a loop.
Richard Penhale
Occasional Advisor

Re: Procurve 5308 CPU utilization goes through the roof

Point taken about attaching the config, I will double check the STP settings as it is enabled but the force-version command seems to have disappeared. I will also check out the Wireless APs to make sure none of these devices are causing loops, but we only have one wireless bridge on site so would be surprised if this was the issue especially as it has been in place for many years and the issue has only occurred in the last few weeks. Thanks for the suggestions though.
Dennis Handly
Acclaimed Contributor

Re: Procurve 5308 CPU utilization goes through the roof

>It's more readable to put the config in an attachment

 

Unfortunately you can no longer do that and must add a .jpg suffix to the end.  :-(