ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Removing old switch but phones go offline when its disconected

jgs240
Occasional Contributor

Removing old switch but phones go offline when its disconected

I have taken over a position that had a few projects that were started before me, one of them is retiring the old core switch.  I have removed all connections from the core switch except for the trunk that connects the old core to the new core.  

the problem I run into is when I disconect this trunk from old core to new core, our IP phones lose connectivity.  We use static routing, I have double checked the routes and updated them to point to the correct next hop but this has not made a difference.  Is there something else in the old core switch config that I could be missing in thew new?

The configs posted below are current running configs, which means the static route in question (192.168.9.0 255.255.255.0 192.168.0.180) is still in there.  When I change this route to point to the correct next hop (192.168.5.3) the phones stop working.  

 

OLD CORE CONFIG (redacted)

Running configuration:

; J8698A Configuration Editor; Created on release #K.13.25

hostname ""
snmp-server location " "
time timezone
time daylight-time-rule Continental-US-and-Canada
no web-management
web-management ssl
no telnet-server
ip access-list extended "100"
   10 permit ip 192.168.0.0 0.0.0.255 192.168.9.0 0.0.0.255
   20 permit ip 192.168.9.0 0.0.0.255 192.168.0.0 0.0.0.255
   exit
ip access-list extended "allow"
   10 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
   11 permit tcp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
   12 permit udp 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
   exit
ip access-list standard "1"
   10 permit 0.0.0.0 255.255.255.255
   exit
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8702A
module 5 type J8702A
module 6 type J8702A
module 7 type J8702A
module 8 type J8702A
module 9 type J8702A
module 10 type J8702A
module 11 type J8702A
module 12 type J8702A
interface A11
   disable
exit
interface C2
   name "Svc Con "
exit
interface C4
   name "Svc Con "
exit
interface C7
   name ""
   speed-duplex 10-half
exit
interface C8
   name "Svc Con "
exit
interface C9
   name "Svc Con "
exit
interface C10
   name "Svc Con "
exit
interface C12
   name "Svc Con ESX01b"
exit
interface C13
   name " Prod"
exit
interface C14
   name " iSCSI"
exit
interface C15
   name " Prod"
exit
interface C16
   name " iSCSI"
exit
interface C17
   name " Prod"
exit
interface C18
   name " iSCSI"
exit
interface C19
   name " Prod"
exit
interface C20
   name " iSCSI "
exit
interface C21
   name " Prod"
exit
interface C23
   name " Prod"
exit
interface D1
   name " Vmotion1"
exit
interface D2
   name " iSCSI"
exit
interface D3
   name " Vmotion2"
exit
interface D4
   name " iSCSI"
exit
interface D5
   name " Vmotion1"
exit
interface D7
   name " Vmotion2"
exit
interface D9
   name " Vmotion1"
exit
interface D10
   name " Mirror"
exit
interface D11
   name " Vmotion2"
exit
interface D12
   name " Mirror"
exit
interface D13
   name " iLo"
exit
interface D14
   name " iLo"
exit
interface D15
   name " iLo"
exit
interface D16
   name " iLo"
exit
interface D17
   name " iLo"
exit
interface B6
   speed-duplex auto-1000
exit
interface B10
   speed-duplex auto-1000
exit
interface B11
   name ""
   speed-duplex 10-half
exit
interface B19
   name ""
   speed-duplex 10-half
exit
trunk B13,B15,B17 Trk1 Trunk
ip default-gateway 192.168.0.26
ip routing
ip directed-broadcast
ip zero-broadcast
ip udp-bcast-forward
timesync sntp
sntp unicast
snmp-server community "" Unrestricted
snmp-server host 192.168.0.196 ""
vlan 1
   name "DEFAULT_VLAN"
   untagged A1-A2,A4-A13,A15-A24,B1-B12,B14,B16,B18-B24,C1-C13,C15,C17,C19-C21,C23-C24,D13-D24,E1-E24,F1-F24,G1-G24,H1-H24,I1-I24,J1-J24,K1-K24,L1-L24
   ip address 192.168.0.180 255.255.255.0
   tagged Trk1
   no untagged A3,A14,C14,C16,C18,C22,D1-D12
   ip access-group "1" in
   ip access-group "1" out
   exit
vlan 160
   name ""
   untagged C14,C16,C18,C22,D2,D4,D6,D8
   no ip address
   exit
vlan 162
   name ""
   untagged A3,D1,D3,D5,D7,D9,D11
   ip address 10.30.30.26 255.255.255.0
   tagged A2,Trk1
   exit
vlan 161
   name "Partner/Mirror161"
   untagged D10,D12
   no ip address
   exit
vlan 109
   name "Phonesubnet"
   qos priority 6
   ip forward-protocol udp 192.168.0.235 5060
   ip forward-protocol udp 192.168.0.235 33434
   ip forward-protocol udp 192.168.9.51 33434
   ip address 192.168.9.1 255.255.255.0
   tagged A1-A24,B1-B12,B14,B16,B18-B24,C1-C13,C15,C17,C19-C21,C23-C24,D13-D24,Trk1
   voice
   ip access-group "allow" in
   ip access-group "allow" out
   exit
vlan 2
   name ""
   no ip address
   exit
vlan 20
   name ""
   untagged A14
   tagged Trk1
   no ip address
   exit
vlan 47
   name ""
   ip address 172.17.24.2 255.255.252.0
   tagged A2-A3,Trk1
   exit
vlan 30
   name ""
   ip address 172.17.30.3 255.255.255.0
   tagged A2,Trk1
   exit
vlan 3
   name ""
   tagged Trk1
   no ip address
   exit
vlan 23
   name ""
   ip address 172.17.20.2 255.255.255.0
   tagged Trk1
   exit
vlan 25
   name ""
   tagged Trk1
   no ip address
   exit
vlan 69
   name ""
   tagged Trk1
   no ip address
   exit
vlan 71
   name ""
   ip address 172.17.8.180 255.255.252.0
   tagged A4,Trk1
   exit
vlan 5
   name ""
   ip address 192.168.5.199 255.255.255.0
   tagged Trk1
   exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
aaa authentication login privilege-mode
aaa authentication console enable radius local
aaa authentication ssh login radius local
aaa authentication ssh enable radius local
radius-server key redacted
radius-server host 172.17.0.59 key 'pf5^5V2L*37v' auth-port 1645 acct-port 1646
mirror 1 port C24
logging 192.168.0.196
sflow 1 destination 192.168.0.196 2055
sflow 1 sampling A1-A24,B1-B12,B14,B16,B18-B24,C1-C23 500
sntp server priority 1 192.168.0.208
ip dns server-address priority 1 192.168.0.25
ip route 0.0.0.0 0.0.0.0 192.168.5.3
ip route 10.100.0.0 255.255.255.0 192.168.5.3
ip route 172.17.0.0 255.255.0.0 192.168.0.26
ip route 172.17.30.0 255.255.255.0 172.17.30.1
ip route 192.168.20.0 255.255.255.0 172.17.30.100
ip route 192.168.30.0 255.255.255.0 172.17.30.100
ip route 192.168.40.0 255.255.255.0 172.17.30.100
ip route 192.168.50.0 255.255.255.0 172.17.30.100
ip route 192.168.60.0 255.255.255.0 172.17.30.100
ip route 192.168.70.0 255.255.255.0 172.17.30.100
ip route 192.168.80.0 255.255.255.0 172.17.30.100
ip route 192.168.90.0 255.255.255.0 172.17.30.100
ip route 192.168.120.0 255.255.255.0 172.17.30.100
ip route 192.168.140.0 255.255.255.0 172.17.30.100
interface A1
   monitor all Both mirror 1
   exit
interface A2
   monitor all Both mirror 1
   exit
interface A3
   monitor all Both mirror 1
   exit
interface A4
   monitor all Both mirror 1
   exit
interface A5
   monitor all Both mirror 1
   exit
interface A6
   monitor all Both mirror 1
   exit
interface A7
   monitor all Both mirror 1
   exit
interface A8
   monitor all Both mirror 1
   exit
interface A9
   monitor all Both mirror 1
   exit
interface A10
   monitor all Both mirror 1
   exit
interface A11
   monitor all Both mirror 1
   exit
interface A12
   monitor all Both mirror 1
   exit
interface A13
   monitor all Both mirror 1
   exit
interface A15
   monitor all Both mirror 1
   exit
interface A16
   monitor all Both mirror 1
   exit
interface A17
   monitor all Both mirror 1
   exit
interface A18
   monitor all Both mirror 1
   exit
interface A19
   monitor all Both mirror 1
   exit
interface A20
   monitor all Both mirror 1
   exit
interface A21
   monitor all Both mirror 1
   exit
interface A22
   monitor all Both mirror 1
   exit
interface A23
   monitor all Both mirror 1
   exit
interface A24
   monitor all Both mirror 1
   exit
interface B1
   monitor all Both mirror 1
   exit
interface B2
   monitor all Both mirror 1
   exit
interface B3
   monitor all Both mirror 1
   exit
interface B4
   monitor all Both mirror 1
   exit
interface B5
   monitor all Both mirror 1
   exit
interface B6
   monitor all Both mirror 1
   exit
interface B7
   monitor all Both mirror 1
   exit
interface B8
   monitor all Both mirror 1
   exit
interface B9
   monitor all Both mirror 1
   exit
interface B10
   monitor all Both mirror 1
   exit
interface B11
   monitor all Both mirror 1
   exit
interface B12
   monitor all Both mirror 1
   exit
interface B14
   monitor all Both mirror 1
   exit
interface B16
   monitor all Both mirror 1
   exit
interface B18
   monitor all Both mirror 1
   exit
interface B19
   monitor all Both mirror 1
   exit
interface B20
   monitor all Both mirror 1
   exit
interface B21
   monitor all Both mirror 1
   exit
interface B22
   monitor all Both mirror 1
   exit
interface B24
   monitor all Both mirror 1
   exit
interface C1
   monitor all Both mirror 1
   exit
interface C2
   monitor all Both mirror 1
   exit
interface C3
   monitor all Both mirror 1
   exit
interface C4
   monitor all Both mirror 1
   exit
interface C5
   monitor all Both mirror 1
   exit
interface C6
   monitor all Both mirror 1
   exit
interface C7
   monitor all Both mirror 1
   exit
interface C8
   monitor all Both mirror 1
   exit
interface C9
   monitor all Both mirror 1
   exit
interface C10
   monitor all Both mirror 1
   exit
interface C11
   monitor all Both mirror 1
   exit
interface C12
   monitor all Both mirror 1
   exit
interface C13
   monitor all Both mirror 1
   exit
interface C15
   monitor all Both mirror 1
   exit
interface C17
   monitor all Both mirror 1
   exit
interface C19
   monitor all Both mirror 1
   exit
interface C20
   monitor all Both mirror 1
   exit
interface C21
   monitor all Both mirror 1
   exit
interface C23
   monitor all Both mirror 1
   exit
interface D13
   monitor all Both mirror 1
   exit
interface D14
   monitor all Both mirror 1
   exit
interface D15
   monitor all Both mirror 1
   exit
interface D16
   monitor all Both mirror 1
   exit
interface D17
   monitor all Both mirror 1
   exit
interface D18
   monitor all Both mirror 1
   exit
interface D19
   monitor all Both mirror 1
   exit
interface D20
   monitor all Both mirror 1
   exit
interface D21
   monitor all Both mirror 1
   exit
interface D22
   monitor all Both mirror 1
   exit
interface D23
   monitor all Both mirror 1
   exit
interface D24
   monitor all Both mirror 1
   exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree priority 0
vlan 1
   ip rip 192.168.0.180
   exit
vlan 30
   ip rip 172.17.30.3
   exit
vlan 109
   ip rip 192.168.9.1
   exit
vlan 162
   ip rip 10.30.30.26
   exit
no autorun
password 
password 

 

NEW CORE CONFIG

Running configuration:

; J9851A Configuration Editor; Created on release #KB.15.15.0006
; Ver #05:18.7f.ff.3f.ef:4d
hostname ""
module A type j9535a
module B type j9534a
module C type j9534a
module D type j9534a
module G type j9538a
module I type j9538a
module J type j9534a
module K type j9538a
module L type j9534a
mirror 1 port J9
mirror 2 port J5
mirror 3 port L9
trunk L2,L4,L6 trk1 trunk
trunk G3-G4 trk2 lacp
trunk G1-G2 trk3 lacp
radius-server host 172.17.0.59 key "redacted" acct-port 1646 auth-port 1645
radius-server key "redacted"
sflow 1 destination 172.17.0.150
sflow 1 polling A1-A24,B1-B24,C1-C24,D1-D24,G5-G8,I1-I8,J1-J24,K1-K8,L1,L3,L5,L7-L24,Trk1-Trk3 20
sflow 1 sampling A1-A24,B1-B24,C1-C24,D1-D24,G5-G8,I1-I8,J1-J24,K1-K8,L1,L3,L5,L7-L24,Trk1-Trk3 128
timesync sntp
sntp unicast
sntp server priority 1 192.168.0.25
no telnet-server
time daylight-time-rule continental-us-and-canada
time timezone
no web-management
web-management ssl
ip dns server-address priority 1 192.168.0.25
ip route 0.0.0.0 0.0.0.0 192.168.5.3
ip route 10.100.0.0 255.255.255.0 192.168.5.3
ip route 10.100.252.5 255.255.255.255 172.17.30.101
ip route 10.100.252.6 255.255.255.255 172.17.30.101
ip route 10.204.0.0 255.255.0.0 192.168.5.3
ip route 10.204.96.0 255.255.254.0 172.17.30.101
ip route 10.204.100.0 255.255.254.0 172.17.30.101
ip route 170.209.0.2 255.255.255.255 192.168.0.215
ip route 170.209.0.2 255.255.255.255 192.168.0.216
ip route 170.209.0.3 255.255.255.255 192.168.0.215
ip route 170.209.0.3 255.255.255.255 192.168.0.216
ip route 172.16.20.0 255.255.255.0 172.17.20.254
ip route 172.16.30.0 255.255.255.0 172.17.20.254
ip route 172.17.100.0 255.255.255.0 172.17.30.100
ip route 172.17.101.0 255.255.255.0 172.17.30.100
ip route 192.168.0.0 255.255.255.0 192.168.5.3
ip route 192.168.9.0 255.255.255.0 192.168.0.180
ip route 192.168.20.0 255.255.255.0 172.17.30.100
ip route 192.168.30.0 255.255.255.0 172.17.30.100
ip route 192.168.40.0 255.255.255.0 172.17.30.100
ip route 192.168.50.0 255.255.255.0 172.17.30.100
ip route 192.168.60.0 255.255.255.0 172.17.30.100
ip route 192.168.70.0 255.255.255.0 172.17.30.100
ip route 192.168.80.0 255.255.255.0 172.17.30.100
ip route 192.168.90.0 255.255.255.0 172.17.30.100
ip route 192.168.120.0 255.255.255.0 172.17.30.100
ip route 192.168.130.0 255.255.255.0 172.17.30.100
ip route 192.168.140.0 255.255.255.0 172.17.30.100
ip routing
ip udp-bcast-forward
interface G1
   name " _Connection_01"
   exit
interface G2
   name " _Connection_02"
   exit
interface G3
   name " _Connection"
   exit
interface G4
   name " _Connection_2"
   exit
interface J17
   name " "
   exit
interface J20
   name " _ "
   exit
interface J21
   name ""
   exit
interface J22
   name ""
   exit
interface J23
   name ""
   exit
interface J24
   name ""
   exit
interface K1
   name " _Default_ "
   exit
interface K2
   name " _Default_ "
   exit
interface L6
   name " "
   exit
interface L13
   name " _1"
   exit
interface L14
   name " _2"
   exit
interface L18
   disable
   exit
interface L20
   name " _ "
   speed-duplex 100-full
   exit
interface L22
   name "  "
   exit
interface Trk3
   unknown-vlans disable
   exit
snmp-server community "" unrestricted
snmp-server location ""
aaa authentication login privilege-mode
aaa authentication console enable radius local
aaa authentication ssh login radius local
aaa authentication ssh enable radius local
oobm
   ip address dhcp-bootp
   exit
uplink-failure-detection
router ospf
   area backbone
   redistribute connected
   redistribute static
   redistribute rip
   enable
   exit
router rip
   redistribute connected
   exit
vlan 1
   name "DEFAULT_VLAN"
   no untagged B1,B13-B23,I1-I5,I7-I8,J1-J12,J15-J18,J20-J24,L3,L10,L13-L18,L20-L21,L24
   untagged A1-A24,B2-B12,B24,C1-C24,D1-D24,G5-G8,J19,K1-K8,L5,L7,L9,L11,L19,L23,Trk2-Trk3
   tagged I6,J13-J14,L1,L8,L12,L22,Trk1
   ip address 192.168.0.26 255.255.255.0
   ip proxy-arp
   exit
vlan 3
   name " "
   untagged I5-I6,J4,J6,J8,J10,J12,J18
   tagged J13-J14,K1-K8,L1,L22,Trk1-Trk2
   ip address 172.17.0.1 255.255.252.0
   ip proxy-arp
   ip rip 172.17.0.1
   exit
vlan 5
   name ""
   untagged J17
   tagged Trk1
   ip address 192.168.5.1 255.255.255.0
   exit
vlan 20
   name ""
   tagged Trk1
   no ip address
   exit
vlan 23
   name " _ "
   untagged I1-I4,J21-J24,L12,L15-L18
   tagged L1,L22,Trk1
   ip address 172.17.20.1 255.255.252.0
   ip proxy-arp
   ip rip 172.17.20.1
   exit
vlan 25
   name "Phone_Subnet"
   tagged L1,L8,L10,L12-L14,L22,Trk1
   ip address 172.17.12.1 255.255.252.0
   ip proxy-arp
   ip rip 172.17.12.1
   voice
   exit
vlan 30
   name  _ "
   untagged J1-J3,J5,J7,J9,J11,J15-J16,J20,L1,L8,L13-L14,L20-L22
   tagged L23,Trk1-Trk3
   ip address 172.17.30.1 255.255.255.0
   ip proxy-arp
   ip rip 172.17.30.1
   exit
vlan 47
   name " "
   untagged B1,I7-I8
   tagged L23-L24,Trk1
   ip address 172.17.24.1 255.255.252.0
   ip proxy-arp
   ip rip 172.17.24.1
   exit
vlan 69
   name " "
   tagged L1,L8,L10,L13-L14,L22,Trk1
   ip address 172.17.16.1 255.255.252.0
   ip proxy-arp
   ip rip 172.17.16.1
   exit
vlan 71
   name "computer_subnet"
   untagged J13-J14,L10
   tagged B24,I5-I6,J17,K1-K8,L8,L12,L22,Trk1-Trk3
   ip address 172.17.8.1 255.255.252.0
   ip proxy-arp
   ip helper-address 172.17.0.10
   ip rip 172.17.8.1
   exit
vlan 101
   name ""
   untagged B13,B15,B17,B19,B21,B23
   no ip address
   exit
vlan 103
   name ""
   untagged B14,B16,B18,B20,B22
   tagged B24
   no ip address
   exit
vlan 109
   name "Old_Phone_Subnet"
   tagged A16,A18,A20,A22,A24,K5,L5,L7,L9,L11,Trk1-Trk3
   no ip address
   ip forward-protocol udp 192.168.0.235 5060
   ip forward-protocol udp 192.168.0.235 33434
   ip forward-protocol udp 192.168.9.51 33434
   monitor all both mirror 1
   monitor all both mirror 2
   monitor all both mirror 3
   qos priority 6
   voice
   exit
vlan 160
   name ""
   untagged L3
   no ip address
   exit
vlan 162
   name ""
   untagged L24
   tagged L20,L23,Trk1
   ip address 10.30.30.25 255.255.255.0
   ip proxy-arp
   ip rip 10.30.30.25
   exit
vlan 201
   name ""
   no ip address
   exit
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator
3 REPLIES
AbeAbe
Valued Contributor

Re: Removing old switch but phones go offline when its disconected

Hi,

have you changed the routes on the device

192.168.5.3

this device needs to know it's way back to your network

 

hth

alex

jgs240
Occasional Contributor

Re: Removing old switch but phones go offline when its disconected

Thank you for the suggestion, yes that device is out Firewall and it has good routes to get back.  

After posting my comment I was scrutinizing the configs a little closer and I realized the default gateway for all phones is configured on the OLD core switch (VLAN 109, IP 192.168.9.1), I did not see this before.  So when I would disconect the old core switch, I was also disconecting all phones from their default gateway.

So now the plan is to remove 9.1 from the old and put it on the new, update the static route to point to the correct next hop &  disconect the OLD core again and test connectivity.  I beleive that should fix this issue, anyone see a problem with this logic or something else I missed?

Vince-Whirlwind
Honored Contributor

Re: Removing old switch but phones go offline when its disconected

If it is your core switch, then you would need to replicate all IP addressing identically onto the new core switch. Your config doesn't appear to do this.

Of course this means you can't have both cores running with the correct config simultaneously.

BUT, I have done this before, migrating all distribution and edge switches from an old pair of core switches to a new pair with no outage. You could do the same thing.

1/ Configure the old core spanning tree priority as 4K, new core as 8k. (Assuming your distribution edge are all higher numbers than this).

2/ Connect the two cores, trunk all VLANs across between them. Test connectivity on all VLANs from new core.

3/ Configure all your switchports - uplink interfaces, correct VLAN membership etc...

4/ Disconnect all your redundant uplinks from the old core (just leaving a single non-redundant "live" link) and patch them into the new core. Use LLDP to confirm you have them patched correctly.
     If the edge switches use spanning-tree for redundancy, use spanning-tree to determine the "blocked" links and disconnect those ones.
     If any edge switch has no redundancy, request an outage for each affected area, migrate their uplinks one by one, testing each as you go.

5/ Swap spanning-tree priorities on the cores by changing the old core to 12k (assuming the rest of your network is higher than this). Your layer2 networks are now all migrated to the new core. Make sure the old core uplinks are no longer passing any traffic.

6/ Configure VRRP on all routed VLAN interfaces on the old core, nominating the physical address as the VIP.

7/ Configure your new core using a different IP address on each routed VLAN interface. Configure VRRP on each of these VLAN interfaces, nominating the old core's physical address as the VIP.
Make sure VRRP is active now across the 2 cores.

8/ Replicate all Layer3 configuration onto the new core, I guess that is mainly just routes.

9/ Manually failover your VRRP so that the new core is your active VRRP. Depending on the switch, you could do this by changing each new core VLAN interface to be "master", or by changing the VRRP priority and turning pre-empt to on.

10/ Repatch remaining uplinks from the old core to the new core.

11/ Switch off old core.