cancel
Showing results for 
Search instead for 
Did you mean: 

Switch QOS

christianferraz
Occasional Visitor

Switch QOS

I have a distribuition switch and vlans 5 for videoconferency and vlan 1100 for voip, my configuration is:

traffic classifier MatchAny operator and
if-match any
traffic classifier VOIP operator and
if-match service-dot1p 5
#
traffic behavior VOIP
remark dot1p 5
accounting packet
remark dscp cs6
#
qos policy VOIP
classifier VOIP behavior VOIP
#
user-group system
group-attribute allow-guest
#
local-user admin
password cipher $c$3$IyfqjJMUfaQ234ySLLoZv6MuTNFMlfBQHSP8mwc=
authorization-attribute level 3
service-type terminal
service-type web
local-user adminssh
password cipher $c$3$NpXJDM30S5zAW6D03o9atRlu8dwa0p1wQVwNVR3ygg==
authorization-attribute level 3
service-type ssh
#
stp mode pvst
stp instance 0 root primary
undo stp vlan 39 enable
stp vlan 1 root primary
stp enable
#
cwmp
undo cwmp enable
#
interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan all
link-aggregation mode dynamic
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.100.55 255.255.224.0
#
interface Vlan-interface1300
ip address 10.42.233.2 255.255.252.0
#
interface GigabitEthernet1/0/1
port link-mode bridge
description HDIA
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 813 1000 1100 1200 1300 1600
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/2
port link-mode bridge
description LAC
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 802 1000 1100 1200 1300 1600
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/3
port link-mode bridge
description SEMA
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 to 801 1000 1100 1200 1300 1600
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/4
port link-mode bridge
description AMBCLMC
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 826 1000 1100 1300
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/5
port link-mode bridge
description AMBREC
port link-type trunk
port trunk permit vlan 1 600 700 800 811 827 1000 1100 1200 1300
port trunk permit vlan 1600
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/6
port link-mode bridge
description RENAL
port link-type trunk
port trunk permit vlan 1 600 700 800 809 to 810 1000 1100 1200 1300 1500
port trunk permit vlan 1600
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/7
port link-mode bridge
description AMBREU
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 805 818 1000 1100 1200 1300
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/8
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 825 1000 1100 1300
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/9
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 806 1000 1100 1200 1300 1600
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/10
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 5 600 700 800 808 1000 1100 1200 1300 1600
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/11
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 5 600 700 800 820 1000 1100 1200 1300
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/12
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 823 1000 1100 1200 1300
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/13
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 803 820 1000 1100 1200 1300
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/14
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 804 817 1000 1100 1200 1300
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/15
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 to 38 40 to 4094
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/16
port link-mode bridge
description AMBORT
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 812 1000 1100 1200 1300 1600
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/17
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 807 1000 1100 1300
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/18
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 821 1000 1100 1200 1300
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/19
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 805 1000 1100 1200 1300
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/20
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 819 1000 1100 1300
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/21
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 600 700 800 814 to 816 1000 1100 1200 1300 1600
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/22
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 824 1000 1100 1300
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/23
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 600 700 800 804 1000 1100 1200 1300
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface GigabitEthernet1/0/24
port link-mode bridge
port link-type trunk
port trunk permit vlan 1 600 700 800 822 1000 1100 1200 1300 1600
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet1/0/25
port link-mode bridge
port link-type trunk
port trunk permit vlan all
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/26
port link-mode bridge
port link-type trunk
port trunk permit vlan all
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/27
port link-mode bridge
port link-type trunk
port trunk permit vlan all
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/0/28
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 39 100 600 700 800 813 821 1000 1100 1200
port trunk permit vlan 1300 1600
speed 1000
duplex full
qos wfq byte-count
qos wfq 6 group sp
qos bandwidth queue 5 min 512
qos bandwidth queue 6 min 1024
qos trust dot1p

 

But the results is:

[SWHPDC02]dis qos queue-statistics interface GigabitEthernet 1/0/1
Interface: GigabitEthernet1/0/1
Direction: Outbound

Queue   Queued packets        Passed packets            Dropped packets                 Passed rate(bps) 
    0                   0                                241                                   0                                         0

     1                   0                                  0                                    0                                          0

     2                   0                          42,546,175                             0                                        396,848

     3                   0                              11,977                                 0                                           0

     4                   0                                 0                                     0                                           0

     5                   0                                 0                                     0                                            0

     6                  0                                  0                                    0                                            0

     7                  0                            2,281,068                              0                                          960

 

Where is the problem?

1 REPLY
Vince-Whirlwind
Honored Contributor

Re: Switch QOS

If I can summarise how your QoS appears to be setup, you have:
 - a classifier matching on IP precedence 5 as "VOIP"
 - a behaviour for VOIP that remarks to IP Precedence 5 (which it already was), and the wrong DSCP value (CS6, should be EF)
 - no policy anywhere that implements this behaviour
 - a "trust" statement on each interface

Your ports stats reflect the trusted values.

Using the trust statement should be the first thing you try - you need to ensure the endpoints are tagging correctly - which should be EF (5) for voice and AF41 (4) for video.
If you can't trust your endpoints, then you need to match on ?something? - maybe IP subnet - to create your two traffic classes "Video" & "Voice", then remark to the correct values, and apply the policy to all interfaces.