ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Syslog Configuration Trouble

Phoenix54c
Occasional Visitor

Syslog Configuration Trouble

Hi,

I am having trouble getting my Procurve 2920 (WB.16.01.0004) to log to my syslog server.

As I understand, everything in the switch's event log can be duplicated on the syslog server.  Yet, after configuring the switch, my server does not receive these messages.  The only syslog message I receive from the switch is a single "info" notifcation at the moment I enable syslog using the logging [ip_addr] command.  I am configuring the switch in this way:

---

HP-SWITCH(config)# logging system-module all-pass

HP-SWITCH(config)# logging severity debug

HP-SWITCH(config)# logging [syslog_server_ip]

------

The sh debug command reflects the correct settings for my syslog server.  However, the messages don't appear.  

I also ran show syslog stat , and verified that the switch is only sending that one intial syslog message.  I have also tried with different system modules, e.g. "mgr," with no success.  What am I doing wrong?

 

1 REPLY
TerjeAFK
Respected Contributor

Re: Syslog Configuration Trouble

We use Syslog on our 2920 switches without any problems (same software version as you). Have you configured the syslog facility? We use "logging facility local2" on our switches so we can separate switch logs from other devices.

We do not specify any modules in our config, and the switch seems by default to log everything to syslog.