ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

kgoddard
Occasional Visitor

Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

Here is my scenerio and issue:

The 2650-PWR works fine, I should say the VLAN's are working as they should, if I plug a phone into this switch, it uses the ip helper address to get the intiial DHCP address and then it uses option 132 to set the VLAN scope which is 192.168.x.x  address.    This alll works as advertised.

Now here is the problem, the 2810-48G although it is trunked from port 47 to port 50 on the 2650-PWR and the trunks tagged for the voice and untagged for the default_vlan, I get nada, nothing, you can see it grab the first address from the DHCP server, that being the PC network for the default_vlan address 10.0.x.x, but then it never picks up the vlan tag to use option 132 and set the 192.168.x.x address.  Thus no go!  

here is output from sh vlans

 802.1Q VLAN ID Name         Status       Voice Jumbo
  -------------- ------------ ------------ ----- -----
  1              DEFAULT_VLAN Port-based   No    No
  200            Voice        Port-based   Yes   No

here is the output for sh vlan ports 1-48

 

Status and Counters - VLAN Information - for ports 1-48

  802.1Q VLAN ID Name         Status       Voice Jumbo
  -------------- ------------ ------------ ----- -----
  1              DEFAULT_VLAN Port-based   No    No
  200            Voice        Port-based   Yes   No

Here is the 2650-PWR Layer 3 Switch Config

Startup configuration:

; J8165A Configuration Editor; Created on release #H.10.38

hostname "ProCurve Switch 2650-PWR"
qos dscp-map 011000 priority 7
qos dscp-map 101110 priority 6
interface 1
   no lacp
exit
interface 2
   no lacp
exit
interface 3
   no lacp
exit
interface 4
   no lacp
exit
interface 5
   no lacp
exit
interface 6
   no lacp
exit
interface 7
   no lacp
exit
interface 8
   no lacp
exit
interface 9
   no lacp
exit
interface 10
   no lacp
exit
interface 11
   no lacp
exit
interface 12
   no lacp
interface 13
   no lacp
exit
interface 14
   no lacp
exit
interface 15
   no lacp
exit
interface 16
   no lacp
exit
interface 17
   no lacp
exit
interface 18
   no lacp
exit
interface 19
   no lacp
exit
interface 20
   no lacp
exit
interface 21
   no lacp
exit
interface 22
   no lacp
exit
interface 23
   no lacp
exit
interface 24
   no lacp
exit
interface 25
   no lacp
exit
interface 26
   no lacp
exit
interface 27
   no lacp
exit
interface 28
   no lacp
exit
interface 29
   no lacp
exit
interface 30
   no lacp
exit
interface 31
   no lacp
exit
interface 32
   no lacp
exit
interface 33
   no lacp
exit
interface 34
   no lacp
exit
interface 35
   no lacp
exit
interface 36
   no lacp
exit
interface 37
   no lacp
exit
interface 38
   no lacp
exit
interface 39
   no lacp
exit
interface 40
   no lacp
exit
interface 41
   no lacp
exit
interface 42
   no lacp
exit
interface 43
   no lacp
exit
interface 44
   no lacp
exit
interface 45
   no lacp
exit
interface 46
   no lacp
exit
interface 47
   no lacp
exit
interface 48
   no lacp
exit
interface 49
   no lacp
exit
ip default-gateway 10.0.2.3
sntp server 10.0.2.10
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-50
   ip address 10.0.2.70 255.255.255.0
   exit
vlan 200
   name "Voice"
   ip address 192.168.200.1 255.255.255.0
   ip helper-address 10.0.2.10
   tagged 1-47,49-50
   voice
   exit
qos type-of-service diff-services
ip route 0.0.0.0 0.0.0.0 10.0.2.3
spanning-tree

Here is the Layer 2 ProCurve Switch 2810-48G Switch

Running configuration:

; J9022A Configuration Editor; Created on release #N.11.06

hostname "ProCurve Switch 2810-48G"
snmp-server contact "Ken Goddard"
snmp-server location "Blackhawk "
max-vlans 2
interface 47
   lacp Passive
exit
ip default-gateway 10.0.2.70
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-48
   ip address 10.0.2.14 255.255.255.0
   exit
vlan 200
   name "Voice"
   no ip address
   tagged 1-48
  voice
   exit
spanning-tree
13 REPLIES
parnassus
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)


kgoddard wrote:

...the 2810-48G although it is trunked from port 47 to port 50 on the 2650-PWR and the trunks tagged for the voice and untagged for the default_vlan, I get nada, nothing...

Just curious about how you "trunked"/"uplinked" your Switches...since both configurations look strange to me (maybe I'm wrong): on each Switch did you defined a new LAG (Link Aggregation Group) that has, let me say, three member ports (47, 49 and  50 / 20, 21 and 22) and did you set both LAGs to use LACP (IEEE 802.3ad) active?

That confiugration has been mirrored on both ends?

Interfaces indexes can be differents, it doesn't matter: consider that interfaces index numbers (47, 49 and 50 in one end, as your wrote) are not relevant but their quantity (3 ports) is...so, as example, 3 ports on one end and 3 ports on the other end, both groups of 3 ports are set through their respective LAG on their Switch and both LAGs are set to use LACP/Dynamic trunking. These three ports are so grouped into a new logical port (the BAGG) which can be configured with VLAN as you require, these three ports are uplinked togheter between the Switches and forms the (LCAP) Trunk between them.

Then you can check that BAGG (Bridge Aggregation Group) is defined as Trunk type and set VLAN tagged as required on that BAGG.

Was your trunking done that way or Am I really missing something evident in your configs?

kgoddard
Occasional Visitor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

Well yesterday trying to troubleshoot this issue I removed the trunks.   So the below is the corrected.

Not sure if I understand your questions by the way.

My understanding is Trunk's are for passing multiple VLAN traffic between switches and LACP LAG is for link aggregation for using multiple links across switches. 

hostname "ProCurve Switch 2810-48G"
snmp-server contact "Ken Goddard"
snmp-server location "Blackhawk "
max-vlans 2
trunk 48 Trk1 Trunk
ip default-gateway 10.0.2.70
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-47,Trk1
   ip address 10.0.2.14 255.255.255.0
   exit
vlan 200
   name "Voice"
   no ip address
   tagged 1-47,Trk1
   voice
   exit
spanning-tree
spanning-tree Trk1 priority 4

Now the trunks are in.   

Startup configuration:

; J8165A Configuration Editor; Created on release #H.10.38

hostname "ProCurve Switch 2650-PWR"
qos dscp-map 011000 priority 7
qos dscp-map 101110 priority 6
interface 1
   no lacp
exit
interface 2
   no lacp
exit
interface 3
   no lacp
exit
interface 4
   no lacp
exit
interface 5
   no lacp
exit
interface 6
   no lacp
exit
interface 7
   no lacp
exit
interface 8
  no lacp
exit
interface 9
   no lacp
exit
interface 10
   no lacp
exit
interface 11
   no lacp
exit
interface 12
   no lacp
exit
interface 13
   no lacp
exit
interface 14
   no lacp
exit
interface 15
   no lacp
exit
interface 16
   no lacp
exit
interface 17
   no lacp
exit
interface 18
 no lacp
exit
interface 19
   no lacp
exit
interface 20
   no lacp
exit
interface 21
   no lacp
exit
interface 22
   no lacp
exit
interface 23
   no lacp
exit
interface 24
   no lacp
exit
interface 25
   no lacp
exit
interface 26
   no lacp
exit
interface 27
   no lacp
exit
interface 28
 no lacp
exit
interface 29
   no lacp
exit
interface 30
   no lacp
exit
interface 31
   no lacp
exit
interface 32
   no lacp
exit
interface 33
   no lacp
exit
interface 34
   no lacp
exit
interface 35
   no lacp
exit
interface 36
   no lacp
exit
interface 37
   no lacp
exit
interface 38
   no lacp
exit
interface 39
   no lacp
exit
interface 40
   no lacp
exit
interface 41
   no lacp
exit
interface 42
   no lacp
exit
interface 43
   no lacp
exit
interface 44
   no lacp
exit
interface 45
   no lacp
exit
interface 46
   no lacp
exit
interface 47
   no lacp
exit
interface 48
  no lacp
exit
interface 50
   no lacp
exit
trunk 50 Trk1 Trunk
ip default-gateway 10.0.2.3
sntp server 10.0.2.10
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-49,Trk1
   ip address 10.0.2.70 255.255.255.0
   exit
vlan 200
   name "Voice"
   ip address 192.168.200.1 255.255.255.0
   ip helper-address 10.0.2.10
   tagged 1-47,49,Trk1
   voice
   exit
qos type-of-service diff-services
ip route 0.0.0.0 0.0.0.0 10.0.2.3
spanning-tree
spanning-tree Trk1 priority 4
parnassus
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

A LACP Trunk (multiple aggregated interfaces) can easily pass VLAN(s) too...it's just "more" than a Trunk (a physical port or a logical port can be set bot as a Trunk) made of a single link (single interface set as Trunk).

Just that.

I asked because you wrote you trunked from port 47 to 50 so I though you were referring to a Trunk made through a LAG (which is the logical port) made of ports 47+ 48 + 49 + 50 (4 members) or ports 47 + 49 +50 (3 members)...either a single port set as Trunk or a LAG set as Trunk (Static-> No Protocol or Dynamic->LACP) can carry the Untagged VLAN and various Tagged VLAN(s).

kgoddard
Occasional Visitor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

Yeah, thanks.    Below is how its trunked and tagged.

2810-48G switch   

config t

trunked 50 trk1 

vlan 200 tagged trk1

 2650-PWR switch   

config t

trunked 48 trk1 

vlan 200 tagged trk1

 

diagram

 

 

16again
Respected Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

In Cisco land, trunk means putting multiple VLANs over a single wire.
However, we are on HP territory, where a trunk means putting multiple ports into a bundle.
(Which in Cisco land is call etherchannel or portchannel....)

Bottomline: When connecting 2 HP switches on single ethernet connection, there's no need to define trunk port,  assigning tagged/untagged VLANs to a port is all that it takes.

HP and Cisco – VLANs and Trunks Confusion!

kgoddard
Occasional Visitor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

Thanks, I have tried it with & without the trunks, currently right now its set that way and no change.     Strange thing is that the phone when restarted goes out to the DHCP server gets the 10.0.x.x. address then drops that but never gets the 192.168.x.x address.

parnassus
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

What's about to check the DHCP Snooping configuration (if enabled)?

Vince-Whirlwind
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

I have suggestions, and a question:

First, the question: What is your DHCP server's default GW address?

Suggestions:
- enable LLDP on your switches ("lldp run").
- in your switch configs, add in a description against the important interfaces, eg, inter-switch links
- Your VLAN1 spans your core switch and incorporates 2 layer3 devices, this is poor design and can easily lead to confusion and difficulties in implementing changes and troubleshooting. If VLAN1 is going to have hosts on it, then it needs to be removed from the layer3-layer3 hop from core switch to router. This link should be in its own dedicated segment. Relevant routes then need to be created.
- Don't use VLAN1 at all if you can avoid it.

If I was asked to look at this, the first thing I would rule out would be that the DHCP server was not using the core switch as its default GW, and that the router was not aware of the .200. subnet.

closerwalk
Occasional Visitor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

To answer the question.   The gateway on the DHCP server is the layer 3 switch, and the layer 2 switch is pointed to that that same gateway.   

Vince-Whirlwind
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

OK, so the next step is to test the network.
You've skipped ahead to testing the DHCP option, but you don't yet know the network is OK, or that DHCP is OK.

On the 2810, configure one switchport as untagged in the Voice VLAN and attach your laptop to it with a static address in the Voice VLAN subnet. Test connectivity.

Then, switch your laptop to DHCP and make sure it can get an IP address via DHCP.

Only then add a phone to the 2810 and see if it can read the DHCP options correctly.

Vince-Whirlwind
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

I should have added: we don't know what your Voice DHCP scope details are. What is it handing out in Option003, for example?

closerwalk
Occasional Visitor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

DHCP

PC Scope 

10.0.2.x                    (This is the intial scope the phone grabs)

scope options

132  Voice 200   (Sets the VLAN 200 tag on the phone then is supposed to grab the voice scope_

 

Voice Scope

192.168.200.x

 

 

Vince-Whirlwind
Honored Contributor

Re: Trouble with VOIP Vlan ProCurve Switch 2650-PWR (L3) -> ProCurve Switch 2810-48G (L2)

And Option003?