ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN Tagging not working between HP 3500YL and Cisco 2950

Network24x7
Frequent Visitor

VLAN Tagging not working between HP 3500YL and Cisco 2950

Hi HP experts, 

I have been stuck at a migration from Cisco to HP vlan tagging issue.  I have port Fa0/2 on tagged (trunk) and connects to HP 3500 on its port 7.  The configuration are there but somehow multiple vlans don't pass over connection between Cisco 2950 & HP 3500.  Only 1 vlan passes at a time.  All vlans are allowed on trunk /tagged link on Cisco side. 802.1q tagging is encapsulated in cisco 2950.  Below is the configuration for Cisco and HP

Cisco 2950

Int f0/0

description ***connection to router***

Switchport mode trunk.

Int f0/2

Description ***Connection to HP-3500***

Switchport mode trunk

vlan 112

ip add 192.168.112.161 255.255.255.0

vlan 113

interface vlan 113

ip address 192.168.113.161 255.255.255.0

---------------------------------------------

HP-3500 CONFIG

int vlan 112

tagged 7

ip add 192.168.112.1/24

int vlan 113

ip add 192.168.113.1/24

tagged 7

vlan 1

untagged 7

I can't ping Cisco 2950 interface vlan 192.168.112.161 from HP 192.168.112.1 when untagged vlan 1  (native vlan), but when native vlan changed to 112 (vlan 112--->untagged 7) I can ping 192.168.112.1 but can't ping 192.168.113.1. If I remove untagged 1 and put untagged 7 for vlan 113 then I can ping 192.168.113.161 from HP but failed to ping 192.168.112.161. So it carries only 1 vlan at a time. 

1 REPLY
16again
Respected Contributor

Re: VLAN Tagging not working between HP 3500YL and Cisco 2950

switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan all
switchport nonegotiate

On cisco, try interface commands above.
Moreover, what is output on Cisco of commands
show vlan
show interfaces trunk