ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN communication issue on 3800 Series

jdeisman
Occasional Collector

VLAN communication issue on 3800 Series

We have just purchased a pair of 3800 J9586A switches running J9586A and stacked them, they installed fine with one exception.  Port 48 on both units does not seem to pass VLAN 100 along to the other switch on those ports, but every other VLAN I've tested works fine.  VLAN 1 is our default and management, untagged on both ends, while all the rest of the VLANs are tagged on the ports on both ends, the other switches being individual HP 2920 and an old 2824.  Port 46 and 47 are setup the same and VLAN 100 works fine on them, but I move the switch link to port 48 and VLAN 100 stops.  The ports were just setup as standard ports, but I also tried setting port 48 as a TRK port and setup the tagging on that but the same results.  Has anyone else heard of this or has had this happen to them?  A known bug?  I looked through the release notes of the newest firmare but didn't see anything stand out at me. 

5 REPLIES
TerjeAFK
Respected Contributor

Re: VLAN communication issue on 3800 Series

We use 3800 switches (no stacking though), and we have never had any problems with VLANs not working on tagged ports. Can you list the config for the two ports?

jdeisman
Occasional Collector

Re: VLAN communication issue on 3800 Series

They were connected via port 48 on stacks, moved them to 46 on same switch in stack and it works, move back to 48 and VLAN 100 fails again.

 

From Stack:

vlan 100
   name "VoIP"
   tagged 1/46-1/48,2/46-2/47,Trk1-Trk4,Trk7
   no ip address
   ip igmp
   exit

interface 2/46
   name "7th Floor"
   exit

interface 1/46
   name "1st Floor"
   exit

 

LLDP:

 2/46      | 9c b6 54 d0 ef 40         48     48        SWITCH17

  1/46      | 00 14 c2 45 40 e0         24     24        Switch 10

 

 

From 2920:

vlan 100
   name "VoIP"
   untagged 40
   tagged 1-39,41-44,48
   no ip address
   ip igmp
   exit

 

LLDP:

  48        | 5c b9 01 27 f3 0a         102    2/46      Stack01

 

 

From 2824:

interface 24
   name "Network"
exit

vlan 100
   name "VoIP"
   untagged 2,6,19
   no ip address
   tagged 1,4,7,24
   ip igmp
   exit

 

LLDP:

  24        | 5c b9 01 27 f3 0a         46     1/46      Stack01

 

Vince-Whirlwind
Honored Contributor

Re: VLAN communication issue on 3800 Series

My best guess is that you were patching the 2920 uplinks to port 48 on the 3800 you *thought* was switch1, but it was in fact 2/48, which doesn't have VLAN100 on it.

jdeisman
Occasional Collector

Re: VLAN communication issue on 3800 Series

I forgot I changed that port to TRK7 and tried and trunked it on other end and tagged the trunks to see if that would make a difference and it did not.  Forgot to remove trial trunk link on the test switch.  Both produbtion switches are currently on ports 46 and both working.  I will open a request with HP support to see if they have any ideas.  Thanks

DDGRUS
Occasional Advisor

Re: VLAN communication issue on 3800 Series

What version of firmware are you running?

We have several sites running stacks, one of which has 7 x 5 switch stacks all passing multiple VLANs. with no problems, they are currently on firmware KA 15.09.0009