ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

Yet Another inter vlan routing problem

MarcDesj
Visitor

Yet Another inter vlan routing problem

Hi all,

here's the picture, Procurve 2620, VLAN 1 unused, VLAN 10 Data, VLAN 20 VoIP.

The DHCP for both VLANs reside on the Data VLAN.  So pretty basic VLan routing.

The fun part, it worked fine and for some unknow reason "half" of the routing stop working.

I can reach any VLAN 20 ip address from VLAN 10 but not the opposite. More over, from VLAN 20 I can ping the default gateway.

I replicated the config on two other 2620 in the lab, just changed the ip addresses to fit the lab environnenmt, and it all work. So what's wrong in these two ? I'm puzzeled.

Running configuration:

time daylight-time-rule continental-us-and-canada #RA.15.08.0009
; Ver #02:13.2d:3c
hostname "SW01"
power-over-ethernet pre-std-detect
qos dscp-map 110000 priority 6
qos device-priority 10.20.111.20 dscp 101110
qos protocol arp priority 4
qos type-of-service diff-services
timesync sntp
ip route 0.0.0.0 0.0.0.0 10.120.1.1
ip routing
spanning-tree
router rip
redistribute connected
enable
exit
vlan 1
name "DEFAULT_VLAN"
no untagged 1-52
no ip address
exit
vlan 10
name "Data"
untagged 1-52
ip address 10.120.1.10 255.255.0.0
ip helper-address 10.120.2.101
exit
vlan 20
name "Voice"
tagged 1-52
ip address 10.20.111.1 255.255.255.0
ip helper-address 10.120.2.101
ip rip 10.20.111.1
qos dscp 101110
voice
exit
no dhcp config-file-update

SWC01# ping 10.120.2.101 source 10.20.111.1
Request timed out.
SW01# ping 10.120.1.1 source 10.20.111.1
10.120.1.1 is alive, time = 3 ms

SWC01# ping 10.20.111.20 source 10.120.1.10
10.20.111.20 is alive, time = 8 ms
SWCAP01#

3 REPLIES
Vince-Whirlwind
Honored Contributor

Re: Yet Another inter vlan routing problem

Your ping fails from the Voice VLAN to the DHCP server.
Your ping succeeds the Voice VLAN and the ?firewall?router?
Your ping succeeds between the Data VLAN and something on the Voice VLAN.

What makes you think this is a routing issue?

 

MarcDesj
Visitor

Re: Yet Another inter vlan routing problem

- The phones can't reach the DHCP server anymore. So it's not a problem as long as any of the phone reboot, then no ip address.

- New phones don't get DHCP addresses.


From 2 Lab switches, same model, same config (only changed the ip addresses):

sw2# ping 10.14.2.101 source 10.140.100.2
10.14.2.101 is alive, time = 17 ms
sw2#

(no problen reaching DHCP server 10.14.2..101 either from phones or laptop)

Vince-Whirlwind
Honored Contributor

Re: Yet Another inter vlan routing problem

Do a route print on the DHCP server.

Can the DHCP server ping anything off its own subnet?