ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

dhcp server 2012 and vlans

Highlighted
josegpe
Occasional Visitor

dhcp server 2012 and vlans

Greetings to all, I am new configuring sw HP, I have a sw 2930f, but I can not get the dhcp to deliver ip in the vlans that were created, only in vlan 1, I do not know what I'm doing wrong, can I route between vlans ?,

Thank you very much


hostname "COREDESIGN"
module 1 type jl262a
comware-help-display enable
gvrp
igmp filter-unknown-mcast
igmp lookup-mode ip
sntp unicast
ip dns server-address priority 1 8.8.8.8
ip route 0.0.0.0 0.0.0.0 10.105.64.1
ip route 10.10.10.0 255.255.255.0 vlan 100
ip route 10.105.65.0 255.255.255.0 vlan 2
ip route 10.105.66.0 255.255.255.0 vlan 3
ip route 10.105.67.0 255.255.255.0 vlan 4
ip route 10.105.68.0 255.255.255.0 vlan 5
ip router-id 10.105.64.254
ip routing
ip udp-bcast-forward
snmp-server community "public" unrestricted
router rip
  redistribute connected
  redistribute static route-map "inloop"
  enable
  exit
vlan 1
  name "DEFAULT_VLAN"
  no untagged 18,20,38
  untagged 1-17,19,21-37,39-48
  tagged 49-52
  ip address 10.105.64.254 255.255.255.0
  ip igmp
  ip rip 10.105.64.254
  exit
vlan 2
  name "Produccion"
  tagged 1,49-52
  ip address 10.105.65.254 255.255.255.0
  ip helper-address 10.105.64.72
  ip igmp
  ip rip 10.105.65.254
  exit
vlan 3
  name "Office"
  untagged 18
  tagged 1,3,49-52
  ip address 10.105.66.254 255.255.255.0
  ip bootp-gateway 10.105.64.254
  ip helper-address 10.105.64.72
  ip forward-protocol udp 10.105.64.72 timep
  ip igmp
  ip rip 10.105.66.254
  exit
vlan 4
  name "wifi"
  untagged 20
  tagged 1,18,38,49-52
  ip address 10.105.67.254 255.255.255.0
  ip helper-address 10.105.64.72
  ip igmp
  ip rip 10.105.67.254
  exit
vlan 5
  name "VLAN5"
  tagged 1,49-52
  ip address 10.105.68.254 255.255.255.0
  ip helper-address 10.105.64.72
  ip igmp
  ip rip 10.105.68.254
  exit
vlan 6
  name "prueba"
  tagged 1,49-52
  ip address 10.105.69.254 255.255.255.0
  ip helper-address 10.105.64.72
  ip rip 10.105.69.254
  exit
vlan 100
  name "VLAN100"
  tagged 49-52
  ip address 10.10.10.254 255.255.255.0
  ip igmp
  ip rip 10.10.10.254
  exit
spanning-tree
spanning-tree ignore-pvid-inconsistency
loop-protect mode vlan
no autorun
no dhcp config-file-update
no dhcp image-file-update

6 REPLIES
HP-Schrauber
Frequent Visitor

Re: dhcp server 2012 and vlans

Hello,

go to your Vlan and Set the IP Helper Adress.

Like this Commands :
vlan 5
ip helper-address "The IP of your DHCP Server"

To Check if there is some Pakets arrived, send this Command : Show-DhcpRelay

Greetings

Mario

druartx
Occasional Contributor

Re: dhcp server 2012 and vlans

each vlan have a DHCP extension in you server and i suppose that you have 1 port by extension.

In this case each interface of your dhcp server have an ip address. Those ip address have to be configured on your vlans as ip helper:

i.e :

vlan 2
  name "Produccion"
  tagged 1,49-52
  ip address 10.105.65.254 255.255.255.0
  ip helper-address 10.105.65.xx

josegpe
Occasional Visitor

Re: dhcp server 2012 and vlans

thanks for your reply,
I have a single server, where all the addresses are,
attached image

Vince-Whirlwind
Honored Contributor

Re: dhcp server 2012 and vlans

Can you expand your scopes to show what you have set as Option3?

Also, what are all those static routes you've configured supposed to be doing?

Is the DHCP server attached to this switch? Which port?

josegpe
Occasional Visitor

Re: dhcp server 2012 and vlans

Can you expand your fields to show what you have set as Option 3?
attached image

Also, what are all the static routes you've set up supposed to be doing?
I have been doing several tests, because I do not get to the dhcp, the idea is to reach those scope

Is the DHCP server connected to this switch? What port?
if it is connected to this switch, in port 1,

Thank you.

Vince-Whirlwind
Honored Contributor

Re: dhcp server 2012 and vlans

Why are all your VLANs tagged on your DHCP server's switchport? Does the DHCP server have multiple virtual interfaces, on for each VLAN?

You didn't include the info about what your Option3 is for every scope.