ProCurve / ProVision-Based
cancel
Showing results for 
Search instead for 
Did you mean: 

internal DHCP of 8206 with other switches

Markus23
Occasional Visitor

internal DHCP of 8206 with other switches

Hi !

I'm quite new to configuring HP PrCurve switches ( 8206, 2920 and some old 2626).

Right now I'm trying to get the new internal DHCP server to work, which is included in the newer HP firmware release (using 15.18 right now).

I managed to configure and activate the internal DHCP with different scopes for all configured vlans. This seems to work on the 8206. Configured a trunk to my 2920 and also configured the same vlans on the switch. But when trying to get a ip-address from the dhcp-server (8206) with a client connected to 2920, it doesn't work.

Is the internal DHCP server of the 8206 limited to itself, or can it serve DHCP-request of connected switches ?

Here is the respective part of the 8206 config:

trunk B15-B18 trk1 lacp
ip routing
vlan 1
   name "DEFAULT_VLAN"
  untagged A1-A24,B1-B14,B19-B24,C2-C22,D1-D24
   tagged Trk1
   ip address 192.168.172.1 255.255.255.0
   exit
vlan 101
   name "it"
   untagged C1
   tagged Trk1
   ip address 192.168.1.1 255.255.255.0
  dhcp-server
  exit
dhcp-server pool "it"
   authoritative
   default-router "192.168.1.1"
   dns-server "192.168.0.10"
   domain-name "test.local"
   network 192.168.1.0 255.255.255.0
   range 192.168.1.10 192.168.1.20
   exit
dhcp-server enable

 

And this are parts of the config of 2920:

trunk 21-24 Trk1 lacp
vlan 1
   name "DEFAULT_VLAN"
   untagged 2-20,A1-A2,B1-B2
   tagged Trk1
   ip address 192.168.172.2 255.255.255.0
   exit
vlan 101
   name "it"
   untagged 1
   tagged Trk1
   no ip address
   exit

When using a PC on Port C1 of 8206 it gets a IP address, but when using a PC on port 1 of 2920 it won't get a IP address from 8206.

What am I doing wrong, or is missing from the config ?

 

Thanks in advance,

 

Markus

 

 

1 REPLY
Richard Litchfield
Respected Contributor

Re: internal DHCP of 8206 with other switches

What is the Untagged VLAN on Trk1 on each switch? You need to make sure your untagged/native/PVID match at each end of a connection.

Do a show logging -r and see if you are having VLAN mismatches