ProLiant Deployment and Provisioning
cancel
Showing results for 
Search instead for 
Did you mean: 

Error 3 During Script Execution

 
Johnathan
Advisor

Error 3 During Script Execution

RDP v2.20
Attempting to deploy "Proliant ML/DL/BL + Windows 2003 Server Standard + PSP" and fails with error message as stated in subject.
The blade will then boot to a 'C:' prompt.
Tried deploying same thing but with Windows 2000 Standard and Advanced on 2 BL20PG2 and 2 BL30P with no luck. Same thing.
Some searching on the forums before had two similar cases, but neither of any avail.
I can create my own job and it will deploy successfully, but none of the predefined jobs will go through. They all stop at the same place, 'C:'

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=957411
and
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=977158

I'd be more than happy to provide more information if necessary.

thank you for your help guys
regards
Johnathan
Keep at it.....they'll release a patch for it soon enough
9 REPLIES
Gopi Sekar
Honored Contributor

Re: Error 3 During Script Execution


In which task you got the error 3 ?

Since you mentioned that target boots back in to C: prompt, i assume it has executed the formatting and creating partition in the blade. The next expected job to be run is copying of windows installer files (i386 folder) along with PSPs and Altiris client files. Please check whether you have the windows 2003 files properly copied without any issues.

By going in to detailed result , you should be able to get more information. (double click on the failed job assigned in the target, you would get in to step wise return status, then clicking on the failed on would give details)

Hope this helps,
Gopi
Never Never Never Giveup
Yuichiro Kitamura
Trusted Contributor

Re: Error 3 During Script Execution

Hi Johnathan Mosca

Does your RDP server have two or more network connection?
If that is right, please stop NIC which is not used for RDP.
(RDP does not support the Multihome environment by a default.)


When your server needs two or more Network connection, a Lmhosts file needs to be edited.

Procedure
(Env Servername: RDP, IPaddress(Use RDP):192.168.1.1)

1. Start RDP, and Clicks "tools" - "PXE Configuration"
2. Select "DOS Managed" and Click "Edit"
3. Click "Edit Boot Image"
4. Open net folder, and Select lmhosts file.
5. Add the following line to a Lmhosts file.

192.168.1.1 RDP

6. Click "Next", and "Yes"
7. Click "Next", and "Finish"
8. Click "OK" , and "Save", and "OK"


Regards, kita
Johnathan
Advisor

Re: Error 3 During Script Execution

Ok guys, thanks for your responses and your help. Gopi, I checked the details of the job and you were right. It was failing at the point of copying Proliant files (See attached image).
The question is now, was there something I possibly missed when I was doing the RDP install to cause this?
And now, how do I rectify it. I digged into the osoem1.bat file and saw that it is supposed to copy files from '\lib\osoem\%oem%\*.*' to 'C:\ /s /e'
In the \lib\osoem...I dont see the %oem% folder
I think we're nearly there

And kita, thanks for your time and the advice on the dual nics.
Keep at it.....they'll release a patch for it soon enough
Gopi Sekar
Honored Contributor

Re: Error 3 During Script Execution

The attachments suggests that you have not run the PIM installation module of RDP installation or you have skipped it.

I believe you can re-run the RDP installation and select the ProLiant Integration Module installation alone (the final one). It will prompt with list of jobs to be imported, select the required jobs and let it import. It will import the jobs and PSPs for the jobs and will prompt you for the OS CD, insert the OS cd (win2k3) and let it copy the contents.

Once the above process is done, try re-running the job and post the result here.

Hope this helps,
Gopi
Never Never Never Giveup
Johnathan
Advisor

Re: Error 3 During Script Execution

trying it now

Thanks
Keep at it.....they'll release a patch for it soon enough
Johnathan
Advisor

Re: Error 3 During Script Execution

same problem gopi :(
Keep at it.....they'll release a patch for it soon enough
Johnathan
Advisor

Re: Error 3 During Script Execution

Could you by chance take a screenshot of how the '\lib\osoem' folder should look...thanks
Keep at it.....they'll release a patch for it soon enough
Johnathan
Advisor

Re: Error 3 During Script Execution

OK guys, it seems Ive found the resolution!
The DOS boot diskette files had to be reinstalled from the CD. I initially used a dos diskette that was created from an exe I downloaded off the web. These diskettes dont contain some of the critical files needed by RDP. Use an original windows 98 boot diskette or CD. After that, it was smooth sailing.
A thread tipped me off...it stated that he got the error 3 because of a missing XCOPY32.MOD file in the /bootwiz/dos folder.
When I looked, my XCOPY32 file was missing. When I downloaded it and manually put it in, I got another error - Error 2. It was saying that it was missing some other files that had to be copied.
From here, just got an original windows98 CD and recopied the DOS boot diskette files from Tools>Boot Disk Creator>Tools>Install Pre Boot Operating Systems.

On another note - If it wasnt for these forums, I wouldnt have solved this problem! Thank You
Regards
Johnathan
Keep at it.....they'll release a patch for it soon enough
Bruno J. Melo
Valued Contributor

Re: Error 3 During Script Execution

Thanks a lot on this post.

I had the same problem using a windows 98 boot disk image downloaded from the web.

I loaded the pre boot operating system files from an original Windows 98 SE CD and all my troubles went away...