ProLiant Deployment and Provisioning

HP PSP 8.4* installs fail "currently running kernel (xxx) is not supported by this rpm"

 
SOLVED
Go to solution
Robert_Boyd
Respected Contributor

HP PSP 8.4* installs fail "currently running kernel (xxx) is not supported by this rpm"

I'm trying to update several servers with SCSI and FC attached tape drives using HP SUM. I tried 8.40 and 8.41 and several items generate the following type of error:

The currently running kernel (2.6.18-194.3.1.el5xen) is not supported by this rpm.

I see in the list of supported versions the 2.6.18-194.el5xen.

Is there a way to coax HP SUM into believing this minor mod to the kernel version is ok to install on? Can I tell HP SUM to override the check?

Or is there something else I should be doing?

On the other hand, is there a way these kits could be built so that minor updates to the kernel version are accepted automatically?
Master you were right about 1 thing -- the negotiations were SHORT!
4 REPLIES 4
Michael Garner_1
Honored Contributor
Solution

Re: HP PSP 8.4* installs fail "currently running kernel (xxx) is not supported by this rpm"

Robert,
The issue isn't with HPSUM. The issue is the individual RPMs you mention do not support that kernel. If you execute the RPMs outside of HPSUM, you will receive the same errors and the RPM will not install. Because many driver RPMs are pre-compiled binaries, as new kernels are released, newer versions of the driver RPMs are required (or you can use the one compiled into the kernel) that have new pre-compiled binaries for those new kernels. For FC drivers, starting with RHEL 5.3, the recommendation is to use the one in the kernel. The RPMs are still included in the PSP for users who still are on older distros.

I would not recommend forcing the installation of the RPMs as they will most likely not work with the latest kernels and could cause kernel panics.

Regards,
Michael Garner
HPSUM Architect
Robert_Boyd
Respected Contributor

Re: HP PSP 8.4* installs fail "currently running kernel (xxx) is not supported by this rpm"

The problem I'm running into is that Red Hat will release critical patches that we choose to apply. Fairly often I've seen trouble when we've done this on some of our NetBackup Master/Media servers. We wind up with strange things happening with our FC or SCSI attached drives after the kernel update until I can re-apply/rebuild the drivers from the PSP kit. I'd be happy to run with the builtin drivers supplied with the kernel if they actually worked correctly with all of our hardware. When I wind up with a situation like the one I had this time, I wind up redirecting GRUB to boot off the highest supported kernel available. Then I can run HPSUM/PSP updates and clean up the handling of the tape drives.
Master you were right about 1 thing -- the negotiations were SHORT!
Gerardo Arceri
Trusted Contributor

Re: HP PSP 8.4* installs fail "currently running kernel (xxx) is not supported by this rpm"

I believe 8.41 supports kernels up to 2.6.18-194, which is the kernel shipped with RHEL 5.5, you might want to try downgrading your kernel to that version until HP decides to fix this problem hopefully with PSP 8.50 that, as indicated on other posts on this forum should be coming out in July.
MStatman
New Member

Re: HP PSP 8.4* installs fail "currently running kernel (xxx) is not supported by this rpm"

It seems to be a perpetual problem, almost like trying to find a winning lottery number. For example, the psp-8.6.0 (10 Sep 2010) for SLES 10 claims to support the following kernel versions (from the install log, after it fails):

2.6.16.60-0.34
2.6.16.60-0.37_f594963d
2.6.16.60-0.39.3
2.6.16.60-0.54.5
2.6.16.60-0.57.1
2.6.16.60-0.58.1
2.6.16.60-0.66.1

If you have SLES 10 SP3, then the kernel should be one of:

SP3-Oct-2009 2.6.16.60-0.54.5
Nov-12-2009 2.6.16.60-0.57.1
Dec-14-2009 2.6.16.60-0.58.1
Jan-22-2010 2.6.16.60-0.59.1
Mar-29-2010 2.6.16.60-0.60.1
Apr-26-2010 2.6.16.60-0.62.1 (x86_64 only)
Jun-11-2010 2.6.16.60-0.66.1
Aug-17-2010 2.6.16.60-0.67.1
Sep-03-2010 2.6.16.60-0.68.1
Sep-22-2010 2.6.16.60-0.69.1

So you have perhaps at best a 40% chance of getting the psp to install agents/drivers, more like a 0% chance if you keep your kernel up-to-date with security patches etc.

(If you still have older SLES 10 SP2, then there's about 17 kernel possibilities, 3 of which are supported, not including the latest 6 kernels released after May 2009)

So if you do have, for example, the latest SLES 10 SP2 and want to install the psp, you can apply SLES 10 SP3 with no further patches, then should be able to install the psp. What happens after that when you install a current kernel update?

:-(