ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

217 - Warning Processor Cache error at POST

 
Ayman Altounji
Valued Contributor

217 - Warning Processor Cache error at POST

All,

A customer has a Proliant 3000R with 2x 300MHz processors, 512Kb cache. There's 576Mb of RAM in the server.

At POST, there's an error message coming up for each of the processors warning about the processor cache, and possible performance degradation - Error code 217, which I can't find any reference to in the support site.

Is this just because of there being too much RAM for the processor caches, or is it due to a problem with the processors. The server is running appallingly slowly, with no logical reason.

Adrian Chapman
6 REPLIES
Ayman Altounji
Valued Contributor

Re: 217 - Warning Processor Cache error at POST

I have the same problem as yours. My server is dual PII333 with 1.50 gig of RAM. I decreed RAM to 1 gig but the problem still exist. It looks to me that the system is running slower than it should be. With dual processor (even PII300), it should perform better than that. I had the BOOS flashed and SCSI controller flashed to the latest version but nothing helped. I called compaq re. He told me that the system should be able to handle 2 gig of RAM. Seems none know what's going on. After I installed NT4.0 (sp5), WINMSD showed me that processor 0 is 332 and processor 1 is 133. I forgot the family and stepping number. I modified the registry to make it looks match. We need help on this issue please.
Ayman Altounji
Valued Contributor

Re: 217 - Warning Processor Cache error at POST

I just had this problem resolved. What happen was someone install the second processor which was not purchased from Compaq. I took the Compaq labled CPU from another server and I don't have any error message. The system is running much, much faster. Check your 1st or 2nd CPU and make sure they have Compaq label on them. Hope this helps.
Ayman Altounji
Valued Contributor

Re: 217 - Warning Processor Cache error at POST

Hmmm.

We've resolved it here as well - it turned out somebody had a similar problem with a 3000 in another office, with 1Gb of memory - They took it down to 512Mb, and it suddenly came alive!

So we've just tried the same here - taken the server down to 512Mb of RAM, and suddenly, instead of 100% CPU utilisation, it's at about 12-15%, with the same (or more) user load.

Kronites - are your processors 1Mb Cache? Ours are 512Kb, so it looks like there's some kind of 1Kb of Cache = 1Mb of RAM rule going on here.

Compaq - Comments?

Adrian Chapman
Ayman Altounji
Valued Contributor

Re: 217 - Warning Processor Cache error at POST

A limitation of the Tag Ram in early Pentium II prevented the processor from caching more than 512MB of main memory. This means that any additional memory added past 512MB cannot be cached resulting in a performance hit .
Ayman Altounji
Valued Contributor

Re: 217 - Warning Processor Cache error at POST

Could Compaq provide more information on this problem? I am also getting the 217 post error. It specifically references processor 2, does this mean only my second processor is affected?
Ayman Altounji
Valued Contributor

Re: 217 - Warning Processor Cache error at POST

I'm also getting this 217 error, on a single-processor 3000 with 655mb at POST. So am I right in thinking that if I upgrade to a newer (and Compaq-branded) processor, or reduce the RAM from 655mb to 512mb, this will fix it?