HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

6i Array Expansion question

 
TMRY
Occasional Contributor

6i Array Expansion question

Hello, we are trying to do an in-line array expansion on a DL 380 G4 with the onboard SA 6i controller. We are replacing the 6 72GB Ultra 2 drives with 6 146GB U320 drives. I've done this before but this particular server is giving me fits.

We got the first drive swapped out fine, everything worked as expected and the array rebuilt fine. We went to do the second and the server crashed. Drive ID 1 was popped out and when the 146GB was inserted the server went down. The ROM based ACU stated that disk ID 3 was failed and disk ID 1 was not even present in the machine. We pulled disk 1 out, replaced it with the original 72GB one, and the array came back.

I did some research and tried to swap out disk ID 5 this time, and again the array reported Disk ID 3 as failed and ID 5 as not being in the system. This continued until power was removed from the unit and it was rebooted with the disks back in the original configuration.

My question is pretty simple, why is this happening? Is there some incompatability with the Ultra 2 drives and the U320 drives on the same bus? If so why did disk ID 0 work without a hitch. This is strange because I've done it so many times on so many other servers.

6i firmware is 2.36.
6 REPLIES
KarloChacon
Honored Contributor
TMRY
Occasional Contributor

Re: 6i Array Expansion question

Thanks for the response. I took your advice and checked out upgrading the firmware on the 6i. In my reading it said it will usually POST that you'll need to upgrade the attached drive firmware.

I looked throught there and found we are using (what the Array Diag Utility says) 72.8GB 10k drives COMPAQ BD0726536C drives with firmware of 3B02 (I'm sure very old just like the drives). I can't find that model number anywhere on the support site. In fact, I can't find any Ultra 2 72GB drive firmware on the site (ADU says they are Ultra 2).

Any ideas on that before I upgrade the array firmware?
juan quesada
Respected Contributor

Re: 6i Array Expansion question

Hi,
BD0726536C = 72.8GB Wide Ultra3 SCSI, 10K, 80 Pin SCA-2, 1" spare number 233349-001
Latest revision 3B02 released (01/17/02).

You have the latestâ ¦
juan quesada
Respected Contributor

Re: 6i Array Expansion question

BTW U320 is backwards compatible with wide ultra 2 however the old HDD may have errors internally.
Run ADU (diagnostic) and attach it, I'll check it for you if you want.
TMRY
Occasional Contributor

Re: 6i Array Expansion question

Thanks for the help so far. I've attached the most recent diag (with the newest diag utility). I'm going ot assume I'm OK with ugrading the firmware on the controller, but I just wanted to verify since this thing has given me so many fits.
KarloChacon
Honored Contributor

Re: 6i Array Expansion question

everything looks OK

but firmware is still not updated right?

I suppose neither driver?

regards
Didn't your momma teach you to say thanks!