HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Adding RAID to an exsisting 2003 install on a DL320 G5

 
Jordie Fike
Occasional Visitor

Adding RAID to an exsisting 2003 install on a DL320 G5

I've google'ed it half to death and I've seen some instrutctions for installing RAID on an initial install, but nothing for adding RAID to an exsisiting server. We have a DL320 G5 that is pretty important to us around here adn I would like another level of protection (other than my tape backup). I'm use to (1) add another HD of the same size (2) turn on RAID1 (3) build the array by defining the source and target drives (4) Reboot.

Not quite that easy on the DL320 .. or I am missing something.
7 REPLIES
KarloChacon
Honored Contributor

Re: Adding RAID to an exsisting 2003 install on a DL320 G5

hi

let me see If I got this clearly
you have RAID 0 and want to migrate to RAID 1???

if so
that is called EXPAND and MIGRATE process.

check the doc attached


bye
Didn't your momma teach you to say thanks!
Jordie Fike
Occasional Visitor

Re: Adding RAID to an exsisting 2003 install on a DL320 G5

Sorry, to clarify I inherited the machine with just the single HD and tape as the only fail-safe. I added an identical HD into the 2nd bay and would like to now mirror the drive in Bay 1. I can enable the embedded SATA RAID controller in the BIOS, and I can F8 into the RAID configuration screen, but it won't let me assign the exsisting populated drive (C:\) to the RAID volume (it will however, let me assign the new blank drive to the volume).

What I am looking for is a Step-by-Step for adding a 2nd SATA drive to an up and running DL320 and using that drive to create a RAID1 without losing the data on the original SATA drive.
KarloChacon
Honored Contributor

Re: Adding RAID to an exsisting 2003 install on a DL320 G5

oh yes sorry I forgot that server has by default embedded unless you get something else

yes there is a procedure to ENABLE RAID - and migrate from no RAID to RAID 1

kinda pain in the ass but I will try to search for it
Didn't your momma teach you to say thanks!
KarloChacon
Honored Contributor
Jordie Fike
Occasional Visitor

Re: Adding RAID to an exsisting 2003 install on a DL320 G5

On your first link, the instructions provided by James the Happy Dude, I tried that yesterday but in Step 3, if is choose the Device is Connected branch there is no RAID controller listed to install drivers for.

Also I was able to find cp007490.exe and cp008694.exe, both of which HP lists as the SAS/SATA embedded RAID Drivers for G5s running 2003, but neither installation works as I am given 'The software is currently installed, but does not need to be installed on this system.' (for cp007490.exe, which I think is the right one) and 'The software will not be installed on this system because the required hardware is not present in the system or the software/firmware doesn't apply to this system.' (for the cp008694.exe).

I can 'enable' the controller from within the BIOS, then F8 to get to the RAID Setup, but it will only let me involve DISK1 as DISK0 (the one I am currently running off of) seems to be off-limits and is greyed out.

I am seriously close to putting in a PCI SATA controller that supports external drives and putting in a Cavalry Drive with pre-configured RAID. There should be a Step-by-Step from HP incuding links to appropriate drivers where needed as it seems I'm not the first person to have to fight this fight.

but btw . your help and guidance is fully appreaicated .. thank you, whether I get this congiured or not.
KarloChacon
Honored Contributor

Re: Adding RAID to an exsisting 2003 install on a DL320 G5

extract the driver and update the device en device manager manually using the inf file
Didn't your momma teach you to say thanks!
Jordie Fike
Occasional Visitor

Re: Adding RAID to an exsisting 2003 install on a DL320 G5

tried that yesterday with the cp007490.exe .. it lists it in the device manager as a deivice that it cannot start. I ass/u/me'ed that once I enabled the embedded controller in the BIOS it would start, but I never got that far as once I went F8 to configure the RAID1 there was no way to pick a source and destination drive .. so I backed out of it and turned the embedded controller back off and booted back to my lowly single drive. I will take another loook in the RAID configuration screen (F8) once I get everyone out of the system for the night and see if I missed anything.