ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Array did not recognise replaced Drive

Ian Flood_2
Occasional Advisor

Array did not recognise replaced Drive

I have a DL760 with 4 x 146GB HDDs using a 5300 controller. After replacing a failed hard disk the ACU still reports drive 2 as failed. The array is running with 3 HDDs and the replacement is seen as a seperate drive. Free space is listed as ?????? because the setup is wrong. I have rebooted without new drive, rebooted with old failed drive and tried 2 new drives, none of which are recognised as replacing the failed drive. All firwares have been updated. Any idea what I can do without rebuilding the server?
5 REPLIES

Re: Array did not recognise replaced Drive

Hi

What is the operating system? What is the raid configuration.

thanks
Ian Flood_2
Occasional Advisor

Re: Array did not recognise replaced Drive

The O/s is win2003, using RAID5.

Re: Array did not recognise replaced Drive

disable the onboard smart array controller from rbsu. Some times 5300 controller may not work correctly after replacing the failed drive on the controller if it has another controller on the system. It might seem to be bit weird but thats the info I got. So try disable it and check.
Ryan_215
Occasional Advisor

Re: Array did not recognise replaced Drive

A couple things could cause this.

When you first but in the replacement drive does it appear to start a rebuild at all? and then fail shortly after? If it starts a rebuild and fails you might have signalling problem cables/backplane, or there could be another drive that is causing the rebuild to fail.

In rare cases I seen the rebuild won't take place because the drive that is put in to be a replacement is too small. replacing a 146GB with another 146GB maybe different manufacuture and is slightly smaller.

Best Thing to do is run an ADU and check out the errors. Or post the ADU report and someone here can look at it aswell.
Ian Flood_2
Occasional Advisor

Re: Array did not recognise replaced Drive

I have tried disabling the on board array controller. This is the ACU report