ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460c Slow Reboot

Myles23
Occasional Contributor

BL460c Slow Reboot

I am experiencing a painfully slow reboot for my 460 servers. They have all the latest firmware applied (9.10c) and it has been rebuilt with latest smartstart (8.50) however the reboots can take 1 hour (usually I will need to ilo on to the server and do a cold reboot). I have looked around at found some posts in regards stopping certains services (the main service being HP System Management Homepage) however it still hangs. The servers are citrix servers and are being used for a published desktop.
Any help is much appreciated.
7 REPLIES
Matt Palmer_2
Respected Contributor

Re: BL460c Slow Reboot

Hi,

please post your boot logs. Have you checked that its not something like ntpd starting/polling before network services have started?

regards

Matt
Robert Miranda - Mesh N
Occasional Visitor

Re: BL460c Slow Reboot

Myles23,

Does it boot up quickly when you do a cold reboot?

I would have a look at your Citrix Licensing configuration first. It could be they are looking for the Citrix Licensing Server in your farm. Another place to look would be your network settings, in particular your DNS server settings.


Regards,

Robert Miranda
Mesh Networks
(416) 888-5007
www.meshnetworks.ca
Myles23
Occasional Contributor

Re: BL460c Slow Reboot

Thanks for your replies.

Matt boot log details below. Just to clarify the slowness is when the server is shutting down\rebooting. I have built G3 and G4 servers with the same firmware (and software) and they boot under 4 mins so confused. The servers are on a domain so they should sync thier time from the local DC (post if I am wrong).

Robert, the server will boot into windows ok after a bold reboot however it still hangs when shutting down\rebooting. I have checked the datastore and the servers are successfully registered (I can slo see them in CAMC), we have checked DNS and it has been setup and tested. We are teaming NICS and creating 2 NIC teams, disabling 1 and assigning a ststic address to the other.

If I have missed anything please post.
Cheers


Service Pack 2 9 6 2010 16:23:06.625
Loaded driver \WINDOWS\system32\ntkrnlpa.exe
Loaded driver \WINDOWS\system32\hal.dll
Loaded driver \WINDOWS\system32\KDCOM.DLL
Loaded driver \WINDOWS\system32\BOOTVID.dll
Loaded driver sacdrv.sys
Loaded driver ACPI.sys
Loaded driver \WINDOWS\system32\DRIVERS\WMILIB.SYS
Loaded driver pci.sys
Loaded driver isapnp.sys
Loaded driver wdf01000.sys
Loaded driver \WINDOWS\System32\Drivers\WDFLDR.SYS
Loaded driver MountMgr.sys
Loaded driver ftdisk.sys
Loaded driver dmload.sys
Loaded driver dmio.sys
Loaded driver volsnap.sys
Loaded driver PartMgr.sys
Loaded driver HpCISSs2.sys
Loaded driver \WINDOWS\system32\drivers\storport.sys
Loaded driver disk.sys
Loaded driver \WINDOWS\system32\DRIVERS\CLASSPNP.SYS
Loaded driver fltMgr.sys
Loaded driver Dfs.sys
Loaded driver PxHelp20.sys
Loaded driver KSecDD.sys
Loaded driver bxvbdx.sys
Loaded driver Ntfs.sys
Loaded driver NDIS.sys
Loaded driver Mup.sys
Loaded driver mfehidk.sys
Loaded driver hpqilo2.sys
Loaded driver crcdisk.sys
Loaded driver \SystemRoot\system32\DRIVERS\intelppm.sys
Loaded driver \SystemRoot\system32\DRIVERS\bxnd52x.sys
Loaded driver \SystemRoot\system32\DRIVERS\usbuhci.sys
Loaded driver \SystemRoot\system32\DRIVERS\usbehci.sys
Loaded driver \SystemRoot\system32\DRIVERS\ati2mtag.sys
Loaded driver \SystemRoot\system32\DRIVERS\cpqcidrv.sys
Loaded driver \SystemRoot\system32\DRIVERS\i8042prt.sys
Loaded driver \SystemRoot\system32\DRIVERS\kbdclass.sys
Loaded driver \SystemRoot\system32\DRIVERS\mouclass.sys
Loaded driver \SystemRoot\system32\DRIVERS\serial.sys
Loaded driver \SystemRoot\system32\DRIVERS\serenum.sys
Loaded driver \SystemRoot\system32\DRIVERS\fdc.sys
Loaded driver \SystemRoot\system32\DRIVERS\cpqteam.sys
Loaded driver \SystemRoot\system32\DRIVERS\audstub.sys
Loaded driver \SystemRoot\system32\DRIVERS\rasl2tp.sys
Loaded driver \SystemRoot\system32\DRIVERS\ndistapi.sys
Loaded driver \SystemRoot\system32\DRIVERS\ndiswan.sys
Loaded driver \SystemRoot\system32\DRIVERS\raspppoe.sys
Loaded driver \SystemRoot\system32\DRIVERS\raspptp.sys
Loaded driver \SystemRoot\system32\DRIVERS\ptilink.sys
Loaded driver \SystemRoot\system32\DRIVERS\raspti.sys
Loaded driver \SystemRoot\system32\DRIVERS\rdpdr.sys
Loaded driver \SystemRoot\system32\DRIVERS\termdd.sys
Loaded driver \SystemRoot\system32\DRIVERS\swenum.sys
Loaded driver \SystemRoot\system32\DRIVERS\update.sys
Loaded driver \SystemRoot\system32\DRIVERS\mssmbios.sys
Loaded driver \SystemRoot\System32\Drivers\NDProxy.SYS
Did not load driver \SystemRoot\System32\Drivers\NDProxy.SYS
Loaded driver \SystemRoot\system32\DRIVERS\usbhub.sys
Did not load driver \SystemRoot\System32\Drivers\ql2300.SYS
Did not load driver \SystemRoot\System32\Drivers\Flpydisk.SYS
Did not load driver \SystemRoot\System32\Drivers\Sfloppy.SYS
Did not load driver \SystemRoot\System32\Drivers\i2omgmt.SYS
Did not load driver \SystemRoot\system32\DRIVERS\cdrom.sys
Did not load driver \SystemRoot\System32\Drivers\Changer.SYS
Loaded driver \SystemRoot\System32\Drivers\Fs_Rec.SYS
Loaded driver \SystemRoot\System32\Drivers\Null.SYS
Loaded driver \SystemRoot\System32\Drivers\Beep.SYS
Did not load driver \SystemRoot\system32\DRIVERS\kbdhid.sys
Loaded driver \SystemRoot\System32\drivers\vga.sys
Loaded driver \SystemRoot\system32\DRIVERS\icacdd.sys
Loaded driver \SystemRoot\System32\Drivers\mnmdd.SYS
Loaded driver \SystemRoot\System32\DRIVERS\RDPCDD.sys
Loaded driver \SystemRoot\System32\Drivers\Msfs.SYS
Loaded driver \SystemRoot\System32\Drivers\Npfs.SYS
Loaded driver \SystemRoot\system32\DRIVERS\rasacd.sys
Loaded driver \SystemRoot\system32\DRIVERS\msgpc.sys
Loaded driver \SystemRoot\system32\DRIVERS\ipsec.sys
Loaded driver \SystemRoot\system32\DRIVERS\tcpip.sys
Loaded driver \SystemRoot\system32\DRIVERS\wanarp.sys
Loaded driver \SystemRoot\system32\drivers\mfetdik.sys
Loaded driver \SystemRoot\system32\DRIVERS\netbt.sys
Loaded driver \SystemRoot\System32\drivers\afd.sys
Loaded driver \SystemRoot\system32\DRIVERS\netbios.sys
Did not load driver \SystemRoot\system32\DRIVERS\redbook.sys
Loaded driver \SystemRoot\system32\DRIVERS\rdbss.sys
Loaded driver \SystemRoot\system32\DRIVERS\mrxsmb.sys
Did not load driver \SystemRoot\system32\DRIVERS\imapi.sys
Loaded driver \SystemRoot\System32\Drivers\Fips.SYS
Loaded driver \SystemRoot\system32\DRIVERS\usbccgp.sys
Loaded driver \SystemRoot\system32\DRIVERS\cdfdrv.sys
Loaded driver \SystemRoot\system32\DRIVERS\hidusb.sys
Loaded driver \SystemRoot\system32\DRIVERS\kbdhid.sys
Loaded driver \SystemRoot\system32\DRIVERS\mouhid.sys
Loaded driver \SystemRoot\system32\DRIVERS\ctxpidmn.sys
Loaded driver \SystemRoot\system32\DRIVERS\CtxSbx.sys
Loaded driver \SystemRoot\system32\DRIVERS\CtxAltStr.sys
Loaded driver \SystemRoot\system32\DRIVERS\ndisuio.sys
Did not load driver \SystemRoot\system32\DRIVERS\rdbss.sys
Did not load driver \SystemRoot\system32\DRIVERS\mrxsmb.sys
Loaded driver \??\C:\WINDOWS\system32\drivers\Haspnt.sys
Loaded driver \SystemRoot\system32\DRIVERS\cdm.sys
Loaded driver \SystemRoot\system32\DRIVERS\ctxrmpn.sys
Loaded driver \SystemRoot\system32\DRIVERS\ctxsmcdrv.sys
Loaded driver \SystemRoot\System32\Drivers\Fastfat.SYS
Loaded driver \??\C:\WINDOWS\system32\drivers\hardlock.sys
Loaded driver \SystemRoot\System32\Drivers\HTTP.sys
Loaded driver \SystemRoot\system32\DRIVERS\srv.sys
Loaded driver \SystemRoot\system32\DRIVERS\usbccgp.sys
Loaded driver \SystemRoot\system32\DRIVERS\hidusb.sys
Loaded driver \SystemRoot\system32\DRIVERS\kbdhid.sys
Loaded driver \SystemRoot\system32\DRIVERS\mouhid.sys
Loaded driver \??\C:\WINDOWS\system32\Drivers\uphcleanhlp.sys
Loaded driver \SystemRoot\system32\drivers\mfebopk.sys
Loaded driver \SystemRoot\system32\drivers\mfeapfk.sys
Loaded driver \SystemRoot\system32\drivers\mfeavfk.sys
Loaded driver \SystemRoot\System32\Drivers\AlKernel.sys
Loaded driver \SystemRoot\System32\Drivers\TDTCP.SYS
Loaded driver \SystemRoot\System32\Drivers\WDICA.SYS
Loaded driver \SystemRoot\system32\DRIVERS\icareduc.sys
Loaded driver \SystemRoot\System32\Drivers\RDPWD.SYS
SCMoore
Occasional Visitor

Re: BL460c Slow Reboot

Hey There,
I have noticed the same slow rebooting on our BL460s. I have to iLO in as well to reset, cold boot, etc. We're running 64 bit Win2K3 server with no virtualization apps. Unfortunately, I have to depend on our server team for maintenance, as I am only the support for the applications running on the machines. Just trying to help out in the troubleshooting. Any ideas out there??

Thanks,
Steve
Andrew Davenport
Frequent Advisor

Re: BL460c Slow Reboot

Hi,

The first thing i would do to rule out any software problems from 3rd party vendors is fire up msconfig from the Start>Run menu and then disable all startup items under the startup tab and then disable all non MS services under the services tab. Then reboot to make the settings take effect and then try your normal reboot again.
If the server boots fine then you will need to enable all the services again and try again until you narrow it down to the culprit. In my experience this is normally down to a bad service or software component not closing properly, also it may be worth putting a screen on the server to ensure that you are not getting any "End Now" prompts when shutting down (using the ILO remote console has the same effect)
Failing that can you send me or post your system log?
Firman
Occasional Visitor

Re: BL460c Slow Reboot

Hi all

I have similar issue, after installed 9.10c NIC connectivity become slower than usual. maybe this is root cause why the teaming NIC setting is slow when reboot. Have you all try install 9.20 ?
SCMoore
Occasional Visitor

Re: BL460c Slow Reboot

Hi Folks!
With a little digging, I found a resolution for the long shutdown times I was experiencing. It turns out it was a Windows Global Policy issue. Specifically, it has to do with having the Shutdown: Clear Virtual Memory Pagefile policy enabled. It is disabled by default. Once I disabled this policy, my reboot time on one of my servers went frmo 24 minutes to five minutes. We're using large pagefiles on our systems (1.5 x amount of mem, and some of our servers have 48GB of mem), so you can see why it would take a while to clear them out.

Anyway, check out this link http://www.windowsnetworking.com/articles_tutorials/Troubleshooting-Windows-Shutdown.html and search the page for "Another potential cause of slow system shut downs is" and it will explain what/where you need to check. Note that this change requires a reboot, so you won't notice the change in shutdown time until you reboot again.

Hope this helps someone else. :)

Steve