ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Backup always fails on DL380 G5

Nathan Simpson
Frequent Advisor

Backup always fails on DL380 G5

Hi,

DL380 G5 running Windows 2003 x64. HP Storage Works 1/8 Autoloader with Ultrium 920 LTO 3 drive connected via SCSI U320 HBA (SC11xe).

P400 Controller (in slot 1) with 6 x 146GB SAS drives. Drives 1 & 2 are mirrored. 3, 4, 5, 6 Raid 5.

Running 7.9 firmware and PSP.

We use Data Protector 5.5 for backup software, but this isn't the problem.

When ever we run a backup it starts and then fails with a 'cannot write to device' error. It might fail after 1 minute, or it might fail after 2 hours. Normally we would backup the server the tape drive is connected to and a number of servers over the network. But it fails regardless of backing up a single machine or multiple. A full backup with all servers is about 200GB and takes about 4 hours.

I can say it isn't Data Protector as we have a ML350 G3 (configured with same OS version/patches and PSP 7.9 and 7.9 firmware) and we can connect the same SC11xe HBA and tape drive and the backup will not fail or show any errors.

Data Protector is configured the same on both servers.

Anyone else having similar problems or have an idea what the problem might be?

I thought it might have something to do with the speed of the DL380, or it could just be a 380 problem. But I am sure there must be someone else using the same hardware configuration that has this working. Or maybe not.

Thanks

Nathan
29 REPLIES
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

And just to provide a little more info on the server differences. The 380 has 8GB RAM while the 350 has 2GB.

Might make a difference, might not.

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Hello Nathan,
Disable the Windows drivers for the tape and medium changer in the device manager.

Disable the Removable Storage service in the Windows services too.

Redefine the autoloader again and try once more the format.

If it still Doesnt wor, try changing the SCSI Cables

Regards,
James.
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

I will try this.

By doing this does that mean I lose the ability to use the autoloader functionality? Because in the past when I have seen this done, when the device is rediscovered in Data Protector you don't see the slots etc. and let DP know which slot the cleaning tape is in and you have to place the tape in the drive instead of just the slot.

I have done what you said.

When I format a tape it seems to work. But when I then scan the drive it comes back with 'Blank medium found'.

And also this message comes up 'Unknown device, please check device support matrix'. I am using the latest SCSITAB file.

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Theoretically You should not loose the AUTOLOADER's feature.

Try A Different Tape Nathan.

James.
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

The tapes are fine. It happened on multiple tapes.

The attachment is what shows in the autoconfigure of DP 5.5. It only allows me to select the drive.

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Do u find anything in the media.log file ??
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

There is no media.log file on the server.

How does this get created?

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Sorry for the delay,

Location of Log Files
Most Data Protector log files are located in:

Windows: \log

HP-UX and Solaris: /var/opt/omni/log

/var/opt/omni/server/log

Other UNIX: /usr/omni/log

Novell NetWare: SYS:\USR\OMNI\LOG

James.
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

These is no log of that name in that location.

I have a debug.log, inet.log and tapealrt.log.

How would I go about creating a log file of the name you mention and what would it show in this log file.

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Good Morning Nathan,

The Media.log >> Each time a medium is used for backup,initialized, or imported, a new entry is made to this log. The file can be used when recovering the IDB to find the medium with the IDB backup and to find out which media were used after the last backup of the IDB.

The Debug.log Contains unexpected conditions. While some can help you, the information is mainly used by the support organization.

Please post them here. Most Data Protector log file entries are of the following format:


Regards,
James.
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

I don't see any errors in the media.log file.

I have attached our debug.log from the MA and the media.log and Ob2Eventlog.txt files from the CC.

I did a backup this morning and the only relevant details should be dated the 30th of August. I removed all the junk from the debug.log file.

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Hello Nathan,

Some tips from another thread:
Disable the Windows drivers for the tape and medium changer in the device manager.

Disable the Removable Storager service in the Windows services too.

Redefine the autoloader again and try the format again !

Can you write to a tape Using NT backup?(disable DP)

Apply the latest scsitab file of DP too.

& did u try Changing the SCSI CABLEs ? Try that, it might just work !

Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

If I disable the tape and medium devices this is when I get the problem of be able to format the tape but then never being able to read it. This is when I get the 'Blank Medium Found' message.

And if I do the above this is when I can't see the autoloader etc. in DP.
The Removable Storage service is disabled.

Using NTBackup works fine. The problem only shows when using DP, but don't know if it is a DP problem.

I have the latest SCSITAB file.

HP have swapped out the SCSI cable and the tape drive in the autoloader.

Thanks

Nathan
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Im sorry to have u repeat. (I need Coffee ! LOL !)

omnicc -check_licenses -detail

whts the output ?
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

The global options file is located on the Cell Manager:
Windows:
\Config\Server\Options\global

To set global options, edit the global file. Uncomment the line of the desired option by removing the â #â mark, and set the desired value.

The medium quality statistics feature is disabled by default. To enable it,
set the global option Ob2TapeStatistics to 1.

then check, if u can find media.log
James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Install ALL patches available:
http://h20000.www2.hp.com/bizsupport/TechSupport/DriverDownload.jsp?prodName
Id=3188925〈=en&cc=us&taskId=135&prodClassId=-1&prodTypeId=18964∏
SeriesId=3188924


also, refer:
http://h71028.www7.hp.com/ERC/downloads/4AA0-7171ENW.pdf

James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

From another thread with no solutions.

Load the tape up manually and try:

/opt/omni/sbin/utilns/TapeAnalyser -device -header

Note, TA works outside of DP, so device_file means the device_file from the OS perspective. Not some DP drive name like you would use with omnimm.
chongkan
Trusted Contributor

Re: Backup always fails on DL380 G5

I see only configuration ( software ) troubleshooting, if applications are teh same and configurations ( software ) are the same then problem should be HW related..

You said you have other SCSI HBA, is it the same, why don't you swap the controllers to see if it makes any difference?

What about the controller firmware? is it the latest? are both controllers using the same firmware version?

Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

James, I will send that info off tomorrow.

Chongkan, the tape drive, cable and HBA works in the other server without a problem.

I am beginning to think it might be a performance issue. I know the LTO3 is fast but maybe 8GB RAM, and SAS drives and 2 x 4way processors are causing probs with the drive being able to write fast enough or DP being able to keep up.

The other server only has 2GB, 10k drives and 2 x xeon processors. The HBA in this server is on the motherboard so I can't swap it out into the problem server.

All the software is the latest. 7.9 HP software and latest from DL380 updates page.

Contradicting my first post I am being to think it might be a problem with DP not being able to keep up.

I really am just guessing.

Thanks

Nathan
chongkan
Trusted Contributor

Re: Backup always fails on DL380 G5

do you get any error on IML or event viewer?
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

No.

The only error I get is in DP and it is 'Cannot write to device: Unknown error'

Thanks

Nathan
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

I am running all the latest relevant DP 5.5 packages mentioned on the first link, but the PDF was interesting when talking about x64.

Can I assume that every one of the DP5.5 updates available for 2003 is x64 ready? And is the PDF doc talking about installing DP in the past when x64 was first avilable?

All our lics are up to date. We have a basic CC and an extra media license.

When I enable the tape in device manager but leave the medium changer disabled, I am then able to Format and Scan the tape in the drive.

But now how do I use the slots?

And I think this might be moving away from real problem.

Thanks

Nathan

James ~ Happy Dude
Honored Contributor

Re: Backup always fails on DL380 G5

Hello Nathen,

"Can I assume that every one of the DP5.5 updates available for 2003 is x64 ready?"
NO (i think)

"And is the PDF doc talking about installing DP in the past when x64 was first available?"

NO, this white paper was released last year.

"All our lics are up to date. We have a basic CC and an extra media license."

OMNITRIG LicenseWarning 1 license(s) need to be purchased for category "Manager-of-Managers Extension for Windows"

1 license(s) should be purchased for category "Single Drive for Windows / NetWare / Linux"

These 2 warnings are repeated in the EventLog. What does omnicc -check_licenses -detail say ???


"When I enable ....tape in the drive."
Interesting.
This may be similar to
http://support.microsoft.com/kb/873337/en-us

Regards,
James.
Nathan Simpson
Frequent Advisor

Re: Backup always fails on DL380 G5

Hi James,

I thought you were onto a winner with that MS link. I pretty much described the problems we are experiencing. I modified the registry and requested the hotfix and was told there wasn't one for x64.

And the first page then pointed to this, http://support.microsoft.com/kb/933682/ and this did have a hotfix for ltotape.sys and this was for x64.

But sadly, none of these solved my problem. The backup still crashes.

I am not sure where ltotape.sys fits in. The tape drive uses hplto.sys.

I have attached the lic info. I am not sure why it says MOM lic needed as MOM isn't installed. We are over the tape limit but are only using 2 at a time. When we get the LTO drive working we will be 1 media lic over.

Thanks

Nathan