ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Bad performance from SQL Server 2014 on DL380 Gen9

Lenny_Smith
Occasional Visitor

Bad performance from SQL Server 2014 on DL380 Gen9

This issue is something that I haven't had much luck trying to solve via on-line research, and was hoping to find a hit on some forums out there.

I have an HP DL380 server that has 3 physical CPUs, 4 cores each. 32 GB RAM. Four HP MM1000FBFVR drives set up in a RAID 5 configuration. There are 4 1 GB network cards in the back, I'm not sure of the model, but we are using only one, with the jumbo mtu set to 9000, the max.

The OS is Windows Server 2012 R2, and I have SQL Server 2014 Standard edition on it.

I have a set of jobs that I am running on my development machine, a Lenovo with 32 GB of RAM, 1GB network card, and a Blue Western Digital hard drive, 1TB. The OS is Windows 7 Pro.

The problem that I am trying to diagnose is that the same jobs are taking up to 4 times longer on the production machine than on my development box, and that just isn't making sense to me. The network connections are the same speed, and the disc I/O on the production machine is at most 1/2 and often 1/3 of my development box.

I am wondering if it is because it is a standard edition of SQL? I didn't do anything out of the ordinary when I installed it. Could it be the RAID 5? Should I set it up as RAID 10? Any help or tips would be appreciated.

1 REPLY
parnassus
Honored Contributor

Re: Bad performance from SQL Server 2014 on DL380 Gen9

Your post is worring me...I deployed a HPE ProLiant DL180 Gen9 with Microsoft Windows 2012 R2 Essential (ROK) directly on bare metal (NO Hypervisor): the Server has single Intel Xeon CPU exacore and it was equipped with 64GB of RAM plus the HPE Smart Array P440/4G FWBC (I think I've to check if Write Cache - both at Smart Array level for each single disks it manages and at OS level for the logic volume it sees - is somewhat yet enabled or not...clearly all is protected by a serious UPS).

I used five supported Midline HPE 1 TB SATA LFF disks (so no SAS) aggregated in a RAID 6 array.

OS updates, OS drivers, Server components' firmwares are really all up-to-date as per Microsoft/HPE recommandations (plus Maximum Performance was set on Server Power Settings, B140i embedded controller was disabled).

Your post is worring me because Microsoft SQL Server 2014 is planned to be installed in two weeks and - at this point - I hope Server I/O performance will be good enough (judging by the Hardware used, IMHO).

Is there a way to measure Microsoft SQL Server 2014 and/or Server local storage I/O performance to be sure there aren't hidden Software/Hardware bottlenecks?

Would be great to share opinions about that...