ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

COM Port on DL380 not working.

Tony_281
Occasional Contributor

COM Port on DL380 not working.

I installed an external 56k modem on my DL380 G3 (Win2k3 O/S). The modem does not communicate with server anymore. I reinstalled the driver and verified that defice manager shows no conflicts on COM port & modem resources. All settings seem fine.

The modem works fine on other machines. I even tried another modem on the server.

Then I made a 9-pin serial loopback (wrap) plug and used it with hyperterminal. It works great on my PC, but still no response when using it on my DL380.

Next I booted with the smartstart CD, ran diagnostic on COM port registers. This test passed.

How do I know if this port is really faulty?
I don't know how else to test/or what to check.
Please advise.

Regards
Tony.
8 REPLIES
Stephen Grimmer
Trusted Contributor

Re: COM Port on DL380 not working.

Sounds like the com port is just bad...

You could try booting a live linux cd like knoppix and test the com port via that to eliminate the os as the cause...

Or maybe find a dos diskette with qmodem or some other terminal program on there to just test the port...

Oleg Koroz
Honored Contributor

Re: COM Port on DL380 not working.

Test one more time â only change from BIOS and O/S COM1 to COM2 â see if that make difference.
Brian_Murdoch
Honored Contributor

Re: COM Port on DL380 not working.

Tony,

The following Customer Advisory fixed a COM port issue recently in another case.

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_ES041112_CW01

I hope this helps,

Brian
Tony_281
Occasional Contributor

Re: COM Port on DL380 not working.

Thanks for the tips guys,


I updated my ILO firmware from V1.70 to 1.82.
Thereafter I logged into ILO and disabled 'Serial command line interface' field & applied the changes.

I also tried changing from COM1 to COM2 in the RBSU, but made no difference.

Now just waiting for a change to take server offline so I can use a DOS utility to test the port outside of the Windows O/S.

I guess my next step is warranty swopout, but if they replace they board, can my Raid5 set stay entact, or will I need to restore all data from backup?

Steven Baillie
Trusted Contributor

Re: COM Port on DL380 not working.

We have/had exactly the same problem.
HP replaced the system board and this sorted the problem.
Problem then returned again.
HP come to replace the system board again but the system board was not correct and was NOT replaced.

When the old system board was put back in the modem was found and started working again.

Please power down you server and disconnect all power and leave for 5 to 10 minutes.
Put power back in and try again.

From our experience it seems that the system board is not the problem.

Also disable the Serial Command Line Interface Status on the ILO as mentioned before as this could be causing the problem and only disconnecting the power will reset it.


steven
Prashant (I am Back)
Honored Contributor

Re: COM Port on DL380 not working.

Hi,

You can replace the board no issues with anything just put back the hdd.
Raid info is under the hdd only.

Just two thing update system board bios for new one and

what ever you do take backup

You can do it easily.

Regards,
Prashant S.

Nothing is impossible
Prashant (I am Back)
Honored Contributor

Re: COM Port on DL380 not working.

This will explain you that you can move teh data without any damage

http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=PSD_EX000818_CW01

Regards,
Prashant S.
Nothing is impossible
Tony_281
Occasional Contributor

Re: COM Port on DL380 not working.

Thankyou Steven Baillie!!!

I disabled the ILO CLI and shut down the server, disconnecting the power for 5 minutes.

When I booted again, it detected the modem again and working great so far.

Many thanks for the advice.

Regards
Tony