ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

CPQSHD Netware disk driver on proliant ML530

 
Steve Law
Occasional Visitor

CPQSHD Netware disk driver on proliant ML530

Hi,

We have a strange problem with the Netware 6.5 CPQSHD.CDM disk driver running on a Proliant ML530.

We have three identical ML530s with Smart Array 5300 raid controllers (Rev A v2.22). When we upgraded to NW6.5 SP2 a couple of years ago one of these servers came up with no volumes, and we could only make it see the local drives by reverting to the generic Novell disk driver SCSIHD.CDM, and not using CPQSHD. The other two machines worked fine.

Recently we connected the machines running SCSIHD.CDM to a san (EVA 5000), and hit a problem. We needed to run CPQSHD to properly see the san drives (with SCSIHD we only got "unbound device objects" for the san drives). Reverting back to CPQSHD allowed us to properly detect the san devices but as soon as we ran the NSS Managment utility and scanned for new partitions the primary SYS pool deactivated with "pool integrity has been violated" errors. A 'Catch-22' situation.

The only way to see both the san drives and the local drives has been to backrev right back to the pre-service pack 2 version of CQPSHD.CDM. This is v1.59 dated 28th May 2003, whereas the current NW6.5 SP5 version is v2.06 dated 7th Nov 2005.

I'm concerned about running a hw driver that's significantly older than the others - the revision history references a number of issues (drive deactivation etc) that are fixed in later revisions. Also this is going to be an issue every time we upgrade ot the next service pack, and unless we resolve it the driver is going to be increasingly out of date.

I can't find any info that might suggest why this one server should reject CPQSHD when two other identical servers run it happily. There's nothing in the Novell support site or forums. Can anyone suggest how we might go about getting a fairly recent version of CPQSHD working?

I have survey reports of this server and one of it's twins, if required.


Thanks,



Steve Law
2 REPLIES
Oleg Koroz
Honored Contributor

Re: CPQSHD Netware disk driver on proliant ML530

... iâ m not sure if that should help, if you change LOAD priority in start-up file to let CPQ go one of first and set SCSIHD.CDM almost to end
Steve Law
Occasional Visitor

Re: CPQSHD Netware disk driver on proliant ML530

Hi,

Got a response unexpectedly from the Novell forums yesterday that seems to exactly match the issue I'm getting.

The problem is caused by a dodgy raid controller is NW6.5 SP2 that wrongly recorded the size of the partitions/volumes. This bad info was picked up by later versions of CPQSHD.CDM causing the volumes to fail to mount. SCSIHD.CDM is a workaround, but the fix is to run PARTFIX.NLM which should then allow the later CPQSHD versions to load fine.

See tids 10093547 and 10092473. The earlier tid says you have to get Novell tech support involved to fix after you have generated a report file, but the later one says you can DIY.


Cheers,



Steve Law