ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

CPQary3 driver on Solaris 10

SOLVED
Go to solution
semiattributable
Occasional Visitor

CPQary3 driver on Solaris 10

The HP page: http://h71028.www7.hp.com/enterprise/cache/492635-0-0-0-121.html claims that the Proliant DL360 G5 is "Sun Certified and HP supported" for Solaris 10 05/09.

The Sun hardware compatibility page for my server: Proliant DL360 G5 claims that it will run on "Solaris 10 11/06 to Solaris 10 05/09"

BUT

I am running Solaris 10 05/09 release
I downloaded the latest version (2.1.0 10 Apr 2009) found here:
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=us&prodNameId=3288144&prodTypeId=15351&prodSeriesId=1121486&swLang=8&taskId=135&swEnvOID=2023

It seems that the CPQary drivers have not been updated therefore I cannot install the stock Solaris 10 05/09 from dvd, nor can I install it with a dvd containing a patched miniroot after following the instructions that came with the CPQary3 drivers. In either state, the installer system booted off of DVD does not see the hard drives and has nothing to install to.

My DL360 G5 has the Smart Array E200i controller in it which according to the revision history of the driver, support for this was added in Version: 1.60 (22 Jun 2006).

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=1842750&swItem=MTX-30012bd09e11426b9b289142e4&prodNameId=3288156&swEnvOID=2023&swLang=8&taskId=135&mode=5

Anyone have ideas on where to go from here besides another vendor?
6 REPLIES
semiattributable
Occasional Visitor

Re: CPQary3 driver on Solaris 10

As an aside, due to not being updated, the drivers may not install fully to the miniroot in that they kick errors about dependencies on packages that are not installed in the miniroot, nor are they installable into the miniroot.

I experience the same thing that Kevin experiences here:
http://archive.netbsd.se/?ml=sunmanagers-sunmanagers&a=2009-06&t=10823181


This happens for both u6 10/08 and u7 05/09 releases of Solaris 10 x86
nada_1
Occasional Visitor

Re: CPQary3 driver on Solaris 10

I got the same problem here with a P400i controller on 2 different g5 generations.

On s10u6 we could run it with the 1.92 driver.
Now with s10u7 it doesn't run anymore.

I tested so far without success following drivers:

-1.9.1
-1.9.2
-2.1.0

I've tried with pathed miniroots as well as with ITU installation.

I see the same message as you: "no drive found"

Seems like HP has to deliver a new driver for u6 :-(
semiattributable
Occasional Visitor

Re: CPQary3 driver on Solaris 10

I have been able to use the iso image version successfully in the way mentioned here:

http://blogs.sun.com/pradhap/entry/solaris_hp_server_installation

and also in the Deployment guide mentioned here:

http://www11.itrc.hp.com/service/james/search.do?searchtext=patch+miniroot&submit.x=0&submit.y=0&hpl=1&todo=search&searchcriteria=allwords&from=other&searchcategory=ALL&rn=25&presort=rank&source=7000&esc=D+LINK&wpa=www11.itrc.hp.com%3A80&origin=0&chkServStor=on

But I am trying to build a completely automated Jumpstart process so manually swapping the disks is not useful for that. I'm not sure why adding drivers to the miniroot is broken but since the process of installing the drivers into the running installer system works, I am going to try to add the package in the begin script that runs before the profile is used. I'll just copy the process that the HP install script uses (a forced install with an admin file that disables requiring any user input) and see how that goes.
nada_1
Occasional Visitor
Solution

Re: CPQary3 driver on Solaris 10

D'oh! The solution for patching the u7 miniroot is described here:
http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1353427

There is a lock-file left in the u7 miniroot:

${miniroot}/tmp/AdDrEm.lck

That prohibits to successful add the driver.
I didn't see the error message:

===
## Executing postinstall script.
add_drv/rem_drv currently busy; try later

Installation of was successful.
===

because I've scripted the whole miniroot patching here.

So just be sure to remove that file before patching miniroot ;-)

Hope that helps you too.
semiattributable
Occasional Visitor

Re: CPQary3 driver on Solaris 10

nada Thanks! I had seen that post before but didn't realize that was the problem I was having. I got thrown off by the WARNINGs that pkgadd was kicking about unmet dependencies and then tried installing the unmet dependencies only to have those packages not completely install and went round and round a few times until I tried the at boot time install and began wondering about what the difference was with the package dependencies since it was the same miniroot that the package was getting installed to both before the install or during. Then I found the note in HP's

Sun Solaris 10
Deployment Guide for HP ProLiant Servers


"NOTE: The stock miniroot does not contain a record of which Solaris packages are already
installed. As a result, pkgadd(1M) can report that dependencies have not been met when
installing additional packages. You must verify that dependencies are met. However, in all the
specific examples provided in this guide, you can ignore dependency warnings from
pkgadd(1M) because the stock miniroot meets all such dependencies."

So I knew it wasn't a dependency problem after all. I revisited the miniroot install and watched the output more carefully and before it says that it installed successfully, it indeed says "add_drv/rem_drv currently busy; try later". Problem solved
Hiroki Hokazono
Occasional Visitor

Re: CPQary3 driver on Solaris 10

Hello,

I failed install the driver both ways using install.sh and using pkgadd to miniroot,
even if I removed state lock file which
succeed in Solaris 10 5/08 release.

Does anyone try to SmartArray driver in Solaris 10 10/09 release?