Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Can I use a P410 controller into a DL 160 G9 server?

SOLVED
Go to solution
Edson_Richter
Occasional Contributor

Can I use a P410 controller into a DL 160 G9 server?

Can I use a P410 controller into a DL 160 G9 server?

Regards,

Edson Richter

4 REPLIES
parnassus
Honored Contributor

Re: Can I use a P410 controller into a DL 160 G9 server?

I fear it will not work (for sure it is supported on Gen8)

Neither HPE ProLiant DL160 Gen9 QuickSpecs nor HP Smart Array P410 Controller QuickSpecs report Gen9 compatibility with P410 (it is matter of lack of P410 HP Storage Controller driver among Gen9 related OS Drivers)

As reference:

https://www.hpe.com/h20195/v2/GetDocument.aspx?docname=c04111713

and:
https://www.hpe.com/h20195/V2/Getdocument.aspx?docname=c04375607
Edson_Richter
Occasional Contributor

Re: Can I use a P410 controller into a DL 160 G9 server?

I don't want to be pedant, but just to clarify, drivers are a matter of operating system, aren't they?

Does RHEL 7 (Centos 7, OEL 7) support P410?

Or there is hardware incompatibility between DL160 G9 hardware and P410?

Is there anyone who made a test on it? The pricing of P440 and P410 is just a huge abism (almost the price of the DL 160 unit it self), and there must be a affordable solution that works. Anyone has any tips?

parnassus
Honored Contributor
Solution

Re: Can I use a P410 controller into a DL 160 G9 server?

I must partially correct myself: I'm not totally sure Gen8 supported old HP Smart Array P410 Controller...see indeed Gen9/Gen8 tables here.

I think it's a matter of UEFI Boot of Gen9: HPE Smart Array Controllers for Gen9 do support UEFI Boot (the key statement is "Supports legacy and UEFI boot operation on Gen9 servers")...controllers made in the far past for Gen8 (and older) probably don't.

So it's a matter also of Operating System Device Drivers (you need them in order for the OS to recognize logical volume(s) created by the underlying HP Smart Array Controller) *and* there is a major relationship with Server hardware (for booting using the installed HP Smart Array Controller)...if you look for "P410+Gen9" you will find that that combination doesn't work (at least this is what I found).

AFAIK the HP Smart Array P410 Controller (or here) belongs to (and thus was suppored by) Gen6 Server Hardware and, probably, some Gen7 Servers era (was it 2009?)...so it was engineered so many years ago (there was no UEFI Boot at time) for old generations of Server hardware not totally comparable with actual ones (Gen8, Gen9 or new Gen10).

Regarding the price: you can't really compare (any) RAID Controller made 8 or more years ago with actual ones...so the P410 versus P440 comparison isn't fair (neither considering what was the - at time - brand new List Price nor considering their respective hardware features/performances): here in Europe a brand new HPE Smart Array P440/4G Controller with FWBC (which is the most expensive version of P440...) could have a price of more or less 450/500 Euro + VAT (that's a Reseller price)...the most cheap (no HDD, no ODD, HPE Dynamic Smart Array B140i Controller) HPE ProLiant DL160 Gen9 (SKU: 830570-B21) could cost just 2.1 or 2.2 times (so more or less 1100/1200 Euro + VAT) the price of a P440/4G with FWBC...so it's literally impossible that a brand new HPE ProLiant DL160 Gen9 costs like brand new HPE Smart Array P440/4G with FWBC.

Those above are brand new Hardware with HPE Warranty, Reseller prices.

To check OS device drivers, firmware and controller utilities use one of the link provided above: it will be easy to check which OS is supported by P410, less which Server Hardware generation support booting into P410.

Highlighted
Edson_Richter
Occasional Contributor

Re: Can I use a P410 controller into a DL 160 G9 server?

Perfect answer! Thanks!