ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Boot SPP-2013.02.00 on DL365 (G1)

epretorious
Regular Advisor

Can't Boot SPP-2013.02.00 on DL365 (G1)

I've downloaded the Service Pack for ProLiant 2013.02.0 .iso, burned it to DVD, and verified that it was successfully created:

eric@eric-D630 ~ $ isoinfo -d -i /dev/sr0
CD-ROM is in ISO 9660 format
System id: 
Volume id: SPP2013020
Volume set id: 
...
Logical block size is: 2048
Volume size is: 1303761
El Torito VD version 1 found, boot catalog is in sector 230
...

eric@eric-D630 ~ $ dd if=/dev/sr0 bs=2048 count=1303761 | md5sum
1303761+0 records in
1303761+0 records out
c734bdf09f40818f4489be7e8c2b49d8  -
...

eric@eric-D630 ~ $ cat ~/Downloads/HP_Service_Pack_for_Proliant_2013.02.0-0_md5sum_spp_2013.02.0-SPP2013020.2013_0204.107.iso.md5sum 
c734bdf09f40818f4489be7e8c2b49d8 *SPP2013020.2013_0204.107.iso

 

However, when I boot using the DVD, the DL365 (G1) complains:

Warning!!! Unable to mount the file system [cdrom]
Warning!!! Unable to mount the file system

Dropping to a shell. Good luck!

/bin/ash: Can't access tty, job control turned off.

So I checked the Server Support Guide for Service Pack for ProLiant 2013.02.0 and verified that SPP 2013.02.0 does provide support for the DL365 (G1). In fact, it provides 80 packages for the DL365 (G1)!

 

What could be causing SPP to fail when booting?

 

Eric Pretorious
7 REPLIES
epretorious
Regular Advisor

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)

FWIW: I'm able to reliably boot the system and run HP Insight Diagnostics using the SmartStart CD Release 8.70 x64.

Eric Pretorious
epretorious
Regular Advisor

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)


epretorious wrote:

FWIW: I'm able to reliably boot the system and run HP Insight Diagnostics using the SmartStart CD Release 8.70 x64.


I've run HP Insight Diagnostics (Full Test) on both machines and both passed without a single error.

Eric Pretorious
Torsten.
Acclaimed Contributor

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)

I would try to create the USB key drive - maybe a problem while burning the DVD?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
epretorious
Regular Advisor

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)


Torsten. wrote:
I would try to create the USB key drive - maybe a problem while burning the DVD?

Thanks, Torsten, but -- as you might have noticed --...

  1. I'm a Linux user and, AFAIK, the HP USB Key Utility is only available for Windows users.
  2. The MD5SUM of the DVD media matches the .md5sum signature file (HP_Service_Pack_for_Proliant_2013.02.0-0_md5sum_spp_2013.02.0-SPP2013020.2013_0204.107.iso.md5sum) perfectly.

Got any other ideas or suggestions?

Eric Pretorious
Torsten.
Acclaimed Contributor

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)

Look into the USB directory - there is the linux version of the USB key utility.


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Jimmy Vance
HPE Pro

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)

I forwarded your issue to the SPP team and they were able to reproduce the issue. They haven't root caused the problem yet, but the workaround is to put the SPP on USB key, or boot via iLO virtual media.

 

 

 

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
Daza
Advisor

Re: Can't Boot SPP-2013.02.00 on DL365 (G1)

Hi,

 

I get the following error when i try pxe booting.

 

Warning ! Unable to mount the filesystem.

 

I have attached the screenshot.

 

 

I tried all SPP versions but no luck.

Only this version works 2012.01.0.  I want to use the latest version 2013.09.0(B). 

 

My configuration of pxelinux.cfg/default as follows,

 

DEFAULT firmware/menu.c32
PROMPT 0
TIMEOUT 0
ALLOWOPTIONS 1
MENU TITLE firmware update additions
label hpfwi
MENU LABEL Firmware Update SPP SPP201309 - Interactive
kernel firmware/hp/fw_cd_iso/SPP201309/vmlinuz
append initrd=firmware/hp/fw_cd_iso/SPP201309/initrd.img media=net rw root=/dev/ram0 ramdisk_size=485956 init=/bin/init loglevel=5 ide=nodma ide=noraid pnpbios=off
nopat hp_fibre vga=791 splash=verbose noexec32=off numa=off nox2apic showopts TYPE=MANUAL iso1=nfs://XX.XXX.X.XXX/media/firmware/hp/fw_cd_iso/SPP201309/SPP2013090.2013_0830.30.iso iso1mnt=/mnt/bootdevice

label hpfwa
MENU LABEL Firmware Update SPP SPP201309 - Automatic
kernel firmware/hp/fw_cd_iso/SPP201309/vmlinuz
append initrd=firmware/hp/fw_cd_iso/SPP201309/initrd.img media=net rw root=/dev/ram0 ramdisk_size=485956 init=/bin/init loglevel=5 ide=nodma ide=noraid pnpbios=off
nopat hp_fibre vga=791 splash=verbose noexec32=off numa=off nox2apic showopts TYPE=AUTOMATIC iso1=nfs://XX.XXX.X.XXX/media/firmware/hp/fw_cd_iso/SPP201309/SPP2013090.2013_0830.30.iso iso1mnt=/mnt/bootdevice iso1opts=rsize=32768,ro,nolock TYPE=AUTOMATIC AUTOPOWEROFFON
SUCCESS=no AUTOREBOOTONSUCCESS=yes

 

Thanks,

Daza