ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't build SATA RAID on ProLiant DL320 G5

SOLVED
Go to solution
Adam Dziurda
Occasional Visitor

Can't build SATA RAID on ProLiant DL320 G5

Hi.

I have HP ProLiant DL320 G5 server with 2x250GB disks. I've enabled array configuration software in RBSU(ROM-Based Setup Utility), then build array in Array Configuration Software. During POST array is shown, but Linux can't see it. It show me 2 separate drives.
Also HP SmartStart 7.80 and ACU show that it did not detect any supported controllers.

I dont know if i'm doing somthing wrong or is somthing wrong with hardware or software.

Can anyone help me?

Sorry fo my poor english.
Adam
6 REPLIES
Oleg Mochkin
Trusted Contributor
Solution

Re: Can't build SATA RAID on ProLiant DL320 G5

You have embeded SATA controlller with RAID support. This controller build on Adaptec HostRAID technology. HostRAID is similar to sowtware raid and you need an appropriate driver within OS. Your Linux kernel does not support this functionality so Linux see two independent disks.
Have a look at this:
http://www.learnaboutraid.com/pages/learn-about-raid/ways-to-implement-raid....php
SmartStart based on linux so storage controller is missing.
BR, Oleg.
Adam Dziurda
Occasional Visitor

Re: Can't build SATA RAID on ProLiant DL320 G5

Thanks,

But I don't understand why HP ships software which can't manage hardware?

One again Thanks for Your help.

Adam Dziurda
AMRIT RANJAN
Frequent Advisor

Re: Can't build SATA RAID on ProLiant DL320 G5

Hi , Adam
as per your query i came to know that you are unable to configure raid on this server
but issue is that the linux is not detecting the array , beacuse it don't have the driver for raid controller so you are able to see individual hdd while installation this server has Integrated Intel 82801GR Serial ATA Host Controller with RAID 0/1 support
here no issue is with HP,HP smart start cd support windows installation only, as the controller which is available in server that is normal raid controller not smart array controller so that is why smart start is not detecting controller, may i know the kernel version of linux which you are using or version with update after that i can suggest you for server deployment, for any query feel free to get in touch ....
Adam Dziurda
Occasional Visitor

Re: Can't build SATA RAID on ProLiant DL320 G5

Hi,

I'm using Debian 4.0 Etch kernel 2.6.18.
After reading something about fake-raid, I will probably give up setting this array. This server should stand up as quickly as possible. And it will not be funny when it begin syncing 250GB drives after fail over.

Thanks for Your help.

Adam
Paul Civati
Occasional Advisor

Re: Can't build SATA RAID on ProLiant DL320 G5

How do I get Debian (4.0/Etch) to see the RAID mirror as a single disk?

The support matrix says that this IS supported:

http://h71028.www7.hp.com/enterprise/cache/433096-0-0-0-121.html

However, this does not appear to work with the standard install kernel and I can't see any additional downloads for drivers?
PatrickS
Occasional Visitor

Re: Can't build SATA RAID on ProLiant DL320 G5

I have exactly the same problem, and all of the replies so far are BS. It has nothing to do with the OS driver. Smartstart should know about this controller, but it doesn't. If that's an "os" problem within SS, then it's still a SmartStart problem.

I am trying to use the SmartStart deployment on a new Windows server, DL320 G5 with the recommended SC44Ge HBA controller. The bios sees it, the RBSU sees it and lets me set it up, but SmartStart does not see any configurable devices. Our standard build involves SS with the installation of all of the management software and drivers, and I'd really rather not deviate, especially since I'm using the HP recommended parts, and the HP software that came with them.

If you can't tell, I'm a little ticked about the problem. The only reason that I haven't opened a support case yet is because I have to go through the reseller first, which is a pain in the rear.

Please, please, someone from HP tell me that there is a patch or new version of SmartStart that I can download to fix this?