ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't configure RAID on ML10 v2 (B120i controller)

 
SOLVED
Go to solution
Jimmy Vance
HPE Pro

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hopefully someone running Windows will post information on setting up the system using the B120i.  I spend my days on the Linux side of the house and don't work with Windows very often

No support by private messages. Please ask the forum! Accept or KudoI work for HPE
Matty-CT
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Remember good old SmartStart? You'd pop in the CD/DVD, boot to it, select the OS you want to install, SmartStart would configure array, partition drive(s), install OS after you popped in proper media, and start HP app/driver install upon OS first boot. You could even pre-register OS by entering COA info.

 

HP took half a step back with SPP if you ask me. I'm doing a ML10v2 right now for a customer and it's just a royal pain going through the extra steps. Is the extra 50 cents for a DVD or two in the box to assist in rapidly deploying a Windows Server OS such a burden on HP? I understand that HP has a procedure that works, but it isn't as good as it used to be, in my estimation.

 

As a matter of fact, on the ML10v2 support and drivers page, I don't see the B120i driver set listed! Seriously??? I've been an HP Partner for nearly 20 years. Ridiculous.

 

Matt

Vitalij_BY
Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hi, english isn't my native language, so sorry for mistakes.

 

Trying ask here: raid was configurate and choose in BIOS. When I begin install windows server 2008 r2 sp1, it shows empty window with driver choose and message: "can't to find disk driver", then I insert flashcard with raid driver controller b120i for windows server 2008 r2 from hp official site, then driver install run, but then it shows empty window with no one disk and ask disk driver again.

 

 

Highlighted
HPserverby
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hello everyone, I solved the problem.
The necessary drivers for the controller:

http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_0be6f79ae4094c4384c7dc4ef9

 

I tried it, and it's works.

Vitalij_BY
Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Thanks a lot !!! It works !!!

 

I spend my worktime in search of working drivers, finded many "dead" pages and links on hp site.

 

It will be first and last server by hp in our company. Awfull tech support.

arun-ajikumar
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

hai

already configure raid 1 on B120i controller but when i install red hat 6 it is showing 2 hard disk

TyomJan
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

For

B120i/B320i SATA RAID Controller

and if you install

Microsoft Windows Server 2008 x64

Microsoft Windows Server 2008 R2

Microsoft Windows Server 2008 R2 Foundation Edition

Microsoft Windows Small Business Server 2011 Standard and Essentials

Microsoft Windows Server 2008 Essential Business

Microsoft Windows Server 2008 Foundation Edition

you need this driver  cp024078.exe

http://h20564.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_0be6f79ae4094c4384c7dc4ef9#tab2

 

 

 

Jimmy Vance
HPE Pro

Re: Can't configure RAID on ML10 v2 (B120i controller)


@arun-ajikumar wrote:

hai

already configure raid 1 on B120i controller but when i install red hat 6 it is showing 2 hard disk


Read the installation instructions for the drvier download

http://h20565.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5293150&swItemId=MTX_0fd8d383cbd445e68f334a398a&swEnvOid=4103

Installation:

CREATING A DRIVER UPDATE USB-KEY

MAKING DRIVER UPDATE USB-KEY UNDER A LINUX-LIKE OS:

  • Save the "hpvsa-<version>.<OSupdate>.x86_64.dd.gz" file into a temporary directory. Use GUNZIP to extract "hpvsa-<version>.<OSupdate>.x86_64.dd" from this file into the same directory.
  • Insert the USB-Key. If the USB-Key is not mounted automatically, then mount it.
  • Copy the hpvsa-<version>.<OSupdate>.x86_64.dd file to the directory you USB-Key is mounted to and then umount the USB-Key.

INSTALLATION

At the initial OS installation screen be sure to:

for B120i: blacklist=ahci
for B320i: none
 

  • Press ESC key.
  • On the command line type the following to keep the ahci driver from interfering with the hpvsa drivers.
  • IMPORTANT: Remove the USB-Key once the driver has been installed to prevent the OS installer from including the USB-Key as part of the OS storage.

 

 

 

No support by private messages. Please ask the forum! Accept or KudoI work for HPE
Kvaksh
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

OMG.

 Is it normal?

 I think its serios bug.  Somebody wrote to support yet?

 P.S. English is not my strong skill

 P.P.S. http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0128448

 Blah-blah-blah, it's not a bug, it's a wonderful feature, be happy to scratching your left ear with right leg.

It’s my last purchase  from HP.

AleDT
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

Hi! Same problem. BIOS updated but F5 doesn't work... Solved using Offline HP Smart Storage Administrator Utility, via USB with HP USB Key Utility. Thank you Jimmy.

Anyway it's so sad that HP hasn't solved the problem in months and months....

Shamzi
Occasional Visitor

Re: Can't configure RAID on ML10 v2 (B120i controller)

I have configured RAID 1 in  ML 10 TODAY - 31-01-2018.

Step by step :

Turn on server

Click on delete button or esc button

It will redirect to bios.

Go to advance and select '' CMS CONFIGURATION'' and enable CMS SUPPORT and select boot optin filter and select legacy only

Again back to advance and select ''SATA CONFIGURATION''  & select SATA MODE SELECTION - change to RAID..

Then - scroll down & select -SOFTWARE FEATURE MASK CONFIGURATION & scroll down and change to 4 seconds  normal delay.

And save & exit.

Restart the server then keep press on CTRL + I then you can create the RAID :)

I hope it will help you.

Thanks

Shamzi