ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot boot from Smart Array

 
Ayman Altounji
Valued Contributor

Cannot boot from Smart Array

I cannot figure out how to boot from the Smart Array. The array itself seems to work fine. The configuration utility allows me to configure the drives in the array. OS installs that boot from floppies or CDs work fine, detect the drives, and copy files to the disk without any problems. When I reboot though it will not attempt to boot from the newly created partitions.

SmartStart (4.5) works fine except it will not install the system utility partition. When I try to do this I get the message "An error occurred while trying to access the fixed disk". As it is loading I notice that smrtscsi says "No Logical Drives Found".

I've completely cleared everything out with the system-erase utility, updated all the firmware for the controller, and am still getting nowhere. What am I doing wrong?

Thanks for any help
1 REPLY
Ayman Altounji
Valued Contributor

Re: Cannot boot from Smart Array

Here's some initial information:

I successfully installed Mandrake linux on the machine. Everything seems to work fine. However, the only way I can boot it is with a boot disk that contains a kernel image. I cannot get LILO or GRUB to boot the machine, even if they are installed to /dev/fd0. So I guess that means the BIOS is not making the disk array available until a kernel driver for it has been loaded.

A little further, but it still doesn't get me to my goal of having NT 4 server installed on the machine