ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot download HP QLogic Online Firmware

Cannot download HP QLogic Online Firmware

Hi

I' am trying to download the firmware from https://h20566.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_096edf3739ef43fdba3198ac5e in order to upgrading the HP ProLiant QLogic P2 and P3 10 Gigabit Ethernet NICs ROM images.

Clicking the buttom "Obtain software"  I receive

Not Found
The requested URL /pub/softlib2/software1/doc/p2025081362/v49549/filehandler.html was not found on this server.

Any help will be appreciated.

Thanks in advance

 Marco 

8 REPLIES
sdmitriev1
Valued Contributor

Re: Cannot download HP QLogic Online Firmware

Do you need exactly 5.0.0 version?

You can download HP QLogic P2/P3 Online Firmware Upgrade Utility for Linux x86 5.4.6 there:

https://h20566.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_d7872c382331478c96b9e96903 

 

Jimmy Vance
HPE Pro

Re: Cannot download HP QLogic Online Firmware

>From your link click on the Revision History tab, then click the Version 5.6.10 link to access a much newer version that you can download



__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
sdmitriev1
Valued Contributor

Re: Cannot download HP QLogic Online Firmware

5.6.10 only for Qlogic P3, 5.6.4 is last version with support of Qlogic P2 

Re: Cannot download HP QLogic Online Firmware

Thank you all

I have a DL580 G7 runnning RH 4.8 (we cannot upgrade the OS) , Firmware 4.0.527 running on the HP NC375i Ethernet Quad Port and device driver nx_nic version 4.0.556.

We have had the error 

Jul  7 11:04:36 fp2 kernel: nx_nic[eth4]: Device is DOWN. Fail count[8]

Jul  7 11:04:36 fp2 kernel: nx_nic[eth4]: Firmware hang detected. Severity code=0 Peg number=0 Error code=0 Return address=0

Jul  7 11:04:36 fp2 kernel: nx_nic: Flash Version: Firmware[4.0.527], BIOS[2.1.0]

Jul  7 11:04:36 fp2 kernel: nx_nic: No memory on card. Load Cut through.

Jul  7 11:04:37 fp2 hald[30194]: Timed out waiting for hotplug event 675. Rebasing to 676

Jul  7 11:04:46 fp2 udevd[1603]: udev done!

Jul  7 11:04:48 fp2 kernel: nx_nic: Loading the firmware from flash.

Jul  7 11:04:51 fp2 kernel: nx_nic: Gen2 strapping detected

Jul  7 11:04:54 fp2 kernel: nx_nic HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter Board S/N ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ^B^A  Chip id 0x1

so we need to update the firmware on the Quad Port and also the device driver.

For many of the versions available in the "revision history" tab, only some of them are available to me ; the ones available are only the ones where there is the buttom "Download".

For the others versions there is the button "Obtain software" that returns to me the "Not Found" error.

-----

The oldest available firmware for download is the 5.4.6 version.

Can I install it in the RH 4.8 or can I install also the latest available 5.6.10 ?

With the above firmware can I install the latest available device drivers version 4.0.590-2 ? 

In other words .... which firmware and device driver version can I install on a system running RH 4.8 ?

    uname output --> Linux FP2 2.6.9-89.ELsmp #1 SMP Mon Apr 20 10:34:33 EDT 2009 i686 i686 i386 GNU/Linux

Thanks in advance !

sdmitriev1
Valued Contributor

Re: Cannot download HP QLogic Online Firmware

You have to upgrade firmware to version 4.0.534 (last supported firmware for RHEL4) and downgrade your driver to 4.0.516 (last supported driver for RHEL4). Your driver 4.0.556 is for RHEL5/6.

I can't download 4.0.534 firmware (got the same error), but driver 4.0.516 is accessible, you can try  

Re: Cannot download HP QLogic Online Firmware

Thanks sdmitriev1

The Firmware affected are the ones earlier than version 4.0.585 for the network adapter NC375i as is written in the HP Advisory http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c02964542

So I need to install at least this firmware version and the relative device driver ...

I suppose that the fact that RH 4.x is not one of the supported OS's by the above firmware version is caused by the fact that this version of RH is out of support by Red Hat and not for other reasons ...HP doesn't check , of course, software/firmware/device driver for OS versions that are out of support ...

So i NEED to install firmware >= 4.0.585 and the proper device driver version .... is there a solution or am I obliged to change the network adapter ?

Thanks

 

sdmitriev1
Valued Contributor

Re: Cannot download HP QLogic Online Firmware

So i NEED to install firmware >= 4.0.585 and the proper device driver version - yes, it's look like the right way

Jimmy Vance
HPE Pro

Re: Cannot download HP QLogic Online Firmware


sdmitriev1 wrote:

5.6.10 only for Qlogic P3, 5.6.4 is last version with support of Qlogic P2 


By serching for your server moel in the HPSC, I was able to drill down to this update which shows to support P2/P3  It is listed for Both RHEL and SLES so it may not be OS version specific

http://h20566.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=4142793&swItemId=MTX_d7872c382331478c96b9e96903&swEnvOid=4006

HP QLogic P2/P3 Online Firmware Upgrade Utility for Linux x86
Type: Firmware - Network
Version: 5.4.6(18 Feb 2014)
Operating System(s):
Red Hat Enterprise Linux 5 Server (x86) | Hide all
SUSE Linux Enterprise Server 11 (x86)
Red Hat Enterprise Linux 6 Server (x86)
Multi-part download
File name: CP020908.scexe (4.3 MB) Download
File name: CP020908.txt (4.5 KB)




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!