ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

Cannot use Power Regulator with DL360 G5 + Xeon L5320

Occasional Contributor

Cannot use Power Regulator with DL360 G5 + Xeon L5320

When I install a Quad Core Xeon L5320 cpu (SLA4Q) in my Proliant DL360 G5, I can only use OS Control mode in the Power Regulator. If I choose any other mode in the iLo2 web interface, once I hit Apply the page returns with "OS Control" selected. Also rebooting the server still shows "OS Control" as the active mode on the POST screen. I also tried changing the mode via Lights Out XML Scripting inside the server OS, but trying to set it to anything other than OS Control gives the error code 0x004A and "The value specified is invalid".


However, if I install my Dual Core Xeon 5160 in the server instead, it works fine and lets me use whatever mode I choose without any problem.


The L5320 is listed as supported for the Proliant DL360 G5 in the HP Power Regulator support matrix, so it seems it should work.


My iLO2 firmware and the BIOS are at the latest versions already.


I don't wan't OS Control mode as I need to use Dynamic Power Capping.


I've tried resetting BIOS and iLO2 to defaults, even tried taking all RAM out of the board and the BIOS battery for a while, but no joy.


I also tried changing the mode in the BIOS setup page.  Interestingly, the change takes effect there, but then on the BIOS POST screen on bootup it still shows the mode as OS Control, and also in iLO2 it shows OS Control. So although it gives the impression in the BIOS setup that the mode is changed, in fact it doesn't take effect.


On other thing I tried was installing my Xeon 5160 that works, changing the Power Regulator mode to e.g. Dynamic Power Savings (which takes effect just fine), and then swapping the CPU to the L5320. But didn't work, the mode just goes back to OS Control as soon as the L5320 is installed.


Can anyone help? as I've run out of things to try. Is the HP matrix saying the L5320 is supported just wrong,  or maybe this particular revision of the L5320 (SLA4Q) doesn't work?  I'd be happy to try another "L" Xeon but can anyone report they've been able to use Power Regulator on this server with an "L" Xeon?



Occasional Contributor

Re: Cannot use Power Regulator with DL360 G5 + Xeon L5320

Hope it's OK if I bump this, still haven't been able to figure out the problem. Thanks in advanced to anyone who can help, or who can just confirm if Power Regulator works for them with any of the Xeon "L" cpus.