ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DISKPART ERROR "the disk management services could not.."

Tom_301
Occasional Visitor

DISKPART ERROR "the disk management services could not.."

I'm trying to expand a basic volume on a raid 5 array in a proliant 530 with W2K Server. I'm following the directions in hp doc # 5981-7156EN. I extended the array with no problem however when I try to run diskpart I get the error "The disk management services could not complete the operation." I found an MS article that talks about this error however it (and MS - I called them) claim the problem was fixed with SP4 which is installed on this system. I have an identical test server that I tried this on first and it ran flawlessly so I know it does actually work.

Thanks in advance for the help.

Tom
2 REPLIES
SAKET_5
Honored Contributor

Re: DISKPART ERROR "the disk management services could not.."

Hi Tom,

So, were you referring to this article:
http://support.microsoft.com/default.aspx?kbid=327020

Note, that this article talks about dynamic disks and not basic disks.

Do you see the unallocated space next to your existing basic disk partition as a consequence of array expansion?

Have you tried a restart of "Logical Disk Manager" service on your Windows host? Does it successfully stop and restart? If it gets into a "starting" or "stopping" state, you can force a kill by using MS's "Kill" utility or you can use Sysinternals "PSKILL".

Additionally, have you rebooted your server after extension of your array?

Let me know how you go with the above,

Hope it was of help and dont forget to assign points:)

regards,
juzsteve
Visitor

Re: DISKPART ERROR "the disk management services could not.."

I know this is an old thread but it did help me resolve a diskpart issue but with one additional step that I found on my own. I thought I would share it in case someone else stumbles across this at a future time. Anyway, it is mentioned that the Logical Disk Manager should be restarted. In my case even after doing so the issue was still present and it was not until I started the Logical Disk Manager Administrative Service that the problem went away.

 

Cheers.