ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

[DL 360 Gen8] ILO 4 small issue

 
John Albrektson
Occasional Contributor

Re: [DL 360 Gen8] ILO 4 small issue

I spent hours (well, 20-minute that seemed like hours) working on that Force_Flash script and each time got a syntax-error response.  The command in the referenced document is,

C:\hpqlocfg -s -l c:\hpqcfg.log -f c:\Force_Format.xml -v -t user=Administrator,password=

BUT, the user/password is in the Force_Format.xml script; is it necessary to use the -t user,password part?  I tried to simplify it by putting hpqlocfg.exe and Force_Format.xml in C: and simply running

hpqlocfg -s 192.168.1.5 -n -f c:\Force_Format.xml

and still couldn't make it work.  Every configuration I tried failed with "Invalid Arguments Passed."  Can someone please give me an exact string that might work?  Thanks!

I opened a case with HPE; the tech said it was an irrelevant error and I could ignore it.  I'm going to revisit the case on Tuesday.

John Albrektson
Occasional Contributor

Re: [DL 360 Gen8] ILO 4 small issue

Darn, I hate replying to my own pleas for help.  Here was the problem(s):  What worked was:

hpqlocfg -s 192.168.1.250 -n -v -f c:\Force_Format.xml

The key was specifying the ILO IP address, not the machine itself.  Not sure why that didn't occur to me earlier. 

Torsten.
Acclaimed Contributor

Re: [DL 360 Gen8] ILO 4 small issue

-s ILO-IP-address is missing

 

This is what I used:

hpqlocfg -s servername -l c:\hpqcfg.log -f c:\temp\ilo-force-format\Force_Format.xml -v -u Administrator -p password


Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
NJK-Work
Honored Contributor

Re: [DL 360 Gen8] ILO 4 small issue

Hello,

Could someone confirm if step 3 is needed to fix the error message, or just get Intelligent Provisioning working again.  We dont use IP, so if this step is not need to fix the overall error message, then I would like to skip it.

Thanks

NK

Jimmy Vance
HPE Pro

Re: [DL 360 Gen8] ILO 4 small issue

Just formatting the NAND device should resolve the iLO error displayed during POST

No support by private messages. Please ask the forum! 
I am an HPE employee
Accept or KudoI work for HPE
NJK-Work
Honored Contributor

Re: [DL 360 Gen8] ILO 4 small issue

Thank you sir.

NK

 

BOYAN BIANDOV
Regular Advisor

Re: [DL 360 Gen8] ILO 4 small issue

I think I'm missing the first step; how do you boot the box in order to get to a prompt to do the format:

 

hpqlocfg -s servername -l c:\hpqcfg.log -f c:\temp\ilo-force-format\Force_Format.xml -v -u Administrator -p password

 

Thanks

~B

GustavoAyala
Advisor

Re: [DL 360 Gen8] ILO 4 small issue

You don't have to do that in the same box. You do it from another helper computer thru the network.

Jimmy Vance
HPE Pro

Re: [DL 360 Gen8] ILO 4 small issue

There are several ways to access the iLO. From the host OS using 'hponcfg' from a remote windows client using 'hpqlocfg.exe', from a remote Linux or Windwos client using the 'locfg.pl' Perl script

Access the support site for driver downloads, search for your system, select the OS, and look under 'Software - Lights Out Management '

No support by private messages. Please ask the forum! 
I am an HPE employee
Accept or KudoI work for HPE
NJK-Work
Honored Contributor

Re: [DL 360 Gen8] ILO 4 small issue

Hello,

In the advisory provided by HPE regarding this issue (http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-c04996097) it provides a link to the iLO Online Utility to use - which links to version 1.50:

http://h20566.www2.hpe.com/hpsc/swd/public/detail?swItemId=MTX_c2f8737292c74b3b852b063ff7

However, there is no download button for that version, on that page.  In the release notes for that version, it states you MUST use version 1.50 for iLO firmware versions 2.30 or later:

For iLO 4 Firmware version 2.30 and onwards, it is a must to upgrade to  HPQLOCFG v1.50.

But as I stated above, there is no download link.  In fact, if you go to the software download page for the DL380 Gen8 (for example), the latest version you can download is 1.40; version 1.50 is not even listed.

So I am hesitant to use version 1.40 to run this script and possibly make things even worse.  Does anyone know where I can get version 1.50 downloaded?

Thanks

NK