ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL120 G9 Noise due fans stuck at 40%

 
sgiordy
Occasional Advisor

DL120 G9 Noise due fans stuck at 40%

Hello,

we have two DL120 G9 with same configuration. After the OS boot, all the three fans remain at 40% of speed, generating an unbearable noise.

There is a similar advisory (c04841782) for DL180 but none of solutions provided have worked.

We done all kind of test: with or without drives, with or without RAM, with or without PCI card, updated with last SPP 2017.04, tried with Windows, ESX, Linux... nothing to do.

The server is inside a room with controlled temperature, working at 21 C

Compared to other HP servers in the same room, the others has fan at 10-15% of speed, these at 40%.

I would exclude hardware issue because the behaviour is the same for the two servers.

I think something regarding wrong temperature reading by some sensor... do you have any suggestion?

Thank you

S.

12 REPLIES
parnassus
Honored Contributor

Re: DL120 G9 Noise due fans stuck at 40%

Does HPE iLO4 (expected Firmware version 2.53) report any Fan/Temperature related issue?

An HPE ProLiant DL120 Gen9 with three installed fans means that its CPU consumes less than 105W, is that correct?
Are Fan Bays populated correctly to grant proper cooling (Fan bay 1, 2 and 4 should have Fans, Fan bay 3 and 5 instead should have Fan Blanks)?

http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=mmr_kc-0129611

Is the DL120 Gen9 equipped with HPE Smart Array Px4x or Hx4c controller? if so is it running very latest 5.04 Firmware?

http://h20564.www2.hpe.com/hpsc/doc/public/display?docId=emr_na-a00008294en_us&sp4ts.oid=7271227

What's about disks types?
sgiordy
Occasional Advisor

Re: DL120 G9 Noise due fans stuck at 40%

Hi Parnassus, thank you for reply.

All the firmware are up to date with the latest SPP 2017.04.

ILO does not report any temperature or fan issue (all green) but with a freeware tool under Windows we found that HD Max sensor is reporting overheating. The strange is that HD Max is OK for ILO.

I confirm that the CPU consumes a maximum of 85W and the fans are properly fit (bay 1,2 and 4).

The servers have no disks (boot from USB) and are equipped with Smart Array B140. However we tried with one or four disks, with or without array configured and also in AHCI mode. The disk controller seems indipendent to the issue.

Today we did a desperate test :-) putting the ambient sensor under an ice cube. ILO was reporting an ambient temperature of 4° C and only fan 4 slowed down to 19%. Fan 1 and 2 still at 40%. Seems it's all increased by an offset of 20% ...

Jimmy Vance
HPE Pro

Re: DL120 G9 Noise due fans stuck at 40%

The HD Max sensor is tied to the disk controller.  If your using the embedded B140i controller the OS needs to be running the correct driver for the B140i RAID function. If you run the controller in AHCI mode the fans will spin faster. as there is no driver to report HDD temperatures back to iLO

 




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
sgiordy
Occasional Advisor

Re: DL120 G9 Noise due fans stuck at 40%

Yes, I know.

As is wrote we tried running Windows, ESXi and CentOS. Most of the test was made with Windows with all the required driver installed. AHCI was one of the many tests done, however in production these servers will work without disks.

Jimmy Vance
HPE Pro

Re: DL120 G9 Noise due fans stuck at 40%

What OS will be running on these diskless systems?




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
sgiordy
Occasional Advisor

Re: DL120 G9 Noise due fans stuck at 40%

The goal is to install CentOS and use the two servers as KVM hosts.

Due fan issue we stopped the deploy and tried before with ESXi and after with Windows (so we have much diagnostic tools). Windows has been installed on HDD, but nothing has changed.

If it's important... the server boots with fan at 100% (i suppose), during OS loading the fan slowing down as expected but remain at 40% (as ILO reports).

Jimmy Vance
HPE Pro

Re: DL120 G9 Noise due fans stuck at 40%

Did you install the HPE B140i driver for Windows?  The B140i driver does not ship with any OS media

Under CentOS you will need to load the Red Hat version of the proprietary hpdsa driver. I'm pretty sure the driver is embedded in the HPE ESXI custom image. Without the driver the fans will spin faster.  If you press F10 and launch Intelligent Provisioning, the hpdsa driver gets loaded and the fan speeds drop to 11%, 11%, 6%. Unfortunately that is just the way things work with the 'B' Series Dynamic Smart Arrays.   Systems with an 'H' or 'P' series Smart Array work differently and don't rely on a driver for temperature readings.

The system I looked at tonight, the fans are running at 32% without the driver loaded.




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
sgiordy
Occasional Advisor

Re: DL120 G9 Noise due fans stuck at 40%

Hi Jimmy

Yes, with Windows we have loaded all the drivers, including B140i

However now we did a new try with ESXi custom image (v. 6.5.0 2016-11-18). During boot the HPDSA is loaded but nothing happens to fan. Still at 40%

 

 

PiterParker
Valued Contributor

Re: DL120 G9 Noise due fans stuck at 40%

Hi m8, 

 

Probably you tried it already but I did not see anything mention in the conversation. 

 

Did you try to change cooling profile or power profile in the BIOS. 

Regards, 

Piotr

sgiordy
Occasional Advisor

Re: DL120 G9 Noise due fans stuck at 40%

Hi Piotr

Yes we tried :-(

Cooling has tree options: normal, increased, maximum ... with the last two the fans goes up to 100%

Power profile: minimum, maximum, balanced... but none of these has effects on fan

PiterParker
Valued Contributor

Re: DL120 G9 Noise due fans stuck at 40%

Hmm, 

I am not sure what to advise. I believe your concern is that fans are not going lower than 40%?
I believe it could be a problem with the design of the revision model. 

Few months ago we had a problem with 4 x HP DL380 G9 servers, where after shut down machine, server was down but connected to the power so it was in standby mode and in that mode FAN in slot 6 was continuously spinning. We had the same problem on all 4 machines recently ordered that time and all has the same problem. We were running cases, updating SPP, changing motheboard and no solution... 

 

 

sgiordy
Occasional Advisor

Re: DL120 G9 Noise due fans stuck at 40%

Yes, the noise is unbearable!

In the same room we have many other servers, including older HP, and it's all quiet!

Entering the room make you thinking about some kind of issue, instead is it "normal" for these servers to keep the fans at 40%. I hope that a new firmware can fix the problem... Jimmy says that his DL120G9 goes at 11% of fans

Moreover the power consumption... much efforts to have low power CPU and after all we waste energy to move air! :-D