ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL140 G3 RAID Controller sees no hard drives

SOLVED
Go to solution
StevenJSmith
Advisor

DL140 G3 RAID Controller sees no hard drives

I am trying to set up a DL140 G3 p/n 442993-425 straight out of the box but having enabled my RAID controller it is not detecting any hard drives. I can get into the configuration utility ok (F8) but no hard drives are reported as being present. I have reseated all cables and the HP 8 Internal Port SAS HBA controller to no effect. I have also tried connecting one hard drive straight to the system board and it is detected OK. Is there anything I need to do to get the system to recognise the disks? It's beginning to get a little wearing! Thanks in advance.
12 REPLIES
James ~ Happy Dude
Honored Contributor

Re: DL140 G3 RAID Controller sees no hard drives

StevenJSmith
Advisor

Re: DL140 G3 RAID Controller sees no hard drives

I only wish it were that simple :) I did try that procedure but when i successfully connected the hard drive to the system board I did so when it was in the drive cage so this means it must be seated correctly. It looks like the problem is related to either the HBA card, the cabling or to some BIOS-type setting that is not correct, but as i said the server is straight out of the box so i'm a bit confused. Thanks for the response anyway.
James ~ Happy Dude
Honored Contributor

Re: DL140 G3 RAID Controller sees no hard drives

Hello Steven,
If You are using:
HP 8 Internal Port SAS HBA with RAID, Option Kit > OPTION PART # 347786-B21

then,
HP 8 Internal Port SAS HBA with RAID requires the purchase of the PCI-X Riser Option kit (P/N 409347-B21)

Have you got this already ?

Regards,
James.
StevenJSmith
Advisor

Re: DL140 G3 RAID Controller sees no hard drives

Our server came pre-configured with an LSI Logic manufactured controller card SP#435709-001 mounted in a low profile PCI-X riser p/n 389895-502 (SP#408293-001). I rather assumed all I would need to do is plug in two drives enable the RAID in the BIOS and off we go. I have had nothing but bad experiences with SATA HDD based servers however.
Valerie G
Occasional Visitor

Re: DL140 G3 RAID Controller sees no hard drives

My situation is almost identical. During bootup, my hard drives are recognized. However, when I try to load the OS (Windows 2003 Standard Server), it cannot find any drives.
StevenJSmith
Advisor

Re: DL140 G3 RAID Controller sees no hard drives

Don't ask me why but the server is now detecting the drives and i've managed to configure RAID. I changed nothing, so it doesn't fill me with confidence for the reliability of the server.

Valerie - I think you're at the stage i'm now at; getting Windows onto my newly configured drives. Windows will require an additional storage driver loaded (boot from the Windows CD then F6 when prompted) however this requires a USB floppy drive and i have read that there are also issues with any drive not HP branded! Anyway i'm off to try it.
StevenJSmith
Advisor

Re: DL140 G3 RAID Controller sees no hard drives

Don't ask me why but the server is now detecting the drives and i've managed to configure RAID. I changed nothing, so it doesn't fill me with confidence for the reliability of the server.

Valerie - I think you're at the stage i'm now at; getting Windows onto my newly configured drives. Windows will require an additional storage driver loaded (boot from the Windows CD then F6 when prompted) however this requires a USB floppy drive and i have read that there are also issues with any drive not HP branded! Anyway i'm off to try it.
James ~ Happy Dude
Honored Contributor

Re: DL140 G3 RAID Controller sees no hard drives

Steven,
are you using HOT plug HDD ??
Then you will Also need option Part #
389650-B21 for HP SATA/SAS Host Cable Kit

Valerie,
You are facing a different situation;
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1161865

Regards,
James.
James ~ Happy Dude
Honored Contributor
Solution

Re: DL140 G3 RAID Controller sees no hard drives

Just read your reply steven !
Thats great !

Hope things will be good from here;

You may refer to the link above which in-turn contains links-within-links... to help you configure RAID; using nLite, or, installing OS without RAID & then converting to RAID.

Good luck;

Regards,
James.
markv_1
Occasional Advisor

Re: DL140 G3 RAID Controller sees no hard drives

Working solution for me ( DL 140 G3 and SAS 8 Port Controller )

was, to use Nlite and use the drivers from the LSI Homepage ( only they worked !! )

( for Windows 2003 the name is SAS_P10_Win2003x86_32)

the drivers supplied by HP have a bug, and therefor if you add them to a CD they still will not see the controller

Would be nice if someone from the HP guys would check that ;)

Cost me alsmost 2 Days to find a working solution as the DL 140 G3 get no PSP or SMARTCD which is not really helpful
StevenJSmith
Advisor

Re: DL140 G3 RAID Controller sees no hard drives

See above for solutions. Thanks to all who contributed.
KarloChacon
Honored Contributor

Re: DL140 G3 RAID Controller sees no hard drives

but which card do you have?

# HP 8 Internal Port SAS HBA with RAID 0,1 on Hot Plug SAS/SATA Models
# HP SC11Xe Host Bus Adapter
# HP SC44Ge Host Bus Adapter

???

regards
Didn't your momma teach you to say thanks!