ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL140 G3 - Windows XP x64 installation problem

 
tomasz_78
Occasional Visitor

DL140 G3 - Windows XP x64 installation problem

Hi.

Does anybody tried to enable RAID on Windows XP x64. I can't find any drivers for 'HP Embedded SATA' for Windows XP x64 :(

When Windows installation starts I press F6 and I should use a floppy disk with drivers but I don't have it. In few minutes I'm going to try with Win 2003 x64 driver - I hope it is going to work.

Does anybody have any experience with this SATA RAID controller and Windows XP x64?

Regards,
Tomasz
2 REPLIES
Mi6t0
Trusted Contributor

Re: DL140 G3 - Windows XP x64 installation problem

Check this out:

Follow the steps below and there is no need to use Floppy Drive or a Slipstreaming OS CD:

1.

Install the OS with Embedded SATA RAID Disabled (No Drivers or F6 required) on one Harddrive.
2.

Once OS is installed, Extract the Embedded SATA RAID Drivers to a folder. HP Embedded SATA RAID Controller Driver for Windows 2000/Windows Server 2003:


3.

Go to Control Panel-> Add New Hardware->Device is connected->New Hardware->Raid Controller->Have Disk->Browse to the folder where the Embedded SATA RAID Drivers were extracted. Select the .inf file->Install Adaptec Raid Driver.
4.

Restart the Server go to BIOS enable the Embedded SATA RAID.
5.

Press F8 and go to Sata Raid BIOS->Configure the Drives->Create Array->Raid 0/1 A warning message will appear "Warning: Configuring the drives will erase all Array information from the selected drives, if that drive is part of an array. Arrays using any of these drives as members will be affected! Do you want to continue?(Yes/No):". Press "Y" to continue.
6.

If Raid 1 is selected it will ask you what is the Source Disk, select the Right Disk in which OS was installed previously. Warning message might appear again. Select "Y".
7.

Rebuild will take sometime, once rebuild is complete restart the server.

Once rebooted Raid would be detected and windows would boot up, in windows it would detect new hardware and Adaptec Raid drivers will be installed. Now Server is built migrated to Raid Successfully.




About the driver - try to download the driver for 2003x64 and extract it :)
tomasz_78
Occasional Visitor

Re: DL140 G3 - Windows XP x64 installation problem

Hi.

What I did is:
- disabled RAID in BIOS
- installed Windows XP x64
- installed RAID driver for Windows 2003 x64

Then I've enabled RAID in BIOS and add my 2 drives into array without RAID building.
Now when I start server Windows Loading page appears and after few sesonds server restarts without any message.

At the moment I'm building RAID-1 and I'll see if my Windows starts. If not I don't have any other idea what can I do to enable RAID on that DL on Win XP x64 :(

Tomasz