ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL145 G3 - Windows Setup Not Finding HD

John Desvernine
Occasional Contributor

DL145 G3 - Windows Setup Not Finding HD

I have a single 80 GB SATA drive using the ServerWorks integrated SATA controller. I am trying to install Windows Server 2003 x64 R2 Enterprise and I get the "Setup did not find any hard drives installed" error. I can't find drivers specific to the Serverworks chipset on the server support CD or website. What to do?

Thanks,

JD
2 REPLIES
John Desvernine
Occasional Contributor

Re: DL145 G3 - Windows Setup Not Finding HD

I figured out a work around. In the cmos go to advanced and change SATA settings from SATA to PATA and the OS will find the drives. I imagine they will come out with a working driver some day. Until then, I will prolly have degraded disk performance. Switching back to SATA mode after the OS install results in the BSOD experience.

Here is a quote from the OS config guide: Use the native SATA mode if you are installing a Linux operating system. Use the PATA setting if you are installing Microsoft Windows.
CAUTION: If you do not change the SATA mode setting to PATA before you install Windows with the default ATA driver, the
operating system will hang.

JD
Allisen
Occasional Contributor

Re: DL145 G3 - Windows Setup Not Finding HD

Had the same problem with my DL145 G3 w/ 2 80 GB drives.

Yes this is the fix that worked for me too. Tried changing it back to SATA after install and it got the BSOD. Also, tried loading the Windows 2003 server SATA drivers by pressing F6 during setup and loading them from a floppy, it recognized the driver and said it loaded it but it still did not see the drives.

Also could not find a Smart Start CD for this server.