ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL160 G6 Unable to use RAID before install OS

Marcel_Brown
Advisor

DL160 G6 Unable to use RAID before install OS

For about a day I'm trying to setup a raid 1+0 on this system. Default is has 1 x 160GB SATA drive and I've inserted a 2nd drive 160GB. Via de BIOS enabled SATA RAID and configured via F8 a 1+0 RAID. When using the Easy Smartstart CD 1.0(b) and v2.00 they are unable to detect the controller (HP Smart Array Sata RAID B110i). During the setup within the CD you can also configure an array but it just crashes wihtin a Firefox session. Strange because I already configured an array from within the controller software. When I skip the array config from the CD It can't continue and returns the message Partitioning had failed - unable to continue - could not update disk mbr code. When I skip the config within the controller, and try to use the array config from the cd, again it crashes within the FF session. I also tried not using the CD and just using Windows 2003 server standaard R2 to boot with an embeded driver (nLite) it returns a BSOD. With Windows 2008 servers it can't detect the controller with the drivers.

I already opened a case with HP. The supplied me with several drivers for all OS'ses mentioned. None of them work. They say the Easy CD is just crap, don't use it. Strange advise ....

Still. I'm looking to a server I can't use. I can't imagen I'm the 1st person facing this simply issue, installing a OS.

Maybe somebody can give me usefull advise?

Thanks.
25 REPLIES

Re: DL160 G6 Unable to use RAID before install OS

First, I am a bit confused, as I thought the controller can handle raid 0,1 and 10.
However with two disks attached I can only choose raid 0 or raid 1+0. I hope this means the controller uses raid 1 if there are two drivers attached.

Second, using Windows 2008 R2 I am also not able to bind the B110i into the setup. It shows up as compatible driver, but it produces an error when it tries to load the files from the USB stick.
Marcel_Brown
Advisor

Re: DL160 G6 Unable to use RAID before install OS

From the HP Support I've understand that the B110i is not a common controller.

Meanwhile upgrading the bios also does not help. Case still open with support ....

Re: DL160 G6 Unable to use RAID before install OS

Hoho,
not a common controller... I think I bought a HP? I settled with using AHCI-mode for my Windows 2008 R2 RC tests. I just need to test Hyper-V2 RC/SCVMM 2008 R2 RC, but when 2008 R2 hits the market on 22nd october HP should be ready with a driver...
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

Hi,
Did someone solve this problem ?
I have the same ... Bought a DL160G6, removed the 160GB hard drive and put 2x HP 250GB hard drive, configured the RAID 1+0 via F8, and the Easy Setup CD hangs on the "could not update disk MBR code"...

Booting on the Windows Server 2008 "HP Branded" DVD doesn't work (bootlock : cannot find media), booting on a Windows Server 2008 from MSDN doesn't work because I can't load the drivers of the b110i controler ...

Could HP have sold some hardware that cannot work ??? How will I explain to my customer I sell a hardware RAID controler enabled server, and it will run on a shitty software RAID configured inside Windows ........

That's a shame for HP servers !!!
Marcel_Brown
Advisor

Re: DL160 G6 Unable to use RAID before install OS

Tommorow an HP engineer will be here to replace the backplane of the server. My drives should be OK. More news later.

Re: DL160 G6 Unable to use RAID before install OS

I will open a support case for this tomorrow and point HP to this thread, so they see there are many customers falling struggling with that problem.

My tried and failed setup was:

Windows 2008 R2 RC german
2x 750 GB Samsung SATA
Raid '1+0' setup
B110i controller shows as valid but fails on install
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

Just had HP Support by phone, they told me to download the new version of the Easy Setup CD (v 2.00, shipped was the 1.00b) and burn it to boot the server and install the OS. That should solve the problem ...

I'm actually downloading, and will give it a try in less than an hour, I'll let you know as soon as I know ...

For information, the download is availaible with many others by selecting the "United States - English" language at the top right of the http://www.hp.com webpage, before browsing to drivers section ...
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

I don't know why I expected it to work ...

Exactly the same error ... "could not update disk mbr code" ...
Marcel_Brown
Advisor

Re: DL160 G6 Unable to use RAID before install OS

Engineer was here. There is no backplane in this server. So he could return with the item. Tommorow they are going to replace the motherboard, since the backplane is on the motherboard. To be continued ....

BTW EasyCD2 also does not work as mentioned in my first post.
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

Well mbr99, I think I've forgotten what I've read in your initial post, I would have known that the v2 of the CD doesn't even work ...

I don't think this is a hardware issue as we are many people having the same issue ... Anyway, you can tell us if changing the hardware resolves your problems, so I can do the same ...

But in emergency, I've setup a software RAID inside W2K8 so I can put the server in production ... I'll remember to test another brand next time I'll sell a server ...

Re: DL160 G6 Unable to use RAID before install OS

The version inside the easy-setup-cd v2 is 6.6.0.64, called cp010380.exe

The newer version on the homepage is 6.6.2.64, called cp010930.exe

Both don't work, as it seems!

Re: DL160 G6 Unable to use RAID before install OS

So to get this a little more straight: I tried on Windows 2008 R2 RC, you alle tried Windows 2008 R1. Did you try x64 or x86?

Marco
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

Yes, I was trying "Windows Server 2008 Standard x64 (HP Branded)", using Easy Setup CD,

and "Windows Server 2008 Standard x64 MSDN" booting normally.

One thing to notice is that the MSDN version did boot, but then didn't load any driver for the RAID Array, but the HP Branded did not start setup when booting alone, the error message was "Bootlock : cannot find media".

But when the RAID Controller was disabled in the Bios, I managed to install W2k8 correctly. This is why I actually ended by building a software RAID using Windows functionnalities. Not the best performance, but at least it works ...

Re: DL160 G6 Unable to use RAID before install OS

Maybe everyone should post his setup:

DL160 G6 rom 2009/06/10
RAID 1+0 in B110i setup
2x Samsung HD753LJ SATA
Windows 2008 R2 x64 RC from MSDN

all driver versions and eays-setup-cds fail

Re: DL160 G6 Unable to use RAID before install OS

Ok, I solved it!

I used two firmware updates from HP for the BMC and ROM, the files are called:
SP44271.exe
Sp44299.exe

I think this upgraded the B110i firmware to v1.10, could you please check your B110i versions before you update?

I then used the regular driver for the B110i from the homepage. I put all those files here:

http://nachtrab.de/files/hp_dl160_g6/

What still bothers me is the naming of those raid levels in the setup:
It calls raid0 'fault tolerance', and does not show any raid1 option, only a raid1+0 option, which seems to be raid1, as raid1+0 would need four drives and I am only using two!
After install I will rip out one of those drives just to be sure...
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

Arghhh, I feel like I need to reinstall this server from scratch using the hardware RAID ...

Thanks so much to HP for having tested their hardware before manufacturing ...

Thanks a lot, REALLY, to you for having found the solution, and posted the files to your website ... I hope to read some good news from you today about the RAID 1+0 feature working like a RAID 1, so I will be sure to reinstall this server as I said ...

Re: DL160 G6 Unable to use RAID before install OS

The good news is, the array is working as a raid1 should, and with the installed event notifier agent the loss of redundancy is shown in event manager in windows 2008 r2. When rebooting the server the B110i offers to rebuild redundancy. Fine.

What I noticed though with the B110i is that write caching seemed disabled (going to the HP Logical SCSI Volume, Properties, Caching is disabled), and cannot be activated. It says this should be done via ACU, the Array Manager. That one does not work for me, I get a browser site 127.0.0.1:2081 that is not reachable.

Write performance is abysmal therefore, and hovers around 10MB/sec, whilst read is around 90mb/sec
sierramike
Occasional Advisor

Re: DL160 G6 Unable to use RAID before install OS

So ... It sounds like it's still not perfect ... Still wondering about what I'll do ...

Just keep us informed if you find that last solution ... Thanks for your great job about that issue !

Re: DL160 G6 Unable to use RAID before install OS

I now also got write-caching to work and am happy. I summarized the whole incident here:

http://nachtrab.de/2009/08/14/hp-dl160-g6-raid-controller-b110i-and-windows-2008-r2/


Short version of getting write-caching to work:
Use cp010232.exe from the HP homepage
Marcel_Brown
Advisor

Re: DL160 G6 Unable to use RAID before install OS

I've used sp44271 and sp44229 succesfully. Then I booted the server from my Win2008 CD. When using the 64 or 32bits regular driver from the HP site, it still says it can't find the hardware belonging to the driver.

What I do find strange that the message is that it needs a driver for cd cd/dvd. Is the message wrong or am I understanding it incorrect that it needs a driver for the CD/DVD player I'm using? That rather strange since Win2008 starts without problems from this DVD player.

What kind of media do you use? I use a sata DVD player. Do I need to use a USB DVD player?

Re: DL160 G6 Unable to use RAID before install OS

Be sure to use the 'embedded sata raid' driver, not the sas/sata one, check on whether you use x64 or x86, the unzip the driver and copy it to a usb stick (or cd).
Marcel_Brown
Advisor

Re: DL160 G6 Unable to use RAID before install OS

Yes I'm sure. Also used yours from the web X64. Did you use a USB DVD player for the install?

Re: DL160 G6 Unable to use RAID before install OS

I used a USB stick and Windows 2008 R2 x64
Marcel_Brown
Advisor

Re: DL160 G6 Unable to use RAID before install OS

Got it working now! It can't use the sata dvd player for the install. So bought an USB DVD player and Win2008 is finaly succesfuly installed.

Thanks you all!