ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL160 G6 cannot boot after install FC HBA

 
TLC06
Advisor

DL160 G6 cannot boot after install FC HBA

I have DL160 G6 installed with Windows 2003 server. It was working fine. After I install FC HBA Qlogic (FC1242SR 4Gb PCI-e), my system cannot boot. I also check the RBSU, I set the boot order to boot from smart array controller first. The system cannot boot to widows. Only the cursor blink at black screen.

When I plug out the FC HBA, windows server boot normally.

Can anyone tell what setting I might misconfigure? Thanks in advance.
3 REPLIES
MattLavallee2
Frequent Advisor

Re: DL160 G6 cannot boot after install FC HBA

Windows is looking for its system drive based on the controller ID; in all likelihood, your new controller took a lower ID (usually 0) that the existing SmartArray was using.

As wonky as it sounds, try moving the FC card to a different slot. Otherwise, you can edit boot.ini to point to a different controller ID (not recommended, but will work).

-Matt
TLC06
Advisor

Re: DL160 G6 cannot boot after install FC HBA

Yes, I also think that the FC controller has the higher boot priority than smartarray controller. The problem is I do not other slot to move. The FC HBA is plug to the single slot raiser card.

I tried to disable the Qlogic HBA card BIOS but still can't resolve the problem.

Today I found out when I unplug the FC HBA, I can see the system detect hard disk in boot order at BIOS setting. If I inserted the FC HBA, no hard disk.

Creek
Frequent Advisor

Re: DL160 G6 cannot boot after install FC HBA

I would suggest trying the 7/28/09 DL160 G6 BIOS, now available on hp.com. It resolves some issues around booting with certain FC cards installed.