ProLiant Servers (ML,DL,SL)
Showing results for 
Search instead for 
Did you mean: 

DL180 G5 firmware flash error on POST

Go to solution
Occasional Visitor

DL180 G5 firmware flash error on POST

Hi all.  I have a DL180 G5 box that I recently flashed to the latest firmware, it is now taking over 10 minutes to POST and during the process it shows Server Asset: (blank) and then Error below.  When it finally moves on from this, it displays a warning to update the lights out firmware to minimal of 3.11.  When I go to update using the LO100i update utility for DL180 G5 / ML150 G5 etc edRompaq boots however quickly fails shoung error 43 and error 38 "INTEL ARCHITECTURE NOT SUPPORTED" and then I cant do anything from here.  It seems to me like the board is bricked and I am completely exhausted hunting down potential solutions on the web to fix it.  I have re-flashed the motherboard to previous versions on several occasions, I have tried resetting the CMOS by holding down the CMOS button and removing the battery, I tried experimenting with a jumper that relates to 'BIOS' on the board.  I have looked for disaster recovery settings for the board however I cant seem to find any.


I think my only hope at this point is to consult this forum for possible solutions.  This motherboard is the same as used in the ML150 or the SE1101.  If anyone has any insight into this and is willing to help I would be very greatful.  I am willing to try about anything short of just scrapping the motherboard and potentially just having it happen again.

Occasional Visitor

Re: DL180 G5 firmware flash error on POST

OK all, so I managed to remedy my problem.  Let me start off by confessing something; I dont actually have a DL180 G5 box.  What I own is a secondhand SE1101 box (Yahoo's hand-me-downs).  It is effectively a DL180/ML150 mobo/system inside a 1U chassis and they are going for really *really* cheap ($200 2x Quad Core 16GB RAM cheap).


Anyhow, these boards have a set of dip switches that determine the identification of the motherboard and what family of firmware they can update to.  The custom made SE1101 SKU has pin 1 flipped on, with 2,3,4 off.  The configuration it comes with only allows one of the pci express expansion slots to function, the one with the large profile card.  This for me was not optimal.  Theres a reason they did this ofcourse, because the motherboard physically wasnt intended to have a low profile card anyways, and the riser kit from the DL160 chassis was totally not in-line with that slot, and the heatsink installed was so tall it made installing most cards impossible.  I found a way around the physical limitations involving thermal adhesive, flexible risers, and some low profile aluminum heatsinks.


So me being insane I got this great idea.  I decided to flip all the DIP switches to OFF to make the board recognize as a DL180 G5, and then the extra expansion slots suddenly worked, but the firmware wasnt hassle free after doing that, unsure exactly why buy fan speed was going full blast, some media failed to boot, other strange shenanigans.  So then I think to myself why not just upgrade the firmware to the one this board was supposed to have.  I go and do this, but I failed to notice you need to update the Lights-Out firmware first (seriously hp?  I know I do crazy things with my hardware but the BIOS update utility should warn you of that).  This resulted in the situation above.


It took a bus pirate attached to the pins of the BIOS chip to reprogram it with the SE1101 firmware that was compatible with the Lights-Out 3.02 firmware.  After installing the lights-out firmware first then the system rom, it worked like a charm and I now have both expansion slots going.  So let this be a warning to future ghetto-modders out there.  If you get the idea to do what I just did make absolutely sure lights-out is updated first.

Occasional Advisor

Re: DL180 G5 firmware flash error on POST

 Just today I discovered which are the proliant models that work with similar mother boards . My troubles are related to a SE1102 Proliant on which I'm not able to slow down the fans. At this time I was able only to disconnect the inlet thermal sensor obtaining a constant 8000-10000 rpms for the 4 fans (depending on the CPU temperature). Before doing this as soon as the room temperature increased up to 24.5-25 °C, then the fans started increasing their speed going up to 14000 RPMs. Said that 8000-10000 rpms is better of 14000 rmps for my hears, I need to slowdown them more and more, I've read that someone have them running at 3000 rpms!!! I haven't LO100icard, I can only point to the server through the serial port and play some commands with BCM cli on a serial terminal (teraterm). I tried vSphere baremetal, Debian server plus HP-tools and every other ipmi utilities promising to let me controlling the bios and powerful setting in the hope to be able to find and set any kind of option fan related. But I get every time errors telling that the model is unsupported so Hponcfg, ipmi-tools, and so on don't work for me. I decided to upgrade the firmware with a new compatible bios so I searched for similar motherboards and found ML150 G5 at the first and then DL180 G5.  I downloaded their bioses and tried to flash them without results, I get error of unsupported model. Yesterday night I tried to change switch setting obtaining an automated flash of new a new bios (I think it is stored somewhere into the board may be for emergency autorepair). Trying different combinations of the four switches, I found that all combinations load the O31 ROM ID BIOS, one combination (off, off, off, off) loads the O32 ROM ID BIOS, but the server coudn't startup telling about a FAN4 error and shooting down the machine in 6 seconds. My BCM ROM is flashed at the latest ROM found: the 3.20, but I'm not able to flash the DL180 BIOS because the server turnes off at this switches combination, and for the working ones the bios is incompatible for the ROMPAQ.EXE flash utility


HOW did you upgraded the system BIOS please? ROMPAQ.EXE lacks the "FORCE" option   :-(   :-(  :-(


 I decompressed the ML150 G5 and DL180 G5 respective bioses and THEY ARE IDENTICAL, so the problem is to force ROMPAQ.EXE utility to flash the bios. I would like also to save the original O31 ROM ID BIOS, but I can't dump it with any utility or ROMPAQ.EXE or through serial connection (only flash but I  don't know how to send the firmware to the serial port, because the CLI "load" command acceptes bios images from tftp sources only).


unfortunatelly you probably won't read this question, but may be that others users will read it  and could aswer to me THANKS IN ADVANCE