ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

Re: DL20 install OS on M.2 NVME

 
SOLVED
Go to solution
marcellinus
Occasional Contributor

DL20 install OS on M.2 NVME

Hi

I have a new DL20 GEN10 Server and installed an internal M.2 NVME Drive. The drive is shown in BIOS and in SmartStorage Administrator.

How can I install an operatin system on this NVME? It does not show up in Intelligent Provisioning.

Any help is apreciated!

Kind regards

Marcellinus

9 REPLIES 9
sudhirsingh
HPE Pro
Solution

Re: DL20 install OS on M.2 NVME

Hi,

M.2 drives are managed through software raid (S100i), 

I believe you need to boot with OS media directly and install Operating system.

You may need to provide S100i driver incase drive does not detect while booting with OS Media.

S100i driver:

https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_5b8eac1a8fe144b4ae4f537c75#tab-history

 

If you feel this was helpful please click the KUDOS! thumb below!

Regards,

Sudhir

I work for HPE
Accept or Kudo

marcellinus
Occasional Contributor

Re: DL20 install OS on M.2 NVME

Hi

thank you for the reply. I just found out that it worked to install booting from the Installation Media. However, this was confusing as I normally provision all servers with Intelligent Provisioning and not booting from installation media directly.

Kind regards

Marcellinus

MadsHaugaard
Occasional Collector

Re: DL20 install OS on M.2 NVME

Hello @marcellinus 

How did you solve this issue?

I'm having problems booting to USB drive, with the OS install media.
Choosing "One-Time boot menu" does not work with UEFI, and enabeling Legacy mode works but disables the option to install to NVME because it disables SW raid.
What do I do?

mysy
Valued Contributor

Re: DL20 install OS on M.2 NVME

I think he talk about m.2 NVME SSD card, not m.2 SATA SSD card  ,the m.2 slot. Not the sata one. I read it was PCIE device ,not use S100i to control.

MadsHaugaard
Occasional Collector

Re: DL20 install OS on M.2 NVME

Well i figures it out anyways.
I had problems installing on the onboard M.2 slot. (The one where you also can install a dedicated iLO expansion board.
But I figured it out, reformatting my USB install media to FAT32 and making in able to install in UEFI.

Now the only problem I have is that the fans run 100% no matter what, and I haven’t figured out yet what to do about that.

Med venlig hilsen

Mads Haugaard
mysy
Valued Contributor

Re: DL20 install OS on M.2 NVME

I have the install nvme card and fans run 85% issue too...

MadsHaugaard
Occasional Collector

Re: DL20 install OS on M.2 NVME

Do you have The dedicated iLO port/nvme expansion installed?
mysy
Valued Contributor

Re: DL20 install OS on M.2 NVME

I install the nvme SSD to mainboard m.2 slot directly. My DL20 don't have the dedicated iLO module.

 

MadsHaugaard
Occasional Collector

Re: DL20 install OS on M.2 NVME

@marcellinus 

What drive did you use?
Did you install it in the M.2 NVMe slot directly or did you use the dedicated iLO/Serial/M.2 card?
Does your fans run at 100%?