ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL320 G4 image recovry problem

Jourj
Occasional Visitor

DL320 G4 image recovry problem

I took an image successfully for HP DL320 G4 server which has two hard drive in a mirror array, using acronis true image 9.1 enterprise version, but when I try to recover it, it says the image was successfully recoverd but when I boot the system it does not work. and I think that is due to the raid array, because it sees two hard drives instead of one, and I do not think it recognize the array so any solution for this problem?
10 REPLIES
chongkan
Trusted Contributor

Re: DL320 G4 image recovry problem

Maybe what you have to do is:

1- Configure the RAID 1 firts so teh OS will see only one empty drive.

2- Restore the image in that logical drive.

Regards
Jourj
Occasional Visitor

Re: DL320 G4 image recovry problem

there is no operating system present, how would you configure the raid array anyway
chongkan
Trusted Contributor

Re: DL320 G4 image recovry problem

Go to RBUS and enable teh rAID capability, then reboot and press Control + A to enter the Rom BAsed Array configuration Utility, create the RAID and then Restore you drive.
Didata_1
Occasional Visitor

Re: DL320 G4 image recovry problem

Does anybody know whether I need to install any drivers in order to get Windows 2000 server to recognise the SATA Raid? I enable the RAID controller in bios (pressing F9) and then configure the RAID 1 by adding the two hard disks. When I go to install the Windows 2000 and it keep on saying there is no valid hard drive. What do I have to do?
Thanks in advance
nurascorpio
Regular Advisor

Re: DL320 G4 image recovry problem

Hi Jouri,

The process of enabling the embedded sata controller in DL320 G4 :

Access the RBSU by pressing F9.

Go to Advance Options.

Go to Embedded SATA RAID Controller.

Change it from Disable to Enable.

Press F10 to save the options.

Server will reboot.

At POST there will be a message to press F8 to access the Embedded RAID configuration

By Accessing Array configuration you can create Raid 1 or Raid 0

While installing windows 2000 , the F6 option to install the drivers for the SATA controller

http://h18007.www1.hp.com/support/files/server/us/download/23534.html

Or you can create the RAID in the OS using the HP Embedded SATA RAID Controller Managers for Windows.

http://h18023.www1.hp.com/support/files/server/us/download/22357.html

Hope this helps !

Jourj
Occasional Visitor

Re: DL320 G4 image recovry problem

I already tried configuring the array but still it does not work. what I am trying to do is not loading the OS, but I am trying to restore the system using an acronis true image file. so when I restor the image still sees two hard drives. so I tried to restor to one of the disks but still it does not work any sugestions?
RaMpaNTe
Trusted Contributor

Re: DL320 G4 image recovry problem

TRy creating the array first and then do the imaging.

Didata: Yes you need to install the drivers for W2K to recognize the logical drive, when installing windows, you need to press F6 to specify a 3rd party driver.
You heve a question... I have an aswer!!!
RGA
Occasional Advisor

Re: DL320 G4 image recovry problem

Jourj,

I don't have an answer for you but some questions. I do not know anything about Acronis True Image and how it works. But, my questions are:

1) When the software states that it writes the image successfully, what error message do you get when you try to boot the OS from the recovered image? Is there drive activity when Acronis is indicating it is writing to the drives? Can you boot to recovery console and run recovery console to see if there are any files on the HDD's..

2) Generally speaking most software are unaware that the HDDs are part of a Raid Set, Raid 1 in your case. Meaning generally the drive appears as a single HDD anyway, and software usually is unaware of how many drives are present.

If Acronis does see the physical HDDs and not the single logical then I would think the solution would be to create your original image from a Raid 0. Then you can recover the image back to a single HDD then add the second HDD and migrate if the DL320 G4 will allow Raid 0 to 1 migration. (Sorry haven't checked)

Again, I don't have the answers but hopefully some questions to lead to the solution.

Regards and good luck....
Jourj
Occasional Visitor

Re: DL320 G4 image recovry problem

the problem is solved; I built the array, then removed one hard drive physically, then recovered the image on one hard drive, then when the image is fully recoverd, I put back the other hard drive and rebooted, so the array starts to build automatically. so that was the solution. thanks anyway
chongkan
Trusted Contributor

Re: DL320 G4 image recovry problem

Nice!!