ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL320 G6 and VT-d - does anybody have this working?

underslung
Occasional Visitor

DL320 G6 and VT-d - does anybody have this working?

I'm trying to get VT-d working with Linux and so far have been unsuccessful. I've enabled it in the BIOS and the machine boots fine until I pass the intel_iommu=on parameter to the kernel via grub.  The machine will never fully boot and the console is filled with this:

 

DRHD: handling fault status reg 102

DMAR:[DMA Read] Request device [00:1e:0] fault addr e763e000

DMAR: [fault reason 06] PTE read access is not set

 

with the reg incrementing 2, 102, 202 etc. through 702 and then it starts over.  I then have to reset the box and disable VT-d in the BIOS to get it to boot again.  Changing intel_iommu to soft or igfx_off will allow the machine to boot but dmesg shows this for all the devices DMAR finds:

 

DMAR: Device scope device [0000:00:0a.00] not found

 

I've tried three different Linux distros, all with the same results, as well as many of the intel_iommu and iommu kernel parameters. Next step is to pull the SCSI card, but since that's what I want to pass through to the VM, that kinda defeats the purpose.

 

Has anybody figured out how to get this to work on this platform with Linux?

 

            thanks--

 

                         --jim

 

 

2 REPLIES
Suman_1978
HPE Pro

Re: DL320 G6 and VT-d - does anybody have this working?

Hi,

 

What is the linux flavor you are trying and what is the bios version on the server?

 

Some tips:

Have you tried installing Windows OS with VT-d enabled on this server?

Can you try updating the BIOS on this server and then install Linux with VT-d?

Also try with minimum DIMM modules with Add-On cards removed if any.

 

Thank You!
I am a HP employee.

underslung
Occasional Visitor

Re: DL320 G6 and VT-d - does anybody have this working?

 

Sorry, I should have mentioned that the BIOS and firmware are all updated to the latest available.  The BIOS is 2012.12.02.  The three Linux flavors I tried were Proxmox (debian-based), Ubuntu 12.04, and CentOS 6.4.  No, I haven't tried Windows, nor do I have any real intention to.  This server's going to run Linux and I was hoping to be able to passthrough a PCIe SCSI card to a guest KVM OS. 

 

I get the same behavior with only two RAM sticks installed and the SCSI card removed.