ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL320 cannot load NW6 - no HDD detected

Cameron Todd
Regular Advisor

DL320 cannot load NW6 - no HDD detected


I am trying to install NetWare 6 on a DL320 server (PIII) and there seems to be a problem in that during the 'detect devices' phase the inbuilt ATA/IDE harddisk is not found despite it being fine at boot time (ie BIOS detects drive ok) and also within DOS.

The CD drive which is on the secondary channel of the same Ultra-100 adaptor appears ok.

Specifically the error is like "no storage device was detected in this system. Please load correct driver (HAM)", however, the Ultra-100 ATA host adaptor detects fine as "IDEATA, IDEATA" (.HAMs for both channels) but the actual HDD device is not detected and the CD-drive is, therefore the next setup screen shows "IDECD" only (for the .CDM file; plus a couple of "N100" NIC's; but no expected "IDEHD") and due to no storage adaptor being detected the install process halts permanently.

I haven't found any info of use on either the Novell or HP website knowledgebases, and having struck a problem in the past where the Netware HDD driver would not install on a Compaq product and determining that the jumper setting on the HDD being on "CS" instead of "Master" was the fault, I duly followed the same procedure in this case, however, to my surprise the HDD still isn't detected by the NetWare installer.

Any ideas on why the HDD cannot be found?

I ran Compaq SmartStart CD V5.5 but it doesn't list specific NetWare drivers nor has an option for preparing the HDD for installing any version of NetWare.
(strange - NetWare is too universal to not be supported)

The HDD is a Seagate Barracuda, not that that should be of relevance. A vanilla NetWare driver should detect any generic IDE device!?


5 REPLIES
JohnWRuffo
Honored Contributor

Re: DL320 cannot load NW6 - no HDD detected

Cameron:

When the server boots up... go into the RBSU (Hit F9) and make sure you have:

A: Selected Novel as the O/S
and;
B: Selected the IDE controller as the Primary Boot Controller in the boot order.

Hope this helps! -John
Enjoy!
__________________________________________
Was the post useful? Click on the white KUDOS! Star.

Do you need help with your HP product?
Try this: http://www.hp.com/support/hpgt
Cameron Todd
Regular Advisor

Re: DL320 cannot load NW6 - no HDD detected

I rechecked the RBSU and there is no 'Netware' option - only 'Win NT4', 'Win 2000', 'Linux', 'Solaris' and 'Other', to which I selected the latter originally.

The Ultra 100 IDE controller is set as the first boot controller.

PS. I didn't mention above that had loaded a Proliant SUpport Pack for NetWare from the SmartStart V5.5 CD and these drivers had no effect, and also found a Compaq Ultra-100 driver update on their website (cp003765.nlm) but being an NLM it won't load that early in the process without an ABend anyway.

Would there be a ROM BIOS update for the DL320's to support NetWare? (funny that even Netware 5.x wasn't an option !?)
SAKET_5
Honored Contributor

Re: DL320 cannot load NW6 - no HDD detected

Hi Cameron,

Just looking at the HP web site for downloading drivers and BIOS for Proliant DL320 server, I could not find an option to download the software for Novell OS. Could you confirm that the server is actually supported for this OS?

The latest BIOS for Proliant DL320 that I found on the HP web site is 11/15/2002 available for download at
http://h18023.www1.hp.com/support/files/server/us/locate/20_1234.html

You could try updating the BIOS and then getting into BIOS to see if you can select the default OS type to be NW.

Hope this helps and don't forget to assign points:)

Good luck.

Cameron Todd
Regular Advisor

Re: DL320 cannot load NW6 - no HDD detected

Yes, I have already updated to the latest BIOS (11/15/2002) yesterday and when that didn't change anything (including the option of selecting NetWare) I firstly removed the Seagate drive in favour of a Maxtor, in case there was some sort of encoding on the disk the install process couldn't reinitialize and then I did a full system reset (NVRAM, HDD's etc) to begin the server configuration from scratch using the SmartStart v5.5 CD.

Unfortunately, even with a brand new Compaq System Partition configured for NetWare 6 (via the SmartStart process) the manual install of NetWare failed at the loading of a NetWare driver for the storage device, as always.

Note that SmartStart V6 brings up a setup GUI which indicates that there are no bootable drives on the Primary Controller (regardless of which HDD was in which controller position each attempt) so am wondering if something is misconfigured hardware-wise, since even if this platform was somehow not compatible with NetWare OS (unlikely!) then Compaq's own setup utlities should be able to report there being a non 0Mb HDD connected to it's own brand controller!

PS. Don't forget that the HDD boots fine into DOS and looks a perfectly healthy C: drive. The NetWare install itself has no problems whatsoever copying the preinstall files there too. The unit previously has had Windows and Linux on it, so originally suspecting that the Linux boot loader was causing problems I had done an FDisk /MBR, but this had made no difference either.


Any more ideas?
Cameron Todd
Regular Advisor

Re: DL320 cannot load NW6 - no HDD detected

Success!

The solution was not loading older version IDEATA HAMs and CDM's (as a Novell TID suggested for a Proliant 5500 exhibiting similar symptoms for NW6 upgrade) but loaded the *latest* versions from the Novell website.
I downloaded the latest IDEATA.HAM, IDECD.cdm and IDEHD.CDM from the supported device driver page
http://developer.novell.com/devres/storage/drivers/index.html#Novell
and loaded these into c:\nwupdate, and finally both HDD and CD devices were autodetected and loaded fine.

Still don't know why the Compaq utils themselves were having problems but at least my OS problem is solved.

thanks for the input.

Cameron.