ProLiant Servers (ML,DL,SL)
cancel
Showing results for 
Search instead for 
Did you mean: 

DL360 G2 cannot reboot to HD after running diskpart and format.

 
Tony Lie
Occasional Contributor

DL360 G2 cannot reboot to HD after running diskpart and format.

Hi All,

I posted this on the Proliant provisioning section but there hasn't been any answer yet, so I hope someone here can help me solve the mistery.

After running winnt32.exe and reboot, Proliant DL360 G2 and G3 get stuck at "Attempting to boot to HD."
I hope someone can help me solve this problem. Thanks in advance.

Background info:
I created a WinPE CD that does the unattended W2K3 installation. I do not use any SSTK for Win32.

I created a VB executable that lets an installer to choose OS, Windows components, and partition size. Based on the input, the executable then creates the unattend.txt and input file(s) for diskpart to create partition(s).

The installation steps as follow:
1. Create partition using diskpart based on input file(s). One input file per partition. For sure it will create at least one partition.
The input file for the first partition:
select disk 0
create partition primary size=12000
assign letter c
select partition 1
active
exit

Step 1 is successful as I can see the partition using diskpart and it is active.

2. Format partition 1:
format c: /fs:NTFS /v:SYS /q /y
Format is also successful as I can see the C drive and its correct size. Note, the format is performed without rebooting after Step 1.

3. Copy proper Proliant files and folders to $OEM$ folder.

4. Copy I386 folders.

5. Run winnt32.exe.
winnt32.exe /unattend:c:\unattend.txt /syspart:c: /tempdrive:c /noreboot.

Steps 1 - 5 run successfully because all files are copied to C: and winnt32.exe runs ok.

Now when the Proliant DL360 G2 reboots after the winnt32 finishes, the server cannot pass beyond the "Attempting to boot to HD" message. The cursor just stop below the message. There is no error message or anything.

I used the same method on a DL560 G3 and a workstation class machine, it rebooted to C: without problem and continue with the text mode portion of the setup.

My colleague and I did some testing on the DL360 G2. We performed the diskpart step manually and rebooted to WinPE CD. Then we formatted the drive. It could reboot to C: and continued with the text mode portion of the setup. However if we formatted partition 1 without rebooting the server after diskpart, we could not boot to C:. I don't understand why reboot seems to make it to work.

We did the same testing on DL560 G3 and we could not reproduce the problem on this server. On the DL560 G3, we formatted partition 1 without rebooting after running diskpart and the server rebooted to C: without problem.

Both server used the onboard smart array 5i controller.

I would really appreciate it if someone can tell me why a reboot is needed after running diskpart on DL360 G2.

Thanks.
-Tony
1 REPLY
Chris Higgins_5
Occasional Visitor

Re: DL360 G2 cannot reboot to HD after running diskpart and format.

Hello, I too had the same problem and called MS. It appears that if an existing partition is found on the disk, that unless you clean the disk, the result is a unbootable disk.

Hope this helps